Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

'Javascript required' message keeps me out of Facebook.

  • 4 risposte
  • 1 ha questo problema
  • 2 visualizzazioni
  • Ultima risposta di Tommy

more options

After downloading a number of Firefox apps I went to Facebook but got a JavaScript required message. I updated the java script, enabled it, restarted it but keep getting the same message. I even installed a new Firefox Browser but no change. What don't I know?

Soluzione scelta

JavaScript is builtin and there is no need to update JavaScript. It is more likely that you have some content blocking extension that is causing this issue.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (4)

more options

Soluzione scelta

JavaScript is builtin and there is no need to update JavaScript. It is more likely that you have some content blocking extension that is causing this issue.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a blueish highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check in the Web Console what content is blocked.

more options

Hello russcrawfordsc, I understand your problem where Javascript is disabled unintentionally for Facebook. You should see the javascript.void(0) on the bottom left. One way to fix that is to clear cache (Ctrl+Shift+Delete) then select the time range to delete. Click on all the little boxes and then, click okay. Below is a Screen Shot of what it should look like: Tell me if that helped and Stay Safe!

more options

Tommy said

You should see the javascript.void(0) on the bottom left.

Seeing that when you hover a link actually does not indicate that JavaScript is disabled. It indicates that the page author has bypassed the usual behavior of a link and attached a script to it. For example:

<a href="javascript:void(0);" onclick="myscript();">Run my script</a>

(To see the real code of the link, right-click it and choose Inspect Element. That will open the Page Inspector and show you the HTML of that element.)

more options

Oh wow! Your the real professional here @jscher2000