Search Support

Webpage errors out with "Error SSL_ERROR_RX_RECORD_TOO_LONG", but works in Private Browsing?

  • 5 risposte
  • 1 ha questo problema
  • 64 visualizzazioni
  • Ultima risposta di FredMcD

more options

A webpage on our internal company domain ("") errors out with "Error SSL_ERROR_RX_RECORD_TOO_LONG". If I switch to private browsing the same page works. The page also works with all other browsers without issue. If I "reset firefox", the page starts working again - even after firefox sync has re-installed all my add-ons. After some indeterminate amount of time (weeks) the page starts to error out again. This problem occurs on Firefox 75 on Ubuntu 18.04 as of now.

I'm at a total loss as to how to even begin to debug this - any pointers on where to start looking? As I mentioned the webpage that errors out the only page on an intranet so I cannot share the URL.

All Replies (5)

more options

‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’
Internet search; More often than not, you have something misconfigured!

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Thank you @Fred! so far:

1. Disabling hardware acceleration did not help. 2. Disabling Addon's did not help but I was about halfway through that process when (for unrelated reasons) I had to clear cache+cookies and *Apparently* that solved the problem.

However, I know that this issue keeps coming back *only* only this one profile of Firefox so I will test again when the problem resurfaces (as it no doubt will) and update this post / thread.

Helpful?

more options

Good luck.

Helpful?

more options

Update and notes: 1. The problem reappeared after 1 week. 2. The problem disappears if I "Clear All History" (Alt+Ctrl+Del), select time=everything and check all boxes *including* Site Preferences. "Site preferences" must be checked for this fix to work.

Conclusions: None of the addons are an issue. As a result it appears that the intranet site sets some preferences for secure connections or something related, which becomes invalid after some days.

Next task is to figure out exactly which site preference is causing the problem and whether is it a problem with the site or with firefox.

Helpful?

more options

Helpful?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.