X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Performing TLS Handshake slowdowns

Inserita

Recently Firefox has become nearly unusable. Opening links are *_sluggish_*... They eventually complete but it's annoying - I've switched back to brave for now. https://support.mozilla.org/en-US/questions/1175357 seems to be the exact same issue however nothing in the thread resolved my problem.

I'd like to stay with Firefox but it's not worth it at this time. :(

Any thoughts/help are much appreciated.

Recently Firefox has become nearly unusable. Opening links are *_sluggish_*... They eventually complete but it's annoying - I've switched back to brave for now. https://support.mozilla.org/en-US/questions/1175357 seems to be the exact same issue however nothing in the thread resolved my problem. I'd like to stay with Firefox but it's not worth it at this time. :( Any thoughts/help are much appreciated.

Soluzione scelta

I ended up uninstalling firefox... i moved away all the folders in %APPDATA% that pertained to Firefox and reinstalled firefox...

It seems to have 'fixed' the issue which is both great and not-great (since we didn't get to the bottom of it).

Thanks to both of you for trying...

Leggere questa risposta nel contesto 0
Citazione

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Ulteriori informazioni

FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte

That is a very old post.

Please provide a public link (no password) that we can check out. No Personal Information Please !


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

That is a very old post. Please provide a public link (no password) that we can check out. '''No Personal Information Please ! ''' -------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Thanks for looking. Yes, I agree that it's an old post. I didn't find anything more recent but I also didn't want people to ask if I've searched the forum for my answer already- I have.

your response confuses me. What sort of 'link' are you looking for when you wrote:

> Please provide a public link (no password) that we can > check out. No Personal Information Please !

I had disabled all extensions and plugins before and that didn't seem to make a difference. I also remade my whole firefox profile to no avail...

Your suggestion to start in safe mode does seem to make a difference. I started into safe mode and did some quick testing and the issue doesn't seem to be there. I can still catch the "TLS Handshake" on some sites but in general I'd say the performance is reasonable and any slow downs are hard/impossible to detect.

Thanks for looking. Yes, I agree that it's an old post. I didn't find anything more recent but I also didn't want people to ask if I've searched the forum for my answer already- I have. your response confuses me. What sort of 'link' are you looking for when you wrote: > Please provide a public link (no password) that we can > check out. No Personal Information Please ! I had disabled all extensions and plugins before and that didn't seem to make a difference. I also remade my whole firefox profile to no avail... Your suggestion to start in safe mode does seem to make a difference. I started into safe mode and did some quick testing and the issue doesn't seem to be there. I can still catch the "TLS Handshake" on some sites but in general I'd say the performance is reasonable and any slow downs are hard/impossible to detect.
È stato utile questo messaggio?
Citazione
FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte

I was asking about the link you are having problems with. Or is the problem with many websites?

dovholuk said

Your suggestion to start in safe mode does seem to make a difference

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

I was asking about the link you are having problems with. Or is the problem with many websites? ''dovholuk [[#answer-1297647|said]]'' <blockquote> Your suggestion to start in safe mode does seem to make a difference </blockquote> It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

> Or is the problem with many websites? oh yes - it's every website. even ones you'd expect to be fast like google sites, firefox's site, reddit, digg, any and ever site.

all my add-ons are currently disabled.

the only antivirus that runs is windows defender - i could disable that but i find it hard to believe it's windows defender

i'll disable hardware acceleration and restart firefox and hope that it solves this issue...

thanks for continued support

> Or is the problem with many websites? oh yes - it's every website. even ones you'd expect to be fast like google sites, firefox's site, reddit, digg, any and ever site. all my add-ons are currently disabled. the only antivirus that runs is windows defender - i could disable that but i find it hard to believe it's windows defender i'll disable hardware acceleration and restart firefox and hope that it solves this issue... thanks for continued support
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Here's a quick glimpse at one example that's actually "not the worst i've seen". I don't know what "blocked" means other than perhaps there are too many outstanding http requests and you can see the "TLS setup" took 3.57s. That's probably 5-10x of what it should be.

Here's a quick glimpse at one example that's actually "not the worst i've seen". I don't know what "blocked" means other than perhaps there are too many outstanding http requests and you can see the "TLS setup" took 3.57s. That's probably 5-10x of what it should be.
È stato utile questo messaggio?
Citazione
FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte

Blocked means that an element of a page or the page itself is not allowed thru. This can be caused by adblockers, anti-virus, system settings, your ISP . . . .

Blocked means that an element of a page or the page itself is not allowed thru. This can be caused by adblockers, anti-virus, system settings, your ISP . . . .
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Ok - I don't believe any of these things are my particular issue given other browsers work fine. I find it very interesting that the reported 'blocked' time is almost identitcal to the reported 'TLS setup' time.

I similar results (different timings) for all these other pages. Sometimes the reported times are lower, sometimes much, MUCH higher.

Looking at it in wireshark I can clearly see long delays in some requests during the TLS handhake process which. Why only in Firefox - I have no clue...

I guess I don't know what to do... Should I try to file a bug for this - or should I just switch away from Firefox and come back after a few updates? I am just at a loss for how to go forward.

Is there any chance this could be due to Firefox's attempts to block trackers? During some of my looking in 'developer tools' I can see a whole bunch of "This URL matches a known tracker and it would be blocked with Content Blocking enabled"

I appreciate your continued engagement.

Ok - I don't believe any of these things are my particular issue given other browsers work fine. I find it very interesting that the reported 'blocked' time is almost identitcal to the reported 'TLS setup' time. I similar results (different timings) for all these other pages. Sometimes the reported times are lower, sometimes much, MUCH higher. Looking at it in wireshark I can clearly see long delays in some requests during the TLS handhake process which. Why only in Firefox - I have no clue... I guess I don't know what to do... Should I try to file a bug for this - or should I just switch away from Firefox and come back after a few updates? I am just at a loss for how to go forward. Is there any chance this could be due to Firefox's attempts to block trackers? During some of my looking in 'developer tools' I can see a whole bunch of "This URL matches a known tracker and it would be blocked with Content Blocking enabled" I appreciate your continued engagement.
È stato utile questo messaggio?
Citazione
FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte

I called for more help.

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

If the data is too big, do not worry. It's the top part we need to look at.

This will show us your system details. No Personal Information Is Collected.

I called for more help. Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' If the data is too big, do not worry. It's the top part we need to look at. This will show us your system details. '''No Personal Information Is Collected.'''
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Here you go:

Application Basics


Name: Firefox Version: 74.0 Build ID: 20200309095159 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0 OS: Windows_NT 10.0 Launcher Process: Enabled Multiprocess Windows: 1/1 Enabled by default Remote Processes: 6 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Found Safe Mode: false

Crash Reports for the Last 3 Days


Firefox Features


Name: DoH Roll-Out Version: 1.3.0 ID: doh-rollout@mozilla.org

Name: Firefox Screenshots Version: 39.0.0 ID: screenshots@mozilla.org

Name: Form Autofill Version: 1.0 ID: formautofill@mozilla.org

Name: Web Compat Version: 7.0.0 ID: webcompat@mozilla.org

Name: WebCompat Reporter Version: 1.1.0 ID: webcompat-reporter@mozilla.org

Remote Processes


Type: Web Content Count: 3 / 8

Type: Extension Count: 1

Type: Privileged About Count: 1

Type: GPU Count: 1

Extensions


Name: Amazon.com Version: 1.1 Enabled: true ID: amazondotcom@search.mozilla.org

Name: Bing Version: 1.1 Enabled: true ID: bing@search.mozilla.org

Name: DuckDuckGo Version: 1.0 Enabled: true ID: ddg@search.mozilla.org

Name: eBay Version: 1.0 Enabled: true ID: ebay@search.mozilla.org

Name: Google Version: 1.0 Enabled: true ID: google@search.mozilla.org

Name: Twitter Version: 1.0 Enabled: true ID: twitter@search.mozilla.org

Name: Wikipedia (en) Version: 1.0 Enabled: true ID: wikipedia@search.mozilla.org

Name: Cisco Webex Extension Version: 1.5.0 Enabled: false ID: ciscowebexstart1@cisco.com

Security Software


Type: Windows Defender Antivirus

Type:

Type:

Graphics


 -- snipped by me --

if you need / want the rest i can post to postbin or something

Here you go: Application Basics ------------------ Name: Firefox Version: 74.0 Build ID: 20200309095159 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0 OS: Windows_NT 10.0 Launcher Process: Enabled Multiprocess Windows: 1/1 Enabled by default Remote Processes: 6 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Found Safe Mode: false Crash Reports for the Last 3 Days --------------------------------- Firefox Features ---------------- Name: DoH Roll-Out Version: 1.3.0 ID: doh-rollout@mozilla.org Name: Firefox Screenshots Version: 39.0.0 ID: screenshots@mozilla.org Name: Form Autofill Version: 1.0 ID: formautofill@mozilla.org Name: Web Compat Version: 7.0.0 ID: webcompat@mozilla.org Name: WebCompat Reporter Version: 1.1.0 ID: webcompat-reporter@mozilla.org Remote Processes ---------------- Type: Web Content Count: 3 / 8 Type: Extension Count: 1 Type: Privileged About Count: 1 Type: GPU Count: 1 Extensions ---------- Name: Amazon.com Version: 1.1 Enabled: true ID: amazondotcom@search.mozilla.org Name: Bing Version: 1.1 Enabled: true ID: bing@search.mozilla.org Name: DuckDuckGo Version: 1.0 Enabled: true ID: ddg@search.mozilla.org Name: eBay Version: 1.0 Enabled: true ID: ebay@search.mozilla.org Name: Google Version: 1.0 Enabled: true ID: google@search.mozilla.org Name: Twitter Version: 1.0 Enabled: true ID: twitter@search.mozilla.org Name: Wikipedia (en) Version: 1.0 Enabled: true ID: wikipedia@search.mozilla.org Name: Cisco Webex Extension Version: 1.5.0 Enabled: false ID: ciscowebexstart1@cisco.com Security Software ----------------- Type: Windows Defender Antivirus Type: Type: Graphics -------- -- snipped by me -- if you need / want the rest i can post to postbin or something
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Here's another recent clip from developer tools...

I then did a "ctrl-f5" on https://support.mozilla.org/en-US/ and here's a capture of that...

Here's another recent clip from developer tools... I then did a "ctrl-f5" on https://support.mozilla.org/en-US/ and here's a capture of that...
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I know I'm 'bumping' this thread - sorry. I don't want to do it too much but I'd also like to keep using Firefox but it's reliant on solving this issue...

Thanks again for all the help thusfar.

I know I'm 'bumping' this thread - sorry. I don't want to do it too much but I'd also like to keep using Firefox but it's reliant on solving this issue... Thanks again for all the help thusfar.
È stato utile questo messaggio?
Citazione
Roland Tanglao
  • Administrator
78 soluzioni 854 risposte

Hi dovholuk

You wrote:

"Your suggestion to start in safe mode does seem to make a difference. I started into safe mode and did some quick testing and the issue doesn't seem to be there. I can still catch the "TLS Handshake" on some sites but in general I'd say the performance is reasonable and any slow downs are hard/impossible to detect."

Firefox works in Firefox Safe mode therefore I am going to suggest what Fred already suggested :-) : "If your problem did not occur in Safe Mode, the likely cause is an extension, theme or hardware acceleration. Continue following the steps in this article to determine whether one of these is the problem. "

Please try the suggestions in the following article which the above quote is from (I think you tried turning hardware acceleration off but it's unclear if you did and what the results were):

https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_the-problem-does-not-occur-in-safe-mode

Cheers! ...Roland

Hi dovholuk You wrote: "Your suggestion to start in safe mode does seem to make a difference. I started into safe mode and did some quick testing and the issue doesn't seem to be there. I can still catch the "TLS Handshake" on some sites but in general I'd say the performance is reasonable and any slow downs are hard/impossible to detect." '''Firefox works in Firefox Safe mode therefore I am going to suggest what Fred already suggested :-) :''' "If your problem did not occur in Safe Mode, the likely cause is an extension, theme or hardware acceleration. Continue following the steps in this article to determine whether one of these is the problem. " Please try the suggestions in the following article which the above quote is from (I think you tried turning hardware acceleration off but it's unclear if you did and what the results were): https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_the-problem-does-not-occur-in-safe-mode Cheers! ...Roland

Modificato da Roland Tanglao il

È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I Thought that the steps Fred had me do were to avoid this confusion. Take note there are extensions that firefox ships with which i do not seem to be able to disable.

> Type about:support in the address bar and press Enter.

I provided that output. Let me follow the steps on the links and provide feedback:

Start Firefox in Safe Mode - done. seems to resolve the issue Turn off hardware acceleration - done. no difference Switch to the default theme - done. the default theme was already selected Disable all extensions - done. I have one extension and it has been disabled since I opened this ticket Updating extensions - done. no updates found Checking extension settings - no extensions are enabled. no options are to be tweaked

I went ahead and just flat out uninstalled the one extension that was installed (and reminder - disabled) - the Cisco webex extension. Perhaps just removing it is called for.

I'm also "hours" from just uninstalling firefox, cleaning any remants and reinstalling it to see if that "solves" the problem.

I Thought that the steps Fred had me do were to avoid this confusion. Take note there are extensions that firefox ships with which i do not seem to be able to disable. > Type about:support in the address bar and press Enter. I provided that output. Let me follow the steps on the links and provide feedback: Start Firefox in Safe Mode - done. seems to resolve the issue Turn off hardware acceleration - done. no difference Switch to the default theme - done. the default theme was already selected Disable all extensions - done. I have one extension and it has been disabled since I opened this ticket Updating extensions - done. no updates found Checking extension settings - no extensions are enabled. no options are to be tweaked I went ahead and just flat out uninstalled the one extension that was installed (and reminder - disabled) - the Cisco webex extension. Perhaps just removing it is called for. I'm also "hours" from just uninstalling firefox, cleaning any remants and reinstalling it to see if that "solves" the problem.
È stato utile questo messaggio?
Citazione
FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte
Use these links to create a new profile. Use this new profile '''as is. ''' Is the problem still there? https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type '''about:profiles'''<enter> in the address bar.
È stato utile questo messaggio?
Citazione

Soluzione scelta

I ended up uninstalling firefox... i moved away all the folders in %APPDATA% that pertained to Firefox and reinstalled firefox...

It seems to have 'fixed' the issue which is both great and not-great (since we didn't get to the bottom of it).

Thanks to both of you for trying...

I ended up uninstalling firefox... i moved away all the folders in %APPDATA% that pertained to Firefox and reinstalled firefox... It seems to have 'fixed' the issue which is both great and not-great (since we didn't get to the bottom of it). Thanks to both of you for trying...
È stato utile questo messaggio?
Citazione
FredMcD
  • Top 10 Contributor
4399 soluzioni 61752 risposte

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' as this can help others with similar problems.
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.