X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

New tab page (top sites page) is missing top margin (not centered vertically)

Inserita

Hello Mozilla fellows.

Yesterday a top margin of the "New tab" page ("top sites" etc. page) suddenly became missing (not centered vertically) in my Firefox 73.0. This page displays broken for any Firefox profile (for Firefox instances of other users of the same Windows), so resetting ("refreshing") Firefox is not a solution, and most simple Firefox reinstallation also did not help.

(I believe there are no screenshot needed here, as anybody knows what is a large top margin of a centered [div] entity, and how does its absence should look.)

My desktop AMD A6 computer where Firefox got this problem is maintained pretty "default" - Windows is strictly genuine out-of-the-box, there was no any errors caught of any custom settings invoked during any software installations, every software unit in Windows is free of charge (no stolen software at all), all hardware drivers are ok, desktop graphics are set to usual 1920x1080 32bpp Windows Aero, and I even did not use any realtime antiviruses for years. There are also no any add-ons\extensions\plugins\themes in Firefox, and no Flash or Java installed.

A similar question (№ 1268604) already exists here for a few months, but I decided to also begin a new thread for the issue, because the problem is quite sensitive for me - I do not want to reset entire PC to get rid of this tiny bug, even though I guess this would help a bit :)

Can anybody clearly explain me, what and why has changed in my Firefox files yesterday and how can I fix this by any obvious tiny configuration actions or something alike? I still believe that a solution different from complex hardcore action exists for my case :'/

Hello Mozilla fellows. Yesterday a top margin of the "New tab" page ("top sites" etc. page) suddenly became missing (not centered vertically) in my Firefox 73.0. This page displays broken for any Firefox profile (for Firefox instances of other users of the same Windows), so resetting ("refreshing") Firefox is not a solution, and most simple Firefox reinstallation also did not help. (I believe there are no screenshot needed here, as anybody knows what is a large top margin of a centered [div] entity, and how does its absence should look.) My desktop AMD A6 computer where Firefox got this problem is maintained pretty "default" - Windows is strictly genuine out-of-the-box, there was no any errors caught of any custom settings invoked during any software installations, every software unit in Windows is free of charge (no stolen software at all), all hardware drivers are ok, desktop graphics are set to usual 1920x1080 32bpp Windows Aero, and I even did not use any realtime antiviruses for years. There are also no any add-ons\extensions\plugins\themes in Firefox, and no Flash or Java installed. A similar question (№ 1268604) already exists here for a few months, but I decided to also begin a new thread for the issue, because the problem is quite sensitive for me - I do not want to reset entire PC to get rid of this tiny bug, even though I guess this would help a bit :) Can anybody clearly explain me, what and why has changed in my Firefox files yesterday and how can I fix this by any obvious tiny configuration actions or something alike? I still believe that a solution different from complex hardcore action exists for my case :'/

Soluzione scelta

Hi again Oleg D.

Somebody else found the bug for me and here it is (and it's fixed in Firefox 74):

https://bugzilla.mozilla.org/show_bug.cgi?id=1605975

Leggere questa risposta nel contesto 1
Citazione

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

Ulteriori informazioni

cor-el
  • Top 10 Contributor
  • Moderator
17774 soluzioni 160767 risposte

Risposta utile

They seem to have changed the margin on the main container from margin: auto to margin: 0 auto causing the top bottom centering to get lost. Only when I only leave the search bar visible I get a centered Firefox logo and search bar. As soon as I enable other items then the top margin is lost and the content gets aligned to the top (i.e. no margin-top).

You can see that if you open the Inspector.

They seem to have changed the margin on the main container from margin: auto to margin: 0 auto causing the top bottom centering to get lost. Only when I only leave the search bar visible I get a centered Firefox logo and search bar. As soon as I enable other items then the top margin is lost and the content gets aligned to the top (i.e. no margin-top). You can see that if you open the Inspector. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML
È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

cor-el said

They seem to have changed the margin on the main container from margin: auto to margin: 0 auto causing the top bottom centering to get lost. Only when I only leave the search bar visible I get a centered Firefox logo and search bar. As soon as I enable other items then the top margin is lost and the content gets aligned to the top (i.e. no margin-top). You can see that if you open the Inspector.

Hello Cor-el.

Thank you a lot for localizing the problem. The newtab page frontend is broken exactly as you said - the zero before auto is causing what I see. I tried to remove zero in Inspector, leaving only auto there, and the centering worked fine then.

You are also right that centering works when only search bar is enabled on the page, and does not work in all the other cases.

The question, nevertheless, is still open: on which side this bug appears to happen, how this can be fixed, and what I have to do myself O_o?

According to your remark, even full system reinstallation will not help, until Mozilla staff remove their nasty wrong zero from the code in the next version of Firefox? Or, maybe, it is still my small personal system failure - only one of several similar cases in the world - and I can manually remove the reason of the bug myself, not waiting for the whole Firefox to update?

Maybe the problem lives in my synchronization Firefox account, or maybe in Russian localization of Firefox? These are the last possible reasons I would suspect myself, but still I want to mention even this - as I already said, I badly need a solution for this broken internal css, because this bug is the only thing going wrong on my PC at present time, while I always loved some kind of pure perfection on my side of Web ^_^

''cor-el [[#answer-1289768|said]]'' <blockquote> They seem to have changed the margin on the ''main'' container from ''margin'': ''auto'' to ''margin'': '''''0 auto''''' causing the top bottom centering to get lost. Only when I only leave the search bar visible I get a centered Firefox logo and search bar. As soon as I enable other items then the top margin is lost and the content gets aligned to the top (i.e. no margin-top). You can see that if you open the Inspector. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML </blockquote> Hello Cor-el. Thank you a lot for localizing the problem. The newtab page frontend is broken exactly as you said - the zero before ''auto'' is causing what I see. I tried to remove zero in Inspector, leaving only ''auto'' there, and the centering worked fine then. You are also right that centering works when only search bar is enabled on the page, and does not work in all the other cases. The question, nevertheless, is still open: on which side this bug appears to happen, how this can be fixed, and what I have to do myself O_o? According to your remark, even full system reinstallation will not help, until Mozilla staff remove their nasty wrong zero from the code in the next version of Firefox? Or, maybe, it is still my small personal system failure - only one of several similar cases in the world - and I can manually remove the reason of the bug myself, not waiting for the whole Firefox to update? Maybe the problem lives in my synchronization Firefox account, or maybe in Russian localization of Firefox? These are the last possible reasons I would suspect myself, but still I want to mention even this - as I already said, I badly need a solution for this broken internal css, because this bug is the only thing going wrong on my PC at present time, while I always loved some kind of pure perfection on my side of Web ^_^
È stato utile questo messaggio?
Citazione
Roland Tanglao
  • Administrator
75 soluzioni 796 risposte

Risposta utile

HI cor-el and Oleg D

If you haven't already, cor-el please file a bug :-) and CC me (:roland)

I believe you both that it's a bug but I never really learned CSS and I don't really see the non centred broken-ness here but I'm sure it's obvious to folks who are designers!

Cheers!

...Roland

HI cor-el and Oleg D If you haven't already, cor-el please file a bug :-) and CC me (:roland) I believe you both that it's a bug but I never really learned CSS and I don't really see the non centred broken-ness here but I'm sure it's obvious to folks who are designers! Cheers! ...Roland
È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

Roland Tanglao said

HI cor-el and Oleg D. If you haven't already, cor-el please file a bug :-) and CC me (:roland). I believe you both that it's a bug but I never really learned CSS and I don't really see the non centred broken-ness here but I'm sure it's obvious to folks who are designers! Cheers! ...Roland

Thank you a lot for your kind reply, Roland. In addition to my past report, I can now also be sure that this is a bug on Firefox side, not on mine, because I have already seen the same new tab page behaviour in Firefox 73 installed on an other computer.

You are right that I have some web design skills enough to be sure that both "zero" and "auto" at once can not be a valid value of any CSS rule parameter. Anyway, there should be either "zero" or "auto", but not both. And I suppose that the correct value is actually "auto", not "zero", because the new tab page looks much better in this case, as it had been looking for months before.

''Roland Tanglao [[#answer-1291123|said]]'' <blockquote> HI cor-el and Oleg D. If you haven't already, cor-el please file a bug :-) and CC me (:roland). I believe you both that it's a bug but I never really learned CSS and I don't really see the non centred broken-ness here but I'm sure it's obvious to folks who are designers! Cheers! ...Roland </blockquote> Thank you a lot for your kind reply, Roland. In addition to my past report, I can now also be sure that this is a bug on Firefox side, not on mine, because I have already seen the same new tab page behaviour in Firefox 73 installed on an other computer. You are right that I have some web design skills enough to be sure that both "zero" and "auto" at once can not be a valid value of any CSS rule parameter. Anyway, there should be either "zero" or "auto", but not both. And I suppose that the correct value is actually "auto", not "zero", because the new tab page looks much better in this case, as it had been looking for months before.
È stato utile questo messaggio?
Citazione
Roland Tanglao
  • Administrator
75 soluzioni 796 risposte

Soluzione scelta

Hi again Oleg D.

Somebody else found the bug for me and here it is (and it's fixed in Firefox 74):

https://bugzilla.mozilla.org/show_bug.cgi?id=1605975

Hi again Oleg D. Somebody else found the bug for me and here it is (and it's fixed in Firefox 74): https://bugzilla.mozilla.org/show_bug.cgi?id=1605975

Modificato da Roland Tanglao il

È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

Hi, Roland.

Thank you, this is exactly what I needed ^_^ I hope now the issue is closed for me. Sorry that I did not examine the nightly build and other versions younger than 73. I was sure nobody would care for such a miniscule, so I just went here after a short googling ^_^

Hi, Roland. Thank you, this is exactly what I needed ^_^ I hope now the issue is closed for me. Sorry that I did not examine the nightly build and other versions younger than 73. I was sure nobody would care for such a miniscule, so I just went here after a short googling ^_^
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.