Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How can I stop Firefox from changing my default search engine? I DO NOT EVER WANT BING. Leave my choice of search engine alone!

  • 15 risposte
  • 11 hanno questo problema
  • 466 visualizzazioni
  • Ultima risposta di jscher2000

more options

When Firefox updates, it changes my search engine. I use Firefox for security purposes (although not as much anymore). Why would anyone in their right mind want to use Bing as their search engine? I don't want it EVER. Please let me know how to stop this from happening.

Tutte le risposte (15)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Bing “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Modificato da FredMcD il

more options

Thanks for the reply. That will stop it from happening on further updates? And even if so, why does Firefox even have any need to change MY choice of search engines on an update?

more options

Actually, none of the things that you suggested removing were there. Any further thoughts?

more options

I don't think Bing is the default anywhere in the world. However, if your default search engine is deleted or disabled, then potentially Firefox will fail over to the next one. Are other search engines being removed during updates?

Also, I think support has ended for Firefox 60.

more options

I'm using 60.6.2esr . I thought it was updating, but looking at the history, it shows that it hasn't updated since 6 May 2019. Unfortunately, I just clicked on the "check for updates" and it downloaded an update. I remeber now why I went back to 60. The current version slowed down my PC incredibly. I'll see how this works now, if noy good, I'll revert to 60 again and keep migrating everything to Brave. BTW, the only search engine I keep reverting to (in Firefox selections) is DuckDuckGo. Thanks!

more options

I can't get Bing off of Mozilla Firefox.

more options

Hi millerj, where is Bing showing up currently? For example:

  • Home page (initial page in a new window, Ctrl+n/Command+n)
  • New tab page (Ctrl+t/Command+t)
  • When searching from the address bar or other Firefox search bars
  • Somewhere else
more options

Thank you for writing. My problem was the homepage. Uninstalling & reinstalling Firefox may have solved my problem.

more options

I spoke too soon. Bing is back as my homepage. I know there's a way to create a different homepage.

more options

Hi millerj, check the setting:

How to set the home page

If it is a Custom home page set to Bing, that's easy to change.

If it says an extension is controlling your home page, you would disable or remove that extension on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

more options

I keep setting my preferred browser for Google and it keeps reverting to the default browse, Bing. I'm tired of this! None of the offered fixes helped. Maybe I have to go to another browser...

more options
more options

I had the same problem and none of the fixes worked. I thought I had malware or a virus, it was so frustrating. The fix was simple in the end. I navigated to page I wanted as my home page, in this instance, Google. I then dragged and dropped the page tab icon onto the home button, see attached image. I hope this works for you.

more options

Thanx for phrasing you issue like this, I'm sure it speaks for A LOT of us. As a feedback I have to mention that none of the above worked, while some of them were totally off topic!

more options

costislieros said

Thanx for phrasing you issue like this, I'm sure it speaks for A LOT of us. As a feedback I have to mention that none of the above worked, while some of them were totally off topic!

Hi costislieros, where is Bing showing up for you?

  • Home page (initial page in a new window, Ctrl+n/Command+n)
  • New tab page (Ctrl+t/Command+t)
  • When searching from the address bar or other Firefox search bars, searches go to Bing
  • When you are on Google's own site, searches are diverted to Bing
  • Somewhere else