X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

FF 70 breaks underlining

Inserita

Since updating to FF70, I've noticed that underlined text on websites is broken by punctuation marks or lower case letters with tails, e.g., p, g, y, etc. It didn't do this before. Hope this will be fixed soon!

Since updating to FF70, I've noticed that underlined text on websites is broken by punctuation marks or lower case letters with tails, e.g., p, g, y, etc. It didn't do this before. Hope this will be fixed soon!
Immagini allegate

Soluzione scelta

OK, you can revert this by flipping a pref on the about:config page.

  • layout.css.text-decoration-skip-ink.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Leggere questa risposta nel contesto 1
Citazione

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 32.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Ulteriori informazioni

cor-el
  • Top 10 Contributor
  • Moderator
17567 soluzioni 158887 risposte

No, this is a permanent change to give better visibility and readability to underlined text.

See the Release Notes under changed.

Readability is now greatly improved on under- or overlined texts, including links. The lines will now be interrupted instead of crossing over a glyph.
No, this is a permanent change to give better visibility and readability to underlined text. See the Release Notes under changed. <pre>Readability is now greatly improved on under- or overlined texts, including links. The lines will now be interrupted instead of crossing over a glyph. </pre> *https://www.mozilla.org/en-US/firefox/70.0/releasenotes/
È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17567 soluzioni 158887 risposte

Risposta utile

It looks rather weird if I deliberately try to break it :oops:

It looks rather weird if I deliberately try to break it :oops:
È stato utile questo messaggio? 1
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17567 soluzioni 158887 risposte

Soluzione scelta

OK, you can revert this by flipping a pref on the about:config page.

  • layout.css.text-decoration-skip-ink.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


OK, you can revert this by flipping a pref on the <b>about:config</b> page. *layout.css.text-decoration-skip-ink.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *https://support.mozilla.org/en-US/kb/about-config-editor-firefox ---- *https://developer.mozilla.org/en-US/docs/Web/CSS/text-decoration-skip-ink

Modificato da cor-el il

È stato utile questo messaggio? 1
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17567 soluzioni 158887 risposte
There is support to modify the offset and thickness of the underline, so websites can affect how it looks. ----- *https://developer.mozilla.org/en/Web/CSS/text-decoration-skip-ink *https://developer.mozilla.org/en/Web/CSS/text-decoration-thickness *https://developer.mozilla.org/en/Web/CSS/text-underline-offset

Modificato da cor-el il

È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Thanks as always cor-el, the config worked!

My eyesight's not great and I never had any problem reading uninterrupted underlined text, only small or irregular fonts or insufficient contrast (e.g., light text on a light background). But as soon as this change was implemented I noticed how weird/ugly it looked - weirder & uglier on text with more punctuation/glyphs and thicker underlining. This appears to me to be a bad 'fix' for a non-existent problem. I certainly think it would make more sense to make the default config setting false.

Then again, maybe it was more of an issue in some languages with a different alphabet...

Anyway, I'm glad I could at least change it back. The ugliness was almost enough to make me try another browser, and I've been a loyal FF user for pretty much as long as there's been a FF!

Thanks as always cor-el, the config worked! My eyesight's not great and I never had any problem reading uninterrupted underlined text, only small or irregular fonts or insufficient contrast (e.g., light text on a light background). But as soon as this change was implemented I noticed how weird/ugly it looked - weirder & uglier on text with more punctuation/glyphs and thicker underlining. This appears to me to be a bad 'fix' for a non-existent problem. I certainly think it would make more sense to make the default config setting false. Then again, maybe it was more of an issue in some languages with a different alphabet... Anyway, I'm glad I could at least change it back. The ugliness was almost enough to make me try another browser, and I've been a loyal FF user for pretty much as long as there's been a FF!

Modificato da cfcentaurea il

È stato utile questo messaggio?
Citazione
Larry 0 soluzioni 1 risposte

I'm glad I've found this thread, because nobody seems to be talking about it. The underlining break is confusing as heck to me when a single URL is underlined, and the breaks make it seem like there are several URLs.

Navigating to about:config?filter=layout.css.text-decoration-skip-ink.enabled and double clicking the option to set it to [false] fixed the problem for me.

It might seem like a catchy aesthetic to the developers, and maybe a large number of Firefox users, but it's confusing as heck to people with poor vision I think. It looks nice with my glasses, but without the glasses, I'm forced to squint at the text to see if there really is just one URL, or several (thanks to text that drills through the line).

Thanks for the solution, sorry for rambling. I love Firefox, keep up the awesome work everyone.

I'm glad I've found this thread, because nobody seems to be talking about it. The underlining break is confusing as heck to me when a single URL is underlined, and the breaks make it seem like there are several URLs. Navigating to '''about:config?filter=layout.css.text-decoration-skip-ink.enabled''' and double clicking the option to set it to ['''false'''] fixed the problem for me. It might seem like a catchy aesthetic to the developers, and maybe a large number of Firefox users, but it's confusing as heck to people with poor vision I think. It looks nice with my glasses, but without the glasses, I'm forced to squint at the text to see if there really is just one URL, or several (thanks to text that drills through the line). Thanks for the solution, sorry for rambling. I love Firefox, keep up the awesome work everyone.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Hi Larry I'm glad I'm not the only one! If you want to let FF know you don't like it, you can give feedback at https://qsurvey.mozilla.com/s3/FirefoxInput/

Hi Larry I'm glad I'm not the only one! If you want to let FF know you don't like it, you can give feedback at https://qsurvey.mozilla.com/s3/FirefoxInput/
È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17567 soluzioni 158887 risposte

It is possible via the offset pref to move the underline a few pixels downwards to avoid issues.

This might be sufficient to see the underline. text-underline-offset: .3em;

It is possible via the offset pref to move the underline a few pixels downwards to avoid issues. *https://developer.mozilla.org/en/Web/CSS/text-underline-offset This might be sufficient to see the underline. text-underline-offset: .3em;
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.