X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Why embedded YouTube videos are not playing?

Inserita

Embedded YouTube videos will not play in any website. It just shows image saying 'click here' which redirects to YouTube website to play it. Which plays fine.

Attached preview.

Embedded YouTube videos will not play in any website. It just shows image saying 'click here' which redirects to YouTube website to play it. Which plays fine. Attached preview.
Immagini allegate

Soluzione scelta

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

Leggere questa risposta nel contesto 1
Citazione

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 26.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Ulteriori informazioni

cor-el
  • Top 10 Contributor
  • Moderator
17564 soluzioni 158869 risposte

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/content-blocking ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

None of this help, I also get same issue on Developer Edition with no addons. Tracking is turned off, shield icon is crossed out.

It can be any link on any website, eg https://www.w3schools.com/html/tryit.asp?filename=tryhtml_youtubeiframe

Works fine on Chrome.

None of this help, I also get same issue on Developer Edition with no addons. Tracking is turned off, shield icon is crossed out. It can be any link on any website, eg https://www.w3schools.com/html/tryit.asp?filename=tryhtml_youtubeiframe Works fine on Chrome.
È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17564 soluzioni 158869 risposte

No problems here with playing the embedded video in that link in Firefox 70 with tracking protection enabled.

Are there any messages in the Web Console related to this issue?

  • "3-bar" menu button or Tools -> Web Developer
No problems here with playing the embedded video in that link in Firefox 70 with tracking protection enabled. Are there any messages in the Web Console related to this issue? *"3-bar" menu button or Tools -> Web Developer
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

Attached. But it has nothing to do with it, I don't get same errors in any other websites with embedded YouTube videos.

Someone has posted same issue with same message at https://stackoverflow.com/questions/58502467/the-embedded-player-shows-please-click-here-to-watch-this-video-on-youtube-to 3 days ago

Attached. But it has nothing to do with it, I don't get same errors in any other websites with embedded YouTube videos. Someone has posted same issue with same message at https://stackoverflow.com/questions/58502467/the-embedded-player-shows-please-click-here-to-watch-this-video-on-youtube-to 3 days ago

Modificato da rhazor il

È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I think you're lost.

(okay you removed your post who's gonna remove mine)

I think you're lost. (okay you removed your post who's gonna remove mine)

Modificato da rhazor il

È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17564 soluzioni 158869 risposte

Yes, that reply was meant for another tread, sorry about that.

I don't know why embedded vireos do not work for you. Since this affects Firefox DE as well that would suggest either some other (security) software on your computer or something with your connection (VPN, proxy, ISP)that is interfering. I don't know if blocking cookies or blocking the referrer can cause such issues.

Maybe try this in a new clean profile without modifications (do not use a refresh/reset).

Yes, that reply was meant for another tread, sorry about that. I don't know why embedded vireos do not work for you. Since this affects Firefox DE as well that would suggest either some other (security) software on your computer or something with your connection (VPN, proxy, ISP)that is interfering. I don't know if blocking cookies or blocking the referrer can cause such issues. Maybe try this in a new clean profile without modifications (do not use a refresh/reset). *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Unticking Cookies on Developer Edition fixes it but not on regular Firefox.

Last time I played with profiles I lost all my saved passwords and bookmarks.

Unticking Cookies on Developer Edition fixes it but not on regular Firefox. Last time I played with profiles I lost all my saved passwords and bookmarks.
È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17564 soluzioni 158869 risposte

What cookie settings are you unticking in DE ? Is this about third-party cookies ?

What cookie settings are you unticking in DE ? Is this about third-party cookies ?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Just that box attached in screenshot in previous post.

Just that box attached in screenshot in previous post.
È stato utile questo messaggio?
Citazione
smihiran98 1 soluzioni 9 risposte

Soluzione scelta

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

Click the menu button and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.
È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

I unchecked Recommended and it works now, but I don't understand why. Attached.

I unchecked Recommended and it works now, but I don't understand why. Attached.
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.