X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

firefox defaults to bing but returns no search results

Inserita

Firefox is my default browser but when I search it automatically changes to Bing. Today when I search, it is returning no results, just a blank page. Just tried Google Chrome - it works fine. My Firefox 'favourites' work but a new search results in the Bing blank page. Any ideas? Have checked default settings (yes for Firefox) and extensions/add-ons - only have an Iobit add-to block ads. Done a malware scan with no issues. No idea why it has changed today. Previously searches from Firefox - auto to Bing - but at least came up with some results.

Firefox is my default browser but when I search it automatically changes to Bing. Today when I search, it is returning no results, just a blank page. Just tried Google Chrome - it works fine. My Firefox 'favourites' work but a new search results in the Bing blank page. Any ideas? Have checked default settings (yes for Firefox) and extensions/add-ons - only have an Iobit add-to block ads. Done a malware scan with no issues. No idea why it has changed today. Previously searches from Firefox - auto to Bing - but at least came up with some results.
Immagini allegate

Modificato da wendyjlang il

Citazione

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 32.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Ulteriori informazioni

FredMcD
  • Top 10 Contributor
4248 soluzioni 59425 risposte

Is Bing your default search engine?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Is Bing your default search engine? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
È stato utile questo messaggio? 0
Citazione
jscher2000
  • Top 10 Contributor
8699 soluzioni 71101 risposte

Hi wendyjlang, you might have noticed the address bar on your search results page contains a lot of extra parameters. When you use the built-in Bing search plugin, the URL looks similar to this:

https://www.bing.com/search?q=mulch&pc=MOZI&form=MOZLBR

Your screenshot very different parameters, which may be added by an add-on or external program. The terms starting with CON remind me of Conduit, a publisher of many add-ons that modify how browsers search.

Hi wendyjlang, you might have noticed the address bar on your search results page contains a lot of extra parameters. When you use the built-in Bing search plugin, the URL looks similar to this: [https://www.bing.com/search?q=mulch&pc=MOZI&form=MOZLBR https://www.bing.com/search?q=mulch'''&pc=MOZI&form=MOZLBR'''] Your screenshot very different parameters, which may be added by an add-on or external program. The terms starting with CON remind me of Conduit, a publisher of many add-ons that modify how browsers search.
È stato utile questo messaggio? 0
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17482 soluzioni 157978 risposte

conlogo=CT333xxxxx is another indication that Conduit might be involved.

conlogo=CT333xxxxx is another indication that Conduit might be involved.
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

Thanks for your responses - wasn't sure what the implications to your responses were jscher2000? Understood what you were getting at, but not sure what to do with it. Oddly, Firefox is functioning just fine today - giving responses to searches but still comes up with Bing automatically. Must have just been a glitch that day, although I had tried shutting down and relogging in for that reason. Quite weird. As I said in initial post, I had checked for add-ins but had only Iobit to stop advertisements, and Firefox was set as default, so in my limited experience, I had no answers. Thanks all for your responses, even though all seems well now. regards, Wendy

Thanks for your responses - wasn't sure what the implications to your responses were jscher2000? Understood what you were getting at, but not sure what to do with it. Oddly, Firefox is functioning just fine today - giving responses to searches but still comes up with Bing automatically. Must have just been a glitch that day, although I had tried shutting down and relogging in for that reason. Quite weird. As I said in initial post, I had checked for add-ins but had only Iobit to stop advertisements, and Firefox was set as default, so in my limited experience, I had no answers. Thanks all for your responses, even though all seems well now. regards, Wendy
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8699 soluzioni 71101 risposte

Hi Wendy, if you WANT to use Bing, then it sounds like you are all set.

Hi Wendy, if you WANT to use Bing, then it sounds like you are all set.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Hi Jscher2000, no I don't particularly want to use Bing and it's annoying that it pops up each time I open my computer. At present, I currently just open another tab and proceed with Firefox and close the Bing tab. Prefer Firefox's search results compared with Bing and Chrome. thanks again, Wendy.

Hi Jscher2000, no I don't particularly want to use Bing and it's annoying that it pops up each time I open my computer. At present, I currently just open another tab and proceed with Firefox and close the Bing tab. Prefer Firefox's search results compared with Bing and Chrome. thanks again, Wendy.
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8699 soluzioni 71101 risposte

Hi Wendy, I guess I'm not completely clear on what is causing Bing to pop up. Does that occur when you start Firefox using its program icon, or if you launch a new window using Ctrl+n? In that case, please check the home page setting: How to set the home page.

Also, if you don't want Firefox to start up automatically with Windows, please check this article: Firefox starts automatically when I restart Windows.

Hi Wendy, I guess I'm not completely clear on what is causing Bing to pop up. Does that occur when you start Firefox using its program icon, or if you launch a new window using Ctrl+n? In that case, please check the home page setting: [[How to set the home page]]. Also, if you don't want Firefox to start up automatically with Windows, please check this article: [[Firefox starts automatically when I restart Windows]].
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.