X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Having trouble undoing autoplay block

Inserita

So, I DON'T want Firefox to block autoplaying of videos, as I like to put on Youtube playlists and work and it isn't feasible for me to rush over to my laptop and click every time the video changes.

I have the latest versions of Firefox (67.0.4).

I have gone to Options, Privacy & Security, and unchecked the box next to "Block websites from automatically playing sound". This did nothing. It still blocks Youtube videos from playing until I click on the video window.

I also went to the about:config page. All the settings there seem to be the opposite of what other users have used to disable autoplay (since I want to enable it). Pic attached to show which settings I have been looking at.

I have also gone to the exceptions page and added Youtube as an exception. Firefox still is not allowing autoplay (with and without the "Block websites..." box checked).

Does someone know of something I am missing? This only occurred after the 66 update, and I've been trying to undo it as it is becoming very annoying for me.

I have tested the same videos on Chrome and Edge (neither of which I prefer to use, hence trying to fix Firefox), and they play right away with no problems.

I will state that some videos do play automatically, but it is not often and is very sporadic.

So, I DON'T want Firefox to block autoplaying of videos, as I like to put on Youtube playlists and work and it isn't feasible for me to rush over to my laptop and click every time the video changes. I have the latest versions of Firefox (67.0.4). I have gone to Options, Privacy & Security, and unchecked the box next to "Block websites from automatically playing sound". This did nothing. It still blocks Youtube videos from playing until I click on the video window. I also went to the about:config page. All the settings there seem to be the opposite of what other users have used to disable autoplay (since I want to enable it). Pic attached to show which settings I have been looking at. I have also gone to the exceptions page and added Youtube as an exception. Firefox still is not allowing autoplay (with and without the "Block websites..." box checked). Does someone know of something I am missing? This only occurred after the 66 update, and I've been trying to undo it as it is becoming very annoying for me. I have tested the same videos on Chrome and Edge (neither of which I prefer to use, hence trying to fix Firefox), and they play right away with no problems. I will state that some videos do play automatically, but it is not often and is very sporadic.
Citazione

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 32.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Ulteriori informazioni

Utente che ha posto la domanda

Here is the picture. It didn't upload.

Here is the picture. It didn't upload.
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

Hello Courtney,

Maybe you could try to set the value of :

media.autoplay.enabled.user-gesture-needed to false

See if that will work for you (don't forget to close and restart Firefox, after you've changed the value).

Hello Courtney, Maybe you could try to set the value of : '''media.autoplay.enabled.user-gesture-needed''' to '''false''' See if that will work for you (don't forget to close and restart Firefox, after you've changed the value).
È stato utile questo messaggio? 0
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17425 soluzioni 157456 risposte

Try to open the YouTube website in its own window and keep this window visible iwth the player in view. Some websites use a script that prevent playing the next video unless this window is in the foreground.

Try to open the YouTube website in its own window and keep this window visible iwth the player in view. Some websites use a script that prevent playing the next video unless this window is in the foreground.
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

McCoy said

Hello Courtney, Maybe you could try to set the value of : media.autoplay.enabled.user-gesture-needed to false See if that will work for you (don't forget to close and restart Firefox, after you've changed the value).

I have tried it both ways. Neither fixes the problem. And yes, I restarted Firefox each time. I restart my LAPTOP each time to see if that did anything. No change.

''McCoy [[#answer-1231851|said]]'' <blockquote> Hello Courtney, Maybe you could try to set the value of : '''media.autoplay.enabled.user-gesture-needed''' to '''false''' See if that will work for you (don't forget to close and restart Firefox, after you've changed the value). </blockquote> I have tried it both ways. Neither fixes the problem. And yes, I restarted Firefox each time. I restart my LAPTOP each time to see if that did anything. No change.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

cor-el said

Try to open the YouTube website in its own window and keep this window visible iwth the player in view. Some websites use a script that prevent playing the next video unless this window is in the foreground.

Firefox is the only thing running, only one tab with the Youtube video, and is in the foreground. Firefox still refuses to auto play the videos.

''cor-el [[#answer-1231855|said]]'' <blockquote> Try to open the YouTube website in its own window and keep this window visible iwth the player in view. Some websites use a script that prevent playing the next video unless this window is in the foreground. </blockquote> Firefox is the only thing running, only one tab with the Youtube video, and is in the foreground. Firefox still refuses to auto play the videos.
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

Apologies if this is a rethorical question, but : when you're on YouTube and you want your playlist to autoplay : do you click the "Autoplay" button ?

Apologies if this is a rethorical question, but : when you're on YouTube and you want your playlist to autoplay : do you click the "Autoplay" button ?
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

McCoy said

Apologies if this is a rethorical question, but : when you're on YouTube and you want your playlist to autoplay : do you click the "Autoplay" button ?

Auto play on Youtube plays the next recommended video; it has never controlled whether a video plays once the video page is loaded. I have never needed it to be turned on to play playlists, or just video I click on. But yes, I tried turning it on. That did not solve the problem either.

Here’s the sticking point of my frustration. I quite literally go to Youtube and click on ANY video link. The page for the video loads, but the video DOES NOT PLAY until I click it. It sits on a big thumb nail image with a little red play box in the middle until I click on it.

This goes for my playlists, videos I click on after a video has ended, etc. And before the latest Firefox update that forced a block on auto play as the default, this did not occur. With Chrome and Edge, this does not occur. But I prefer using Firefox, so I want to try to fix this.

''McCoy [[#answer-1231865|said]]'' <blockquote> Apologies if this is a rethorical question, but : when you're on YouTube and you want your playlist to autoplay : do you click the "Autoplay" button ? </blockquote> Auto play on Youtube plays the next recommended video; it has never controlled whether a video plays once the video page is loaded. I have never needed it to be turned on to play playlists, or just video I click on. But yes, I tried turning it on. That did not solve the problem either. Here’s the sticking point of my frustration. I quite literally go to Youtube and click on ANY video link. The page for the video loads, but the video DOES NOT PLAY until I click it. It sits on a big thumb nail image with a little red play box in the middle until I click on it. This goes for my playlists, videos I click on after a video has ended, etc. And before the latest Firefox update that forced a block on auto play as the default, this did not occur. With Chrome and Edge, this does not occur. But I prefer using Firefox, so I want to try to fix this.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

Also, don’t know if this is relevant or not, but for all the other “Security and Privacy” options, once unchecked, the little “Exceptions” box next to the option becomes light gray and inaccessible (as it should, since if I am not using the option, there is no need for exceptions to the option).

However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible.

Also, don’t know if this is relevant or not, but for all the other “Security and Privacy” options, once unchecked, the little “Exceptions” box next to the option becomes light gray and inaccessible (as it should, since if I am not using the option, there is no need for exceptions to the option). However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible.
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

CourtneyRayle said

However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible.

That's because there you can specify which websites are always or never allowed to autoplay media with sound ....

''CourtneyRayle [[#answer-1231869|said]]'' <blockquote> However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible. </blockquote> That's because there you can specify which websites are ''always'' or ''never'' allowed to autoplay media with sound ....
È stato utile questo messaggio? 0
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

Another (probably rethorical) question :

When you're on YouTube, and you click on the little "i" in a circle at the left side of the address bar (next to the padlock), do you see:

"Permissions" => Autoplay sound, and an "Allow" button  ?

Another (probably rethorical) question : When you're on YouTube, and you click on the little "i" in a circle at the left side of the address bar (next to the padlock), do you see: "Permissions" => Autoplay sound, and an "Allow" button ?
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

McCoy said

CourtneyRayle said
However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible.

That's because there you can specify which websites are always or never allowed to autoplay media with sound ....

Which shouldn’t matter, if I have the box unchecked and am not using that option, ergo, ALL websites should autoplay media with sound. If I have turned off the option, it should not matter what websites I have allowed or blocked. Firefox should not be using that option, period, if it is unchecked.

This leads me to wonder if some of the code changed in the latest update is not working properly, which is why I mentioned it.

''McCoy [[#answer-1231872|said]]'' <blockquote> ''CourtneyRayle [[#answer-1231869|said]]'' <blockquote> However, for the “Block websites from automatically playing sound” option, unchecking it still leaves the “Exceptions” box usable and accessible. </blockquote> That's because there you can specify which websites are ''always'' or ''never'' allowed to autoplay media with sound .... </blockquote> Which shouldn’t matter, if I have the box unchecked and am not using that option, ergo, ALL websites should autoplay media with sound. If I have turned off the option, it should not matter what websites I have allowed or blocked. Firefox should not be using that option, period, if it is unchecked. This leads me to wonder if some of the code changed in the latest update is not working properly, which is why I mentioned it.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

McCoy said

Another (probably rethorical) question : When you're on YouTube, and you click on the little "i" in a circle at the left side of the address bar (next to the padlock), do you see: "Permissions" => Autoplay sound, and an "Allow" button  ?

Yes, with or without the “Privacy & Settings” block... option unchecked. It is checked on “Allow.” It still is not autoplaying.

''McCoy [[#answer-1231876|said]]'' <blockquote> Another (probably rethorical) question : When you're on YouTube, and you click on the little "i" in a circle at the left side of the address bar (next to the padlock), do you see: "Permissions" => Autoplay sound, and an "Allow" button ? </blockquote> Yes, with or without the “Privacy & Settings” block... option unchecked. It is checked on “Allow.” It still is not autoplaying.
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

I just took another look at your screenshot and compared your values to mine - you have the value of "media.autoplay.default" set to "0" (zero), and I have mine set to "1" My playlists autoplay just fine ....

Would you give it a try  ?

I just took another look at your screenshot and compared your values to mine - you have the value of "media.autoplay.default" set to "0" (zero), and I have mine set to "1" My playlists autoplay just fine .... Would you give it a try ?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

McCoy said

I just took another look at your screenshot and compared your values to mine - you have the value of "media.autoplay.default" set to "0" (zero), and I have mine set to "1" My playlists autoplay just fine .... Would you give it a try  ?

The playlist I was watching seems to be playing now, but a subset of videos still aren’t autoplaying if I just click on video link and go to the page. So the problem is not 100% fixed.

I am specifically looking at Eurovision Song videos, if that helps.

''McCoy [[#answer-1231885|said]]'' <blockquote> I just took another look at your screenshot and compared your values to mine - you have the value of "media.autoplay.default" set to "0" (zero), and I have mine set to "1" My playlists autoplay just fine .... Would you give it a try ? </blockquote> The playlist I was watching seems to be playing now, but a subset of videos still aren’t autoplaying if I just click on video link and go to the page. So the problem is not 100% fixed. I am specifically looking at Eurovision Song videos, if that helps.
È stato utile questo messaggio?
Citazione
cor-el
  • Top 10 Contributor
  • Moderator
17425 soluzioni 157456 risposte

YouTube auto-plays for me the next video even with block auto-play enabled (this feature should only prevent playing when you first open the page).

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
YouTube auto-plays for me the next video even with block auto-play enabled (this feature should only prevent playing when you first open the page). Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

cor-el said

YouTube auto-plays for me the next video even with block auto-play enabled (this feature should only prevent playing when you first open the page). Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Nope. Videos still not autoplaying, with the only difference being the ads before the videos are not playing either (since Safe Mopde disables Ad Blocker). The video just shows a picture of that instead of the thumb nail.

''cor-el [[#answer-1231891|said]]'' <blockquote> YouTube auto-plays for me the next video even with block auto-play enabled (this feature should only prevent playing when you first open the page). Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems </blockquote> Nope. Videos still not autoplaying, with the only difference being the ads before the videos are not playing either (since Safe Mopde disables Ad Blocker). The video just shows a picture of that instead of the thumb nail.
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

CourtneyRayle said

I am specifically looking at Eurovision Song videos, if that helps.

Not my favorite videos, but I just tried this one :

https://www.youtube.com/watch?v=5sGOwFVUU0I&list=PL9KifGoS3P-TWwlbEx7OYjstrBHgpdm7z&index=2

Autoplays just fine .....

So, now that you've change the value of "media.autoplay.default" to "1" - most playlist autoplay, but just not all of them  ?

''CourtneyRayle [[#answer-1231890|said]]'' <blockquote> I am specifically looking at Eurovision Song videos, if that helps. </blockquote> Not my favorite videos, but I just tried this one : https://www.youtube.com/watch?v=5sGOwFVUU0I&list=PL9KifGoS3P-TWwlbEx7OYjstrBHgpdm7z&index=2 Autoplays just fine ..... So, now that you've change the value of "media.autoplay.default" to "1" - most playlist autoplay, but just not all of them ?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

McCoy said

CourtneyRayle said
I am specifically looking at Eurovision Song videos, if that helps.

Not my favorite videos, but I just tried this one :

https://www.youtube.com/watch?v=5sGOwFVUU0I&list=PL9KifGoS3P-TWwlbEx7OYjstrBHgpdm7z&index=2

Autoplays just fine .....

So, now that you've change the value of "media.autoplay.default" to "1" - most playlist autoplay, but just not all of them  ?

Yes, that is correct. And it seems to be videos not in a playlist now.

One of the videos giving me trouble is: https://m.youtube.com/watch?v=Ud7mYAI4Vtk

''McCoy [[#answer-1231902|said]]'' <blockquote> ''CourtneyRayle [[#answer-1231890|said]]'' <blockquote> I am specifically looking at Eurovision Song videos, if that helps. </blockquote> Not my favorite videos, but I just tried this one : https://www.youtube.com/watch?v=5sGOwFVUU0I&list=PL9KifGoS3P-TWwlbEx7OYjstrBHgpdm7z&index=2 Autoplays just fine ..... So, now that you've change the value of "media.autoplay.default" to "1" - most playlist autoplay, but just not all of them ? </blockquote> Yes, that is correct. And it seems to be videos not in a playlist now. One of the videos giving me trouble is: https://m.youtube.com/watch?v=Ud7mYAI4Vtk
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

CourtneyRayle said

Yes, that is correct. And it seems to be videos not in a playlist now.

Rethorical question again : the "Autoplay" button is blue  ?

One of the videos giving me trouble is:
https://m.youtube.com/watch?v=Ud7mYAI4Vtk

I just tried it - they don't autoplay right away, but they do play eventually. Same thing when I try in Edge .....

''CourtneyRayle [[#answer-1231907|said]]'' <blockquote> Yes, that is correct. And it seems to be videos not in a playlist now. </blockquote> Rethorical question again : the "Autoplay" button is blue ? <blockquote> One of the videos giving me trouble is:<BR> https://m.youtube.com/watch?v=Ud7mYAI4Vtk </blockquote> I just tried it - they don't autoplay right away, but they do play eventually. Same thing when I try in Edge .....
È stato utile questo messaggio?
Citazione
McCoy
  • Top 10 Contributor
525 soluzioni 4913 risposte

If it still doesn't work the way you want it to, you could try this on the "about:config" page :

Type in the search bar foreground

Look for the preference :

media.block-autoplay-until-in-foreground

and see if setting the value to false will work for you If not : change it back to the default (don't forget to close and restart Firefox)

If it still doesn't work the way you want it to, you could try this on the "about:config" page : Type in the search bar '''foreground''' Look for the preference : '''media.block-autoplay-until-in-foreground''' and see if setting the value to '''false''' will work for you If not : change it back to the default (don't forget to close and restart Firefox)
È stato utile questo messaggio? 0
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.