Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

User agent string wrong, about:config claims it's the default one

  • 4 risposte
  • 1 ha questo problema
  • 210 visualizzazioni
  • Ultima risposta di aiviv

more options

My UserAgent string is wrong. It has the wrong OS and the wrong Firefox version. I ran into the article explaining how to reset it, but when I search for "useragent", I don't see any of the suggested preferences (see also screenshots).

It might be relevant that I had the UAControl extension installed, until it got automatically disabled due to the switch to WebExtensions. That might have had the "wrong" user agent selected when it was disabled. But I still can't find where it was set or how to reset it.

Immagini allegate

Soluzione scelta

The Safe Mode test should address the possibility that one of your extensions is doing it.

Do you use the "resist fingerprinting" setting? That may override your user agent, replacing it with a more common one.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (4)

more options

What's your computer system and Firefox version? And what is the User Agent showing?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Soluzione scelta

The Safe Mode test should address the possibility that one of your extensions is doing it.

Do you use the "resist fingerprinting" setting? That may override your user agent, replacing it with a more common one.

more options

Because a Firefox 60 ESR version is reported, I'm thinking the same way that "Resist Fingerprinting" is enabled. Note that this also changes the Date/Time to UTC (GMT).

See also:

more options

Thanks! It was indeed the "Resist Fingerprinting" setting. Disabled it and now my User Agent is normal again.