X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

pages keep coming up entirely black.

Inserita

web pages are entirely black. that means entirely black, nothing but black, no text, no pictures just black. entirely and absolutely black.

web pages are entirely black. that means entirely black, nothing but black, no text, no pictures just black. entirely and absolutely black.

Soluzione scelta

Yeah, its working fine now. It just wanted updates installed. That is weird.

Leggere questa risposta nel contesto 0
Citazione

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 32.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:65.0) Gecko/20100101 Firefox/65.0

Ulteriori informazioni

Utente che ha posto la domanda

if it is at all helpful I am on a MacBook Pro (15-inch, 2.53GHz, Mid 2009) running El Capitan 10.11.6 . and i am running firefox Quantum 65.0.1 (64-bit).

the pages are coming up just plain black and there is nothing I can do about it. occasionally if I open a new tab with a quick and sharp motion it will work OK, but otherwise it will be black. and if I try to open a new tab from a link it will always be black.

and I mean entirely black. there is nothing there except black.

if it is at all helpful I am on a MacBook Pro (15-inch, 2.53GHz, Mid 2009) running El Capitan 10.11.6 . and i am running firefox Quantum 65.0.1 (64-bit). the pages are coming up just plain black and there is nothing I can do about it. occasionally if I open a new tab with a quick and sharp motion it will work OK, but otherwise it will be black. and if I try to open a new tab from a link it will always be black. and I mean entirely black. there is nothing there except black.
È stato utile questo messaggio?
Citazione
WestEnd
  • Top 25 Contributor
61 soluzioni 5304 risposte

What Addon or Security software are you using? And is this for a specific page or just all web pages?

What Addon or Security software are you using? And is this for a specific page or just all web pages?
È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

I am running No-script, Ad blocker Plus, Facebook Container, Honey, and Social Fixer for Facebook. Ive also been running all of these for years and have not had a problem at all with them.

It is for all web pages.

I am running No-script, Ad blocker Plus, Facebook Container, Honey, and Social Fixer for Facebook. Ive also been running all of these for years and have not had a problem at all with them. It is for all web pages.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

still no answer? Hello?

still no answer? Hello?
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8511 soluzioni 69527 risposte

If you call up the source view (I think it's Command+u, or right-click > View Page Source), does the black page have any HTML content?

In case Firefox is trying to adapt colors to your system theme, could you set Firefox to strictly apply the colors assigned by the page. You do that on the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog as it appears on Windows 7:

If you call up the source view (I think it's Command+u, or right-click > View Page Source), does the black page have any HTML content? In case Firefox is trying to adapt colors to your system theme, could you set Firefox to strictly apply the colors assigned by the page. You do that on the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''color'' and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that. Try changing this setting: "Override the colors specified by the page with your selections above" Below that, it usually says "Only with High Contrast themes" Click that and change the setting to "'''Never'''" then click OK to finish the change. Does that help at all? Here's a screenshot of that part of the Colors dialog as it appears on Windows 7: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-01-21-12-48-55-d2a6b4.png" width="500">
È stato utile questo messaggio? 0
Citazione

Utente che ha posto la domanda

I followed your directions exactly and it made no difference.

I followed your directions exactly and it made no difference.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

here is a screenshot

here is a screenshot
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8511 soluzioni 69527 risposte

Is there any HTML source of the page, if you check Page Source?

Does the black area turn white if you change to Firefox's "Light" theme: Built-in themes in Firefox - alternative to complete themes?

Firefox is a multi-process application, and the tab contents run in a separate process from the toolbar area (user interface). Although rare, I do think some users have reported completely empty tabs (no HTML source to view) when software on their system is somehow blocking those additional processes, or the interprocess communication required to coordinate them. Unfortunately, I can't recall the details of those threads.

Is there any HTML source of the page, if you check Page Source? Does the black area turn white if you change to Firefox's "Light" theme: [[Built-in themes in Firefox - alternative to complete themes]]? Firefox is a multi-process application, and the tab contents run in a separate process from the toolbar area (user interface). Although rare, I do think some users have reported completely empty tabs (no HTML source to view) when software on their system is somehow blocking those additional processes, or the interprocess communication required to coordinate them. Unfortunately, I can't recall the details of those threads.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I tried checking page source and could not find it. when I clicked command+U as you suggested, I still had a black page.

I tried checking page source and could not find it. when I clicked command+U as you suggested, I still had a black page.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I finally found the option to view page source under Tools in the menu, but the page is still just black.

I finally found the option to view page source under Tools in the menu, but the page is still just black.
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8511 soluzioni 69527 risposte

Oh, the source code page is black, too? Hmm. If you use "Select All" (Command+a), which should highlight text, is there any text?

Oh, the source code page is black, too? Hmm. If you use "Select All" (Command+a), which should highlight text, is there any text?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

I did command+A and nothing appeared to happen, so I copied and pasted into a text document, and the text document is now full of code. so it seems to be working, it is just all coloured black.

I did command+A and nothing appeared to happen, so I copied and pasted into a text document, and the text document is now full of code. so it seems to be working, it is just all coloured black.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

interestingly this is at the bottom of the code:

     if (!Object.defineProperty || !document.addEventListener) {
       ins('It looks like you are running an outdated web browser.
To continue to the online store, please install one of these updated browsers:'); } else if (navigator.appVersion.indexOf("MSIE 9") != -1) { ins('It looks like you are running an outdated web browser.
For the best experience, please install one of these updated browsers:')
interestingly this is at the bottom of the code: if (!Object.defineProperty || !document.addEventListener) { ins('It looks like you are running an outdated web browser.<br>To continue to the online store, please install one of these updated browsers:'); } else if (navigator.appVersion.indexOf("MSIE 9") != -1) { ins('It looks like you are running an outdated web browser.<br>For the best experience, please install one of these updated browsers:')
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8511 soluzioni 69527 risposte

Hmm, Firefox was able to retrieve the page, but nothing visual is working.

Have you already tested in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, userChrome.css and userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hmm, Firefox was able to retrieve the page, but nothing visual is working. Have you already tested in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, userChrome.css and userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

its working fine now, but also firefox installed updates, so I wonder which of the 2 solved the problem. I'm gonna try restarting again in normal mode and see what happens

its working fine now, but also firefox installed updates, so I wonder which of the 2 solved the problem. I'm gonna try restarting again in normal mode and see what happens
È stato utile questo messaggio?
Citazione

Soluzione scelta

Yeah, its working fine now. It just wanted updates installed. That is weird.

Yeah, its working fine now. It just wanted updates installed. That is weird.
È stato utile questo messaggio?
Citazione

Utente che ha posto la domanda

thank you so much for the help, I appreciate it.

thank you so much for the help, I appreciate it.
È stato utile questo messaggio?
Citazione
jscher2000
  • Top 10 Contributor
8511 soluzioni 69527 risposte

Maybe one of the program files went bad and the Firefox 66 update solved that? Anyway, fingers crossed the problem does not return.

Maybe one of the program files went bad and the Firefox 66 update solved that? Anyway, fingers crossed the problem does not return.
È stato utile questo messaggio?
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.