Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How To Make Firefox (plus system) Faster & Responsive By Disabling FF Default New Tab Settings Manually?

  • 14 risposte
  • 2 hanno questo problema
  • 1857 visualizzazioni
  • Ultima risposta di cor-el

more options

Hello earthlings,

Recently, I have noticed a severe drawback on "Electrolysis" - e10s feature (plus interference with add-ons/extensions maybe?), that causes severe CPU load and therefore system non-responsiveness. After some ...hard-core trial & error I managed to narrow down the problem onto that (very useful otherwise) feature, unfortunately: Tools-->Options-->Performance, and reduced the number of processes from 4(default) to 1, and then I restarted FF. Voilà, now my Firefox/system experience is again back to normal! Any thoughts would be appreciated...

Thank you,

Modificato da dimIS85 il

Soluzione scelta

Thank you very much, both, for your immediate responses! Well, I think I was a bit hurry to announce that the problem was solved so easily, cause it came back, unfortunately (thus with much lower frequency, since e10s is disabled)... My FF distro is a fresh install of x64 version on top of x86 that I used to have in the past and furthermore this issue did not happen to other browsers such as IE or Opera (on my system).

And, now as I was writing these lines in the Mozilla support page editor (started Firefox in Safe-mode/no add-ons, no extensions, no nothing) and with only these twotabs opened:

then same sh*t happens - URGHHHHHHHH!!! At spontaneous time the CPU randomly peaks at 99.32% or more (as you can see on the screenshot), with non responsive FF main window (white out by Win7), system running really slow (with 8 Gigs of RAM and free up to 30%!) and so on... I forgot to mention at my previous post that at times this situation lead to my nVidia graphics kernel fail by Timeout Detection & Recovery (TDR) accompanying with the ...respective windows drivers balloon informing me! This situation started to drive me nuts!!!!! I had to find what the heck was goin' on!!

After some further searching 'n' testing I managed to figure out the root cause of the problem (so far): I noticed that the problem could be reproduced instantly when a new tab was opened!! Then went to

  • Bulleted list item<about:preferences#home> and UNCHECKED everything but left FF with the default <empty> tab page (only FF logo top left and settings gear on top right corners).

BAMMM, THE PROBLEM DISAPPEARED INSTANTLY and CPU back to ZERO~14.0% for God's Shake = there is something wrong in the algorithm you guys, please have it inspected :-) My old good FF is back and even my laptop fan is running low or at zero RPM now at last - WOWWWWWWWWWWWW! :-O Useful to mention that each time I enabled some setting on this <about:preferences#home> CPU peaks at 99.99% - WTF??? In code view of the <default FF new tab> I can see tons of JavaScript queries and scripts behind it - maybe somethin' scrambled over there with FF last update or has to do with a crawler, dunno... Currently am checking with FF in normal start mode (not Safe) with all add-ons/extensions loaded and so far so good, no peaks, no pikes, no CPU load, all running smoothly!! If that helps, I managed to narrow down the hogging issue further at the process memory tree thread "Firefox.exe!TargetNtUnmapViewOfSection+0x9314" (it was the only one that peaked at ~73.15%).

Now, I have to change the title from "How To Make Firefox (plus system) Faster By Disabling Multi-Process E10S Manually?" to "How To Make Firefox (plus system) Faster & Responsive By Disabling FF Default New Tab Settings Manually?" or something similar ;-)

Thank ya all for your valuable help guys - keep up da good work!!! Firefox rocks and I won't change it with anything other than ...Firefox!

My warmest greetings,

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (14)

more options

Are you running low on RAM with the four processes running, causing swapping which slows everything down?

You don't say what the high CPU load is showing up against in Task Manager, is it Firefox or another process? How much free memory do you have when everything is running slowly?

If you run Firefox in safe mode then it will temporarily disable all extensions so you can test it out to see whether it's an extension causing the problem.

more options

Did you try to set the number of content processes to 1?

The multi-process window feature is meant as a stability feature to prevent the browser from crashing in a case something goes wrong. You can see three or more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes set via
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread (Windows;graphics)

You can find the current multi-process state on the Troubleshooting Information (about:support) page.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes

See also:

more options

Soluzione scelta

Thank you very much, both, for your immediate responses! Well, I think I was a bit hurry to announce that the problem was solved so easily, cause it came back, unfortunately (thus with much lower frequency, since e10s is disabled)... My FF distro is a fresh install of x64 version on top of x86 that I used to have in the past and furthermore this issue did not happen to other browsers such as IE or Opera (on my system).

And, now as I was writing these lines in the Mozilla support page editor (started Firefox in Safe-mode/no add-ons, no extensions, no nothing) and with only these twotabs opened:

then same sh*t happens - URGHHHHHHHH!!! At spontaneous time the CPU randomly peaks at 99.32% or more (as you can see on the screenshot), with non responsive FF main window (white out by Win7), system running really slow (with 8 Gigs of RAM and free up to 30%!) and so on... I forgot to mention at my previous post that at times this situation lead to my nVidia graphics kernel fail by Timeout Detection & Recovery (TDR) accompanying with the ...respective windows drivers balloon informing me! This situation started to drive me nuts!!!!! I had to find what the heck was goin' on!!

After some further searching 'n' testing I managed to figure out the root cause of the problem (so far): I noticed that the problem could be reproduced instantly when a new tab was opened!! Then went to

  • Bulleted list item<about:preferences#home> and UNCHECKED everything but left FF with the default <empty> tab page (only FF logo top left and settings gear on top right corners).

BAMMM, THE PROBLEM DISAPPEARED INSTANTLY and CPU back to ZERO~14.0% for God's Shake = there is something wrong in the algorithm you guys, please have it inspected :-) My old good FF is back and even my laptop fan is running low or at zero RPM now at last - WOWWWWWWWWWWWW! :-O Useful to mention that each time I enabled some setting on this <about:preferences#home> CPU peaks at 99.99% - WTF??? In code view of the <default FF new tab> I can see tons of JavaScript queries and scripts behind it - maybe somethin' scrambled over there with FF last update or has to do with a crawler, dunno... Currently am checking with FF in normal start mode (not Safe) with all add-ons/extensions loaded and so far so good, no peaks, no pikes, no CPU load, all running smoothly!! If that helps, I managed to narrow down the hogging issue further at the process memory tree thread "Firefox.exe!TargetNtUnmapViewOfSection+0x9314" (it was the only one that peaked at ~73.15%).

Now, I have to change the title from "How To Make Firefox (plus system) Faster By Disabling Multi-Process E10S Manually?" to "How To Make Firefox (plus system) Faster & Responsive By Disabling FF Default New Tab Settings Manually?" or something similar ;-)

Thank ya all for your valuable help guys - keep up da good work!!! Firefox rocks and I won't change it with anything other than ...Firefox!

My warmest greetings,

Modificato da cor-el il

more options

dimIS85 said

...At spontaneous times, the CPU randomly peaks at 99.32% or more (as you can see on the screenshot), with non responsive FF main window (white-out by Win7), system running really slow (with 8 Gigs of RAM and free up to 30%!) and so on... ...I managed to figure out the root cause of the problem (so far): I noticed that the problem could be reproduced instantly when a new tab was opened! Then went to:
  • Bulleted list item<about:preferences#home> and UNCHECKED everything but left FF with the default <empty> tab page (only FF logo top left and settings gear on top right corners).
BAM! THE PROBLEM DISAPPEARED INSTANTLY and CPU back to ZERO~14.0%... There is something wrong in the algorithm you guys, please have it inspected.  :-) My old good FF is back and even my laptop fan is running low or at zero RPM now at last...

Well, I'll have to keep this in mind. Do report back here updating on your performance.

What is you Windows 7 Paging File Size? I got the best yet Quantum performance when I manually changed my 'auto' sized PF from ~8GB to 14GB/14GB! (This, with a 1T Drive with about 121GB remaining.)

How much Hard Disk Drive space remaining to you have?

~Pj

Modificato da Pj il

more options

Pj said

dimIS85 said
...At spontaneous times, the CPU randomly peaks at 99.32% or more (as you can see on the screenshot), with non responsive FF main window (white-out by Win7), system running really slow (with 8 Gigs of RAM and free up to 30%!) and so on... ...I managed to figure out the root cause of the problem (so far): I noticed that the problem could be reproduced instantly when a new tab was opened! Then went to:
  • Bulleted list item<about:preferences#home> and UNCHECKED everything but left FF with the default <empty> tab page (only FF logo top left and settings gear on top right corners).
BAM! THE PROBLEM DISAPPEARED INSTANTLY and CPU back to ZERO~14.0%... There is something wrong in the algorithm you guys, please have it inspected.  :-) My old good FF is back and even my laptop fan is running low or at zero RPM now at last...

Well, I'll have to keep this in mind. Do report back here updating on your performance.

What is you Windows 7 Paging File Size? I got the best yet Quantum performance when I manually changed my 'auto' sized PF from ~8GB to 14GB/14GB! (This, with a 1T Drive with about 121GB remaining.)

How much Hard Disk Drive space remaining to you have?

~Pj

Thank you very much Pj for your response!

  • My page file is currently set at 8159 MB (automatically re-sized/modified by Win7). Of course I'll keep in mind your suggestion to double the size manually, but for the time being I think I will leave it as is, because a few years ago had real trouble messing with Swap/Page file sizes... ;-)
  • Furthermore, my remaining disk space (on OS/System partition) is around 20 Gb out of 221 Gb (...needs some serious clean-up, I think so).
  • Also, thanks for your suggestions about FF Quantum multi-process/e10s, but since my first post I reverted back and checked "Use recommended performance settings", since I am afraid of tabs instability if I disable multi-e10s. But, I think you are absolutely right that the system is much faster with "Content process limit"->1 (aka e10s multi-process disabled). Additionally, if I uncheck "Use hardware acceleration..." the videos end up a bit choppy, so I think I'll let this enabled in order to unload some heavy duty from CPU.

Oh my Gosh, I am writing these lines in the FF editorial window - I do not believe it - before I had to copy/paste from notepad, since I couldn't write neither one line with CPU 99% peaking up constantly!! Hurray!!!!

I'll keep you informed, of course :-)

My best regards,

more options

dimIS85 said

My page file is currently set at 8159 MB (automatically re-sized/modified by Win7). Of course I'll keep in mind your suggestion to double the size manually, but for the time being I think I will leave it as is, because a few years ago had real trouble messing with Swap/Page file sizes... ;-)

I just recently had an 8GB/8GB Windows Paging File Size, and FF does better when going way beyond 8GB.

It doesn't hurt to increase the Paging File Size, but you can run into problems by under-sizing it. I've played around over the last number of months and found performance and memory issues when it was too low. You can try a 10GB/10GB to 12GB/12GB setting after you 'clean-up' your very low HDD space. (See more on next section.)

dimIS85 said

Furthermore, my remaining disk space (on OS/System partition) is around 20 Gb out of 221 Gb (...needs some serious clean-up, I think so).

OUCH! Windows 7 (and some other programs) do not like such low-remaining disk space. I'm around 121GB now (of 1TB Total) and that's getting low. It's desirable to have plenty of GB 'breathing' room. 20GB is a 'choker', gasping for air. (Grin)

dimIS85 said

Also, thanks for your suggestions about FF Quantum multi-process/e10s, but since my first post I reverted back and checked "Use recommended performance settings", since I am afraid of tabs instability if I disable multi-e10s...

I never had 'Tabs Instability' since I've been on the '1' setting. Since I increased my Windows Paging File to 14GB/14GB FF 61.02 is the most stable over time. I'm on Day 4, and other Day 4's were 'clogging-up' by this time (pending how many browser windows and loaded Tabs). My Main Browser Window has about 912 Tabs (only a few dozen or so loaded right now). (Ok, I know. I seriously need to do some Tabs cleanup to get way, way under 912 Tabs.) (Grin)

I may try to set Process up to '2' (since I have a Dual Processor) and see what happens now that I have a much higher Windows Paging File Size.


~Pj

more options

Have you tried running Firefox in safe mode and opening a new tab there, to see if the same problem happens? If it does then it's likely a Firefox issue, but if not, then it would appear to be a problem with your Firefox profile.

For the CPU load to peak at 100% it makes me wonder whether you have visited a website that has cryptocurrency mining software embedded in it, which is somehow being triggered when Firefox is trying to render the pages of your recently viewed sites, as shown on the new-tab page.

If you run in safe mode then the suspect site won't be shown on the new-tab window, so if that fixes the problem then you might want to investigate which of those sites showing up in your normal profile is the one to avoid!

more options

Pj said

dimIS85 said
My page file is currently set at 8159 MB (automatically re-sized/modified by Win7). Of course I'll keep in mind your suggestion to double the size manually, but for the time being I think I will leave it as is, because a few years ago had real trouble messing with Swap/Page file sizes... ;-)

I just recently had an 8GB/8GB Windows Paging File Size, and FF does better when going way beyond 8GB.

It doesn't hurt to increase the Paging File Size, but you can run into problems by under-sizing it. I've played around over the last number of months and found performance and memory issues when it was too low. You can try a 10GB/10GB to 12GB/12GB setting after you 'clean-up' your very low HDD space. (See more on next section.)

dimIS85 said

Furthermore, my remaining disk space (on OS/System partition) is around 20 Gb out of 221 Gb (...needs some serious clean-up, I think so).

OUCH! Windows 7 (and some other programs) do not like such low-remaining disk space. I'm around 121GB now (of 1TB Total) and that's getting low. It's desirable to have plenty of GB 'breathing' room. 20GB is a 'choker', gasping for air. (Grin)

dimIS85 said

Also, thanks for your suggestions about FF Quantum multi-process/e10s, but since my first post I reverted back and checked "Use recommended performance settings", since I am afraid of tabs instability if I disable multi-e10s...

I never had 'Tabs Instability' since I've been on the '1' setting. Since I increased my Windows Paging File to 14GB/14GB FF 61.02 is the most stable over time. I'm on Day 4, and other Day 4's were 'clogging-up' by this time (pending how many browser windows and loaded Tabs). My Main Browser Window has about 912 Tabs (only a few dozen or so loaded right now). (Ok, I know. I seriously need to do some Tabs cleanup to get way, way under 912 Tabs.) (Grin)

I may try to set Process up to '2' (since I have a Dual Processor) and see what happens now that I have a much higher Windows Paging File Size.


~Pj

Sorry for my late reply - I am back..

Ah..Yes, recently I did a major clean-up [plus updates] and things were even better since then!

  • Also, I did set multi-Process to '2' since I also have a Dual Core Processor and even loaded up to 100 Tabs - that was an extraordinary number before, far away from ...912 that you have - omg ;-)

Thank you, of course, for your suggestion on this!

  • Furthermore, I have disabled "Save on cache memory..." setting for Auto-Protect / Norton Internet Suite, since it seems to have severe conflict with firefox.exe (it self-triggered SRTSP64.sys and EX64.sys high CPU usage sometimes). Although, iexplore or opera executables did not trigger such behavior (maybe is the huge history that my FF has - back to 10 years or more with the same profile and with millions of pages & websites visited, dunno).

Well, I think this is finally solved. Of course, I'll post if I notice or find something new. Thanks a lot, again!! :-)

Best regards,

more options

Malvineous said

Have you tried running Firefox in safe mode and opening a new tab there, to see if the same problem happens? If it does then it's likely a Firefox issue, but if not, then it would appear to be a problem with your Firefox profile. For the CPU load to peak at 100% it makes me wonder whether you have visited a website that has cryptocurrency mining software embedded in it, which is somehow being triggered when Firefox is trying to render the pages of your recently viewed sites, as shown on the new-tab page. If you run in safe mode then the suspect site won't be shown on the new-tab window, so if that fixes the problem then you might want to investigate which of those sites showing up in your normal profile is the one to avoid!

Sorry for my late reply and thank very much for your response..

  • Yes, as I have already stated in a previous post, the first thing I tried was to running Firefox in safe mode and opening two tabs there, in order to see if the same problem persists. It did, so then was likely a Firefox issue coping with too big history size of websites and pages loaded in the past, dunno...
  • As for the CPU load to peak at 100% it also made me wonder whether I had visited a website that has cryptocurrency mining software embedded in it, that is somehow being triggered when FF is trying to render the pages of recently viewed sites, as shown on the new-tab page.

For that reason, I had already installed a bunch of mining blocker add-ons and anti-virus software a long time ago, that detected nothing. Also, the recently viewed sites, as shown on the new-tab page where only channel stations, social networks, or similar "legitimate" pages. If they are cryptomining too, really dunno what to say! Moreover, I let the "dirty" job being done in Tor plus Ubuntu distro for keeping my a$$ safe ;-)

  • Also, recently I did a major clean-up [plus updates] and things were even better since then!
  • Furthermore, I have disabled "Save on cache memory..." setting for Auto-Protect / Norton Internet Suite, since it seems to have severe conflict with firefox.exe (it self-triggered SRTSP64.sys and EX64.sys high CPU usage sometimes). Although, iexplore or opera executables did not trigger such behavior.

Well, I think this is finally solved. Of course, I'll post if I notice or find something new. Thanks, again.

Best regards,

more options

Hello folks,

Unfortunately, the nightmare returned a few days ago while I was trying to clean up FF default tab/start page by removing Top Sites... Malvineous you were absolutely right: while I was hitting Dismiss on each site displayed on the tiles (why isn't there a Dismiss All option, you folks?) it seems that a specific site triggered cryptomining exploit - the moment it was displayed on the tile - and an unexplained high CPU usage of 50~99% and caused FF to stuck/hang!

What is puzzling me is how the heck this sh*t bypassed all the anti-virus or add-on blockers I have enabled on my system, anyways... The fact is that I had to erase ALL my FF history (pages+downloads) in Firefox+Windows Safe mode (F8) and only, in order to get FF back to responding state (URGHHHHH, again)! If I restarted FF in normal (or FF only safe) mode it simply triggered 100% CPU usage and stuck in there, nothing more nothing less...

So, as a last option, I decided to go check my FF profile and I noticed that my prefs.js file in my main FF profile exploded to 336Mb - yeap, megabyte!

  • When I opened my profile folder I noticed 21 files created within some days/months of each other: prefs-1.js prefs-2.js,..., prefs-21.js and the original prefs.js are all 100-336Mb each (screenshot attached).

As I stated in my 1st/2nd posts, where I reported FF acting very sluggish, and freezing right after going to new tab, I tried starting up with all extensions disabled, in safe mode and closing all tabs, but it was still slow-->it seems that firefox.exe acted like a malicious executable (it is supposed that FF is one of the safest browsers - WTF?)!!

Trying to open one of the prefs-*.js JavaScript files, with notepad++ or even Dreamweaver, was feckless, since all the programs hanged immediately right after Open with... I could only preview the specific prefs-*.js files on notepad++ where I noticed a huge set of raw data from the middle till the end of each file (right after preferences lines),

 just like these://Start of file ...(preferences) user_pref("browser.newtabpage.pinned""[null,null,null,null,null,null,{\"url\":\"http://www.site.gr/\",\ΞΞΔΓΞΣδσογ$@^$#^ΞΔΓΞσδ^#$κΞΔΓΞΞΔΓΞΞΔΓΞ$#ΓΔΣφ@%#^$#^#$......(lot of raw data~335Mb!!!)//End of file

Dammit, I am not able to fix it by replacing prefs.js from a backup, cause I don't have one (of this specific file), but I'd really like to know what caused this and how to "cure" this file. For example if I simply delete it (in order to regenerate a new 'clean' prefs.js) will I lost only my about:config user defined preferences, my add-ons settings or lost all my passwords (cause I have a Master Password currently set)? Plz inform me!

As I stated before, I have thoroughly scanned for viruses and rootkits (Avira, Kaspersky, Malwarebytes, ESET, Sophos, MSE and more). I also use NoScript, and other security add-ons within Firefox, so I find it hard to believe I am infected.

I realize that this issue is the (bad) root cause of my thread question "How To Make Firefox (plus system) Faster & Responsive By Disabling FF Default New Tab Settings Manually?" and it was most likely a bug from an add-on but haven't been able to clarify that...

Also, I do realize that:

 "The prefs.js file does not actually contain all of the settings. It only stores changes made to the defaults, after they are written back to disk. This normally occurs when you exit the Mozilla-based application.
 Prefs.js is a plain-text file that can be edited with a text editor. However, its recommended that you don't edit it directly since you can damage your profile if you make any mistakes. Its recommended you use one of the standard methods."

But, how the heck can I edit it if I am not able to open a 336Mb file? Could you plz explain that to me? Has anyone else had something like this happen? I'm really going out of my mind with paranoia...

Thank you very much, for your assistance, in advance.

Modificato da dimIS85 il

more options

You get multiple numbered prefs-##.js files when Firefox can't replace the main prefs.js.

Try to delete all these numbered prefs-##.js files and prefs.js to see if that allows Firefox to create a new prefs.js file. Firefox first creates a numbered prefs-##.js file when a new prefs.js file needs to be written. Once this numbered temp file has been created successfully then Firefox will delete prefs.js and rename the numbered prefs-##.js file to prefs.js. If the latter action fails then the numbered file will stay and the next time you get a numbered file with the next available number.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

It looks like you're ending up on a site that has been compromised (or intentionally runs mining software) which embeds itself in the browser. This doesn't seem to be anything to be paranoid about, as it would affect anyone who visits the site. Maybe if you can confirm the web site we can check it ourselves and will likely experience the same problem.

I'm not sure exactly why or how the site is storing such a large amount of data. Perhaps it is using the preview image as a means of storing data that can bypass other limits the browser has. I am fairly certain that this should be considered a bug in Firefox, so if you're able to give us the URL then we can log a bug report on your behalf (or you can do so yourself).

Deleting the enormous prefs.js won't break anything, you'll just return everything back to the defaults and might have to customise a few things again. Maybe back it up again (after closing Firefox to save its changes to the file) once you've made any customisations you want to keep in case it happens again.

This mining program likely would have made it through all your virus scanners because it's not technically a virus, it's just a program that runs in the browser like any other. Since it doesn't access your files or try to delete anything, there's no suspicious behaviour for a virus scanner to detect. You might suggest that the high CPU usage is a good thing to pick up on, but many programs use a lot of CPU so if the anti-virus software warned about this, there would be too many false positives.

So since this mining software looks and behaves almost like any other web site, it's very difficult to detect and remove. This is also why virus scanners can be of limited value, especially if you are careful when you browse and keep regular offline backups of your data.

Let us know what site you're visiting (assuming visiting that site in a clean browser profile does indeed start the mining software running) and we'll hopefully get it reported and fixed.

more options

Hello & Happy New Year,

Thank you very much both for your immediate replies and suggestions! I have already filed a bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1518140) moments ago...

Also, another issues I have noticed are the enormous webappsstore.sqlite, places.sqlite files and thousands of pending FF crash reports/over 2300 (I am currently submitting) from back to ...2011!!! I am attaching the corresponding screenshots...

Unfortunately, I am not able to recall the web-page that caused this mess, since I have already erased my past history (otherwise FF was not operable) and therefore cannot reproduce the problem...

To my disappointment, till now I realize that my firefox.exe executable, was "converted" into a 'zombie' app/hog consuming all of my resources (plus increasing my power bills and devastating my CPU/GPU), nothing more nothing less :-(

That's all for the time being. I am at your disposal if you need some further info...

Thank you,

Modificato da dimIS85 il

more options

You can remove the folder with the not submitted crash reports or possibly keep some recent crash reports.

You can remove webappsstore.sqlite. Firefox should vacuum places.sqlite when you click "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page. Under normal conditions Firefox only clears data in places.sqlite and doesn't reduce its size. If you have used the same profile that long since 2011 then maybe consider to create a new profile to remove no longer used files from older Firefox versions.