X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

All new emails marked as 'read' even before opening them

Inserita

Hi, I've noticed recently that incoming emails are landing in my inbox and marked as 'read', so I don't get notifications to say I have a new message.

I've turned my phone off, in case my mail app was causing the issue, but that made no difference. The automatically mark messages as read option is unchecked, so I'm a bit of a loss as to what to do.

Hi, I've noticed recently that incoming emails are landing in my inbox and marked as 'read', so I don't get notifications to say I have a new message. I've turned my phone off, in case my mail app was causing the issue, but that made no difference. The automatically mark messages as read option is unchecked, so I'm a bit of a loss as to what to do.
Citazione

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Ulteriori informazioni

MarkVictor 0 soluzioni 19 risposte

Risposta utile

Just as a test, try checking "Automatically mark messages as read" in Tools->Options->Display->Advanced, and choose the "5-second" option. This option should work for both POP and IMAPI. It might ensure messages don't get marked "read" on download.

If you've heard in the past some of what's below, please read quickly...! I want to cover all bases, so I've included as much information as I know.

In Thunderbird, there is no option available in Account Settings to mark messages as read in the GUI until 'after' a message has been downloaded and the user chooses to open that message (I didn't check for an "Open message on download" option). Again, this is true for both types of mail servers. However, I don't know if there is a Java/Javascript command that you can or should change. Those who may have knowledge about this, please help.

Who is your email provider and what type of server are you connected to? POP servers provide more simple connections; they simply upload all messages to your computer when you load Thunderbird and periodically according to your setting in Account Settings. IMAPI is more complex. Messages are downloaded to your computer and stay on the server until you delete them. In addition, some servers, particularly Google, provide no POP option. Messages are "synchronized"... usually.

Unless there is a documented bug/conflict among your operating system, T-Bird, and possibly other loaded active (or even paused/stopped!) program or application, I think the only other source of your problem is your email provider. (I have no problem with Verizon or Google in Windows 10, and I have far too many apps and programs on my active/paused/stopped lists!)

Just as a test, try checking "Automatically mark messages as read" in Tools->Options->Display->Advanced, and choose the "5-second" option. This option should work for both POP and IMAPI. It might ensure messages don't get marked "read" on download. If you've heard in the past some of what's below, please read quickly...! I want to cover all bases, so I've included as much information as I know. In Thunderbird, there is no option available in Account Settings to mark messages as read in the GUI until ''''''after'''''' a message has been downloaded '''and''' the user chooses to open that message (I didn't check for an "Open message on download" option). Again, this is true for both types of mail servers. However, I don't know if there is a Java/Javascript command that you can or should change. Those who may have knowledge about this, please help. Who is your email provider and what type of server are you connected to? POP servers provide more simple connections; they simply upload all messages to your computer when you load Thunderbird and periodically according to your setting in Account Settings. IMAPI is more complex. Messages are downloaded to your computer '''and''' stay on the server until you delete them. In addition, some servers, particularly Google, provide no POP option. Messages are "synchronized"... usually. Unless there is a documented bug/conflict among your operating system, T-Bird, and possibly other loaded active (or even paused/stopped!) program or application, I think the only other source of your problem is your email provider. (I have no problem with Verizon or Google in Windows 10, and I have far too many apps and programs on my active/paused/stopped lists!)
È stato utile questo messaggio? 1
Citazione

Utente che ha posto la domanda

Hi, Many thanks for the reply. I tried the '5 second' option, which does work, i.e. the email remains 'unread' for those 5 seconds, but then changes to read.

My email provider is Zoho, and I use IMAP settings on Thunderbird. I've had a look in those settings to see whether there's an option to automatically mark emails as read, but there doesn't seem to be. Weird thing this problem has only just started happening.

Hi, Many thanks for the reply. I tried the '5 second' option, which does work, i.e. the email remains 'unread' for those 5 seconds, but then changes to read. My email provider is Zoho, and I use IMAP settings on Thunderbird. I've had a look in those settings to see whether there's an option to automatically mark emails as read, but there doesn't seem to be. Weird thing this problem has only just started happening.
È stato utile questo messaggio?
Citazione
Toad-Hall
  • Top 10 Contributor
1496 soluzioni 9914 risposte

Risposta utile

Are they marked as read on the server before the folders in Thunderbird synchronise?

If you access the server via eg: phone or webmail or another computer or program that can download emails to read emails then they will get marked as read on server.

Another suggestion... have you ever used Outlook or other mail app on the computer ? If yes, then it is possible that email client is accessing the server and downloading emails. Please check this out. I've had reports of Outlook downloading in the background causing all kinds of confusion.

re :i.e. the email remains 'unread' for those 5 seconds, but then changes to read. But it should only do this, if you have clicked on that email in the list. It should not be marking anything as opened if you are not actually using the cursor to click on an email. left click once opens email in Message Pane, double left click opens in new tab, but both methods open emails. By the way, using the arrow keys to go up and down the list is also selecting to open the email.

If email is opened by another access point eg: phone, then it will be opened and therefore marked as read before Thunderbird imap synchronises with server.

Are they marked as read on the server before the folders in Thunderbird synchronise? If you access the server via eg: phone or webmail or another computer or program that can download emails to read emails then they will get marked as read on server. Another suggestion... have you ever used Outlook or other mail app on the computer ? If yes, then it is possible that email client is accessing the server and downloading emails. Please check this out. I've had reports of Outlook downloading in the background causing all kinds of confusion. re :i.e. the email remains 'unread' for those 5 seconds, but then changes to read. But it should only do this, if you have clicked on that email in the list. It should not be marking anything as opened if you are not actually using the cursor to click on an email. left click once opens email in Message Pane, double left click opens in new tab, but both methods open emails. By the way, using the arrow keys to go up and down the list is also selecting to open the email. If email is opened by another access point eg: phone, then it will be opened and therefore marked as read before Thunderbird imap synchronises with server.
È stato utile questo messaggio? 1
Citazione
Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.