Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Do you want to allow this app to make changes to your device?

  • 10 risposte
  • 2 hanno questo problema
  • 18075 visualizzazioni
  • Ultima risposta di RobertWA

more options

When I open Firefox I get a message “Do you want to allow this app to make changes to your device?” If I click on Yes everything then proceeds as normal. If I close Firefox and then re-open it, the same thing happens (even as soon as one minute - or less - later). This is recent behaviour (last couple of days) and there has been no known event which might have triggered this. Other browsers (Chrome, Edge) do not exhibit this behaviour. How can I fix this (or do I just switch browsers)? The settings re Compatibility Mode and Run as Administrator are both unchecked.

Thanks for any assistance.

Robert

Soluzione scelta

I would assume that there is still some shortcut present that sets Firefox to run as administrator. If you can't find this then uninstall and reinstall Firefox. Make sure that the Firefox program folder is removed after uninstalling.

You can find the full version of the current Firefox release (62.0.3) in all languages and all operating systems here:

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (10)

more options

Hello RobertWA,

You could change the User Account Control (UAC) settings:

Go to Windows Control Panel => User Accounts, and click "Change User Account Control settings".

This will open the User Account Control Settings window, where you make your choice.

Note: Don't disable it altogether.

Also see :

https://www.cnet.com/how-to/how-to-run-everything-in-administrator-mode-and-why-you-shouldnt-do-it/

(You'll have to scroll down some)

'Hope that helps ......

more options

Thanks McCoy,

I had already looked at this and the settings are as I would want them - the second one from the top - so that doesn't help.

I cannot understand why it is only Firefox which is affected - Chrome and Edge are fine. I would have thought that the UAC Settings would affect all apps similarly.

Cheers

Robert

more options

Bummer  !

Would you please take a look at this thread and see if maybe the Chosen Solution there (or one of the other suggestions) will work for you (fingers crossed) :

https://support.mozilla.org/en-US/questions/1185731

more options

Hi McCoy

Thanks again.

I had already looked at this but I have the same problem as rjottawa, ie


I tried this and had to change EFC...211B to the string in my case so it read: C:\Users\Owner\AppData\Local\Mozilla\updates\308046B0AF4A39CB

This was an empty file so using \0 (to start from the same pace as the advice) or \1, all I got was an error :" Windows can't find 'the string above' Check the spelling and try again".

How do I insert \0 or \1 on the end of a file name? Answer: I can't; \ / are forbidden characters. Back to square 1.

I also have 308046B0AF4A39CB

So, indeed, "Back to square 1."

Cheers,

Robert

PS Chrome is looking very enticing!!

more options

hello,go to start,type user accounts then administrator and put a tick on your software or program checkbox to allow,enjoy!

more options

Thanks Minja, but I couldn't follow the steps. After I typed "User accounts" there was no place to type Administrator. All I got was the option to "Add, edit or remove other people".

Could you provide a bit more detail, please, or tell me what I am doing wrong?

Thanks

Robert

more options

Check that Firefox isn't set to run as Administrator.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab.

Make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.

more options

Thanks, Cor-el,

Again, I looked at this before I posted, and both the Administrator and Compatibility boxes are unchecked.

Cheers,

Robert

more options

Soluzione scelta

I would assume that there is still some shortcut present that sets Firefox to run as administrator. If you can't find this then uninstall and reinstall Firefox. Make sure that the Firefox program folder is removed after uninstalling.

You can find the full version of the current Firefox release (62.0.3) in all languages and all operating systems here:

more options

Thanks, Cor-el,

Re-installing seems to have worked.

Cheers,

Robert