X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Whenever I start to type something in the search bar, no suggestions for websites or search suggestions pop up. How do I fix this?

Inserita

MacOS Mojave public beta

MacOS Mojave public beta

Soluzione scelta

Well, we did just erase history... Does Firefox suggest any of your bookmarked sites? If not, could you double-check these preferences (they correspond to various checkboxes on the Options page):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) These preferences have a default value of true, if they are bolded and "modified" to false, you can double-click them to restore them to true as desired:

  • browser.urlbar.suggest.bookmark
  • browser.urlbar.suggest.history
  • browser.urlbar.suggest.openpage ("switch to tab")
  • browser.urlbar.suggest.searches (search engine suggestions)

The following preference is sort of a master switch, but changing it tends to modify the others and vice versa. I'm not quite sure how it works, but it should be set to true:

  • browser.urlbar.autocomplete.enabled

Was there anything unexpected there?

Leggere questa risposta nel contesto 1

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 30.0 r0

Applicazione

  • Firefox 61.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:61.0) Gecko/20100101 Firefox/61.0
  • URL per il supporto: https://support.mozilla.org/1/firefox/61.0.1/Darwin/en-US/

Estensioni

  • AdBlocker Ultimate 2.31 (adblockultimate@adblockultimate.net)
  • Grammarly for Firefox 8.829.1781 (87677a2c52b84ad3a151a4a72f5bd3c4@jetpack)

Javascript

  • incrementalGCEnabled: True

Grafica

  • adapterDescription:
  • adapterDeviceID: 0x1626
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 1, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 1
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel(R) HD Graphics 6000
  • webgl1Version: 4.1 INTEL-12.0.17
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel(R) HD Graphics 6000
  • webgl2Version: 4.1 INTEL-12.0.17
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Preferenze modificate

Varie

  • User JS: No
  • Accessibilità: No
jscher2000
  • Top 10 Contributor
8635 soluzioni 70623 risposte

Hi raph871, have you noticed anything like the message described in the following article:

Fix "The bookmarks and history system will not be functional" error message

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi raph871, have you noticed anything like the message described in the following article: [[Fix "The bookmarks and history system will not be functional" error message]] Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Utente che ha posto la domanda

Sadly I have tried using safe mode and it has not helped. Also my bookmark system isn't working, I can't bookmark anything or change my bookmarks but my history is fine.

Sadly I have tried using safe mode and it has not helped. Also my bookmark system isn't working, I can't bookmark anything or change my bookmarks but my history is fine.
jscher2000
  • Top 10 Contributor
8635 soluzioni 70623 risposte

Hmm, it's troubling that bookmarks are just not working.

The Troubleshooting Information page has a "Verify Integrity" button to do a little light maintenance on the Places database (where bookmarks and history are stored). You can open that using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Then scroll way down or use Find to search for Integrity in the Places Database section. At first, nothing will seem to happen, but then several seconds after clicking the button Firefox should report some diagnostic results below it.

Please copy/paste the results somewhere safe, then quit/restart Firefox to see whether it helped.

Hmm, it's troubling that bookmarks are just not working. The Troubleshooting Information page has a "Verify Integrity" button to do a little light maintenance on the Places database (where bookmarks and history are stored). You can open that using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter Then scroll way down or use Find to search for ''Integrity'' in the Places Database section. At first, nothing will seem to happen, but then several seconds after clicking the button Firefox should report some diagnostic results below it. Please copy/paste the results somewhere safe, then quit/restart Firefox to see whether it helped.

Utente che ha posto la domanda

The Verify Integrity button has not done anything for me yet, I pressed it as soon as I received the email that you replied and still nothing has happened.

The Verify Integrity button has not done anything for me yet, I pressed it as soon as I received the email that you replied and still nothing has happened.
jscher2000
  • Top 10 Contributor
8635 soluzioni 70623 risposte

Have you shut down and restarted your Mac since this problem began? I wonder if there is a random file lock or privileges issue. Maybe that only happens on Windows...

Have you shut down and restarted your Mac since this problem began? I wonder if there is a random file lock or privileges issue. Maybe that only happens on Windows...

Utente che ha posto la domanda

Yes I have done this countless times, also reinstalled firefox, refreshed all preferences, etc but nothing has changed. This problem has been going on for about a month now and it has only been ever since I downloaded MacOS Mojave so maybe Firefox is not optimized for this update yet as it is only a beta, but I still would love to figure out how to stop it because for my school work there are many websites I have to go to that aren't very accessible just from searching a term and also I can't bookmark them.

Yes I have done this countless times, also reinstalled firefox, refreshed all preferences, etc but nothing has changed. This problem has been going on for about a month now and it has only been ever since I downloaded MacOS Mojave so maybe Firefox is not optimized for this update yet as it is only a beta, but I still would love to figure out how to stop it because for my school work there are many websites I have to go to that aren't very accessible just from searching a term and also I can't bookmark them.
jscher2000
  • Top 10 Contributor
8635 soluzioni 70623 risposte

Risposta utile

You might need to dump the Places database and have Firefox generate a new one. This will remove all history and bookmarks, and Firefox should automatically restore the last automatic bookmark backup. Since it's not 100% reliable, you should keep a copy of the database in case you need to revert to it.

Make a Bookmark Backup

Firefox has two formats and I recommend creating both:

Remove the Places database

This is the file that stores history and bookmarks. Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. This should launch a new window listing various files and folders in Finder. (If Finder shows a folder with a name like a1b2c3d4.default selected, double-click into that folder.)

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit Firefox

Pause while Firefox finishes its cleanup, then rename places.sqlite to something like placesOLD.sqlite. If you see files named places.sqlite-shm and/or places.sqlite-wal, you can delete those.

When you start Firefox back up again, it should attempt to rebuild your bookmarks from the latest automatic backup. If that doesn't work, you can restore/import from one of the backups you made in the first step (only one needs to work):

Any improvement?

You might need to dump the Places database and have Firefox generate a new one. This will remove all history and bookmarks, and Firefox should automatically restore the last automatic bookmark backup. Since it's not 100% reliable, you should keep a copy of the database in case you need to revert to it. '''''Make a Bookmark Backup''''' Firefox has two formats and I recommend creating both: * JSON-format "backup" file: [[Restore bookmarks from backup or move them to another computer]] * HTML-format "export" file: [[Export Firefox bookmarks to an HTML file to back up or transfer bookmarks]] '''''Remove the Places database''''' This is the file that stores history and bookmarks. Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. This should launch a new window listing various files and folders in Finder. (If Finder shows a folder with a name like a1b2c3d4.default selected, double-click into that folder.) Leaving that window open, switch back to Firefox and Quit, either: * "3-bar" menu button > Quit * (menu bar) Firefox > Quit Firefox Pause while Firefox finishes its cleanup, then rename '''places.sqlite''' to something like placesOLD.sqlite. If you see files named places.sqlite-shm and/or places.sqlite-wal, you can delete those. When you start Firefox back up again, it should attempt to rebuild your bookmarks from the latest automatic backup. If that doesn't work, you can restore/import from one of the backups you made in the first step (only one needs to work): * "Restore" the JSON file: [[Restore bookmarks from backup or move them to another computer]] * "Import" the HTML file: [[Import Bookmarks from an HTML file]] Any improvement?

Utente che ha posto la domanda

Thanks I can now bookmark things which is great but for some reason the search still won't suggest any websites.

Thanks I can now bookmark things which is great but for some reason the search still won't suggest any websites.
jscher2000
  • Top 10 Contributor
8635 soluzioni 70623 risposte

Soluzione scelta

Well, we did just erase history... Does Firefox suggest any of your bookmarked sites? If not, could you double-check these preferences (they correspond to various checkboxes on the Options page):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) These preferences have a default value of true, if they are bolded and "modified" to false, you can double-click them to restore them to true as desired:

  • browser.urlbar.suggest.bookmark
  • browser.urlbar.suggest.history
  • browser.urlbar.suggest.openpage ("switch to tab")
  • browser.urlbar.suggest.searches (search engine suggestions)

The following preference is sort of a master switch, but changing it tends to modify the others and vice versa. I'm not quite sure how it works, but it should be set to true:

  • browser.urlbar.autocomplete.enabled

Was there anything unexpected there?

Well, we did just erase history... Does Firefox suggest any of your bookmarked sites? If not, could you double-check these preferences (they correspond to various checkboxes on the Options page): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''URLB''' and pause while the list is filtered (3) These preferences have a default value of true, if they are bolded and "modified" to false, you can double-click them to restore them to true as desired: * browser.urlbar.'''suggest'''.bookmark * browser.urlbar.'''suggest'''.history * browser.urlbar.'''suggest'''.openpage ("switch to tab") * browser.urlbar.'''suggest'''.searches (search engine suggestions) The following preference is sort of a master switch, but changing it tends to modify the others and vice versa. I'm not quite sure how it works, but it should be set to true: * browser.urlbar.'''autocomplete'''.enabled Was there anything unexpected there?