Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Why does FireFox consume all 32G Memory + 16 Gig Swap + all 8 Cores

  • 2 risposte
  • 1 ha questo problema
  • 3 visualizzazioni
  • Ultima risposta di Shadow110

more options

I have FireFox 58.0.2 64 bit installed from the Fedora Linux repository, but FireFox 57 did the same thing. Sad to see this as I have been using FireFox from the very beginning, and of the 15 Browsers I run on this machine, FireFox was in the top 5. I run 15 different browsers for testing reasons, 10 of them at a time, if I INCLUDE FireFox Browser as one of the 10 that are Running, it brings my powerful system to its knees, and in a matter of hours hangs this powerful system. Each browser runs with only 2 Tabs open. Any mix of any 10 of the 15 Browsers WITHOUT FireFox, runs in a stable and speedy manner indefinitely.

So Yes, this is clearly to me, a serious memory leak in FireFox Quantum.

I am running Adobe Flash in all browsers. Running on Fedora Linux 26 KDE with the most up to date Adobe Flash 29.0.0.113 On my 2 Windows 10 Laptops, FireFox also bogs the system down. On Fedora Linux 25 FireFox does the same thing again.

I am going to try to revert back to pre-Quantum FireFox, as the older versions worked just fine. I will check back in a few months to see if Mozilla has figured out this serious memory leak yet. I am sad for the Mozilla QA team, as this does not look good for them. Remember to "eat your own dogfood guys" Thanks and best of luck.

Tutte le risposte (2)

more options

I forgot to mention that I went through the "FireFox Refresh" method previously as described here in support, with the refreshed Profile this made an improvement as FireFox then ran faster, but evidently this did not resolve the memory leak. I have tried every tip and suggestion I could find here in support, but the memory leak problem is still there, this is why I am reverting to an older pre-Quantum Firefox.

more options

You could try this please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Note : Acceleration is for your Video Card, monitor to see if need to turn back on. https://support.mozilla.org/en-US/kb/performance-settings

Please leave the check mark in Prevent Accessibility Services.

Please let us know if this solved your issue or if need further assistance