Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Youtube won't play on Firefox but will on other browsers

  • 5 risposte
  • 9 hanno questo problema
  • 65883 visualizzazioni
  • Ultima risposta di mgmm1

more options

Since yesterday, Youtube hasn't been working on Firefox. The page loads, but then the video itself just won't play. The black screen comes up and then a circle, saying it's loading but it just never does. I've tried:

- Using Firefox in safemode, which caused YouTube to work again. I then re-entered the normal mode an disabled my only add-on (AdBlock Plus), but YouTube still didn't work. - Deleting my cache/history - Doing the windows+r thing, and deleting temporary files, which someone else on the website suggested - Refreshing Firefox

None of these solutions have worked. On my 'plugins' section, Widevine something and OpenH264 something will be installed shortly, but I don't know if that'll change anything, and it's been saying that since yesterday.

Soluzione scelta

'I found this solution in another feed. It seems to have solved my problem with the streaming video issue.


Chosen solution

Another thing to try : Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  Select the Advanced panel and the General tab.
  Uncheck Use hardware acceleration when available.
  Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

  Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  Select the General panel.
  Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
  Fx55Performance-disableHWA
  Uncheck Use hardware acceleration when available.
  Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

  Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
  Upgrade your graphics drivers to use hardware acceleration and Web
Leggere questa risposta nel contesto 👍 2

Tutte le risposte (5)

more options

Sorry, I meant that it says those two plugins will be installed shortly, but they just haven't been.

more options

Soluzione scelta

'I found this solution in another feed. It seems to have solved my problem with the streaming video issue.


Chosen solution

Another thing to try : Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  Select the Advanced panel and the General tab.
  Uncheck Use hardware acceleration when available.
  Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

  Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  Select the General panel.
  Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
  Fx55Performance-disableHWA
  Uncheck Use hardware acceleration when available.
  Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

  Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
  Upgrade your graphics drivers to use hardware acceleration and Web
more options

Thank you! I saw that solution on the original thread just moments before I saw your reply, and it solved my problem.

more options

You're welcome, I'm happy it worked for you.

more options

Unchecking the Performance option solve my issue as well. Thanks for posting.