X
Tocca qui per la versione per piattaforma mobile del sito.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

can't record a video using adobe flash on firefox

Inserita

Hello

I am trying to set up a discussion in Canvas. When I click on Record/Upload Media, a window pops up with Adobe Flash Player Setting asking me to click on Allow, nothing works on the window...However when I do the same on Safari and Chrome, no problem it works... I am also having mega problems on another online platform "Portails" when I also use Firefox (I suspect this is a Flash player problem...) and same thing, when I use Chrome everything works...I have uninstalled and reinstalled Firefox and downloaded the latest version of Adobe flash player..it did not help...I have a Mac Pro... thanks...

Hello I am trying to set up a discussion in Canvas. When I click on Record/Upload Media, a window pops up with Adobe Flash Player Setting asking me to click on Allow, nothing works on the window...However when I do the same on Safari and Chrome, no problem it works... I am also having mega problems on another online platform "Portails" when I also use Firefox (I suspect this is a Flash player problem...) and same thing, when I use Chrome everything works...I have uninstalled and reinstalled Firefox and downloaded the latest version of Adobe flash player..it did not help...I have a Mac Pro... thanks...

Soluzione scelta

It's normal for a user to need to give a site permission to use the Flash plugin. To bypass that, you can make a change on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins.

On the right side, find "Shockwave Flash" and change "Ask to Activate" to "Always Activate".

When you reload the problem page and try to access your camera/microphone, you should now get whatever permission prompt the Flash plugin presents, without first having to interact with Firefox's permission prompt.

Any improvement?


If not, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. Flash still runs.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of option/alt.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


Do you know whether this issue occurs on other platforms or only on MacOS?

Leggere questa risposta nel contesto 1

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36

Ulteriori informazioni

WestEnd 60 soluzioni 5387 risposte

Each of those Browser uses different flash version so you should see and install the latest Flash to see what happens. Otherwise you need to contact Adobe support for flash problems.

Each of those Browser uses different flash version so you should see and install the latest Flash to see what happens. Otherwise you need to contact Adobe support for flash problems.

Risposta utile

There is no live support for adobe flash player

There is no live support for adobe flash player
jscher2000
  • Top 10 Contributor
8953 soluzioni 73374 risposte

Soluzione scelta

It's normal for a user to need to give a site permission to use the Flash plugin. To bypass that, you can make a change on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins.

On the right side, find "Shockwave Flash" and change "Ask to Activate" to "Always Activate".

When you reload the problem page and try to access your camera/microphone, you should now get whatever permission prompt the Flash plugin presents, without first having to interact with Firefox's permission prompt.

Any improvement?


If not, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. Flash still runs.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of option/alt.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?


Do you know whether this issue occurs on other platforms or only on MacOS?

It's normal for a user to need to give a site permission to use the Flash plugin. To bypass that, you can make a change on the Add-ons page. Either: * Command+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and change "Ask to Activate" to "Always Activate". When you reload the problem page and try to access your camera/microphone, you should now get whatever permission prompt the Flash plugin presents, without first having to interact with Firefox's permission prompt. Any improvement? ---- If not, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. Flash still runs. ''If Firefox is not running:'' Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of option/alt.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? ---- Do you know whether this issue occurs on other platforms or only on MacOS?

Utente che ha posto la domanda

Someone at Canvas figured it out... I think we did Firefox Safe mode and it fixed it! thanks for the help...

Someone at Canvas figured it out... I think we did Firefox Safe mode and it fixed it! thanks for the help...
jscher2000
  • Top 10 Contributor
8953 soluzioni 73374 risposte

Okay, check whether it's one of the extensions.

If not, it could be an incompatibility with your graphics card/chipset driver software. You can temporarily disable hardware acceleration in normal mode (see: Firefox's performance settings) and check for updates (see: Upgrade your graphics drivers to use hardware acceleration and WebGL).

Okay, check whether it's one of the extensions. If not, it could be an incompatibility with your graphics card/chipset driver software. You can temporarily disable hardware acceleration in normal mode (see: [[Firefox's performance settings]]) and check for updates (see: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]).