Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Does Firefox Quantum support flash player?

  • 6 risposte
  • 8 hanno questo problema
  • 382 visualizzazioni
  • Ultima risposta di James

more options

I like to play flash games. Sometime around Firefox v 50 or so, it stopped supporting flash players and I've had to uninstall it and reinstall an older version that works with my games. Some people with newer machines found they could eventually get a flash player working on the newer ones but it was very laggy and most of them also ended up downgrading their Firefox. Does this Firefox Quantum that I just got an email about actually work with flash games?

Tutte le risposte (6)

more options

Yes, Flash Player will be supported in all browsers until 2020!

more options

Firefox 59 won't allow me to enable flash. it won't allow plugins that use flash.

So, no Flash player is not being supported Until 2020. The only people that believe that Flash is being supported are apparently Adobe's Digital Rights Management team, and Comcast/Xfinity.

more options

Hi Itsune9tl, what happens when you try to enable Flash? By that, I mean:

(A) Default Permission

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins.

On the right side, find "Shockwave Flash" and change its permission to "Ask to Activate" (or "Always Activate" if you don't care what sites can use Flash).

(B) Site Permission

With "Ask to Activate," when you visit a site that wants to use Flash, you should see a notification icon in the address bar. The icon typically is light gray is the page needs permission to use Flash, and dark gray if permissions has been granted.


If you need a test page, I have one here that tries to read your Flash version: https://www.jeffersonscher.com/res/plugins.html

It should show 29.0.0.113 if you have updated recently.

more options

No flash support- Wether Shockwave or Adobe.

Firefox compatibility docs.

more options

Hi Itsune9tl, I'm not sure of the point of your link. There's no problem with Flash on Windows versions of Firefx.

Try reinstalling Flash to make sure you have the Firefox-compatible version of the plugin: https://get.adobe.com/flashplayer/otherversions/

Assuming successful installation, exit Firefox and start it up again to trigger a re-scan of the plugins list in the Windows registry. Does it now appear on the Add-ons page?

More info:

more options

Itsune9tl said

Firefox 59 won't allow me to enable flash. it won't allow plugins that use flash. So, no Flash player is not being supported Until 2020.

The NPAPI Flash Player Plugin from Adobe is indeed being supported until late 2020, though with increasing restrictions over time.

https://developer.mozilla.org/docs/Plugins/Roadmap https://theblog.adobe.com/adobe-flash-update/

You appear to have a old version of Flash 27 when current Release from Adobe is 29.0.0.113 https://get.adobe.com/flashplayer/

The Flash 27.0.0.159 and older is on addons.mozilla.org/blocked/ blocklist for click to play soft blocking due to critical vulnerabilities.


Itsune9tl said

No flash support- Wether Shockwave or Adobe.

The old name for Flash player from Adobe is Shockwave Flash and is being supported stil.

It is other NPAPI Plugins like Silverlight, Java and such that are not allowed to run in Firefox Releases but is allowed on Firefox 52 ESR. https://support.mozilla.org/en-US/kb/npapi-plugins

Modificato da James il