Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Some Cyrillic (Russian) font does not look correctly

  • 7 risposte
  • 1 ha questo problema
  • 1293 visualizzazioni
  • Ultima risposta di and.g.000

more options

Some Cyrillic (Russian) font does not look correctly. Just some web site with Russian fonts. Most of all looks great. It's look like Firefox doesn't know some specific font. Other browser EI and Chrome can show the same page correctly. How I can solve the problem? Thanks.

Soluzione scelta

cor-el said

That website uses a downloadable font named "Open Sans Regular" as you can see in the Inspector. We have seen issues reported before with this specific font.

Thank you again cor-el I used "Inspect Element" through right click on my mouse. I came to the same conclusion - My problem is the system font "Open Sans Regular". I found it in my system fonts folder, it's look well and the file reads correctly. Anyway I download new font file from the web and replaced (reinstall) my ttf file. - and problem solved Now. P.S. I do not really know what particular point of this solution. now I little sorry that I didn't make a copy of my old Open Sans Regular TTF file. But like I said at first sight, it looked good.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (7)

more options

Please provide public (no password) link(s) that we can check out. No Personal Information Please !


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

more options

Can you attach a screenshot?


This could be related with the recent switch in Firefox 52+ from Cairo to Skia for canvas/content rendering.

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering.

You can modify these gfx.*.azure.backends prefs on the about:config page to revert to the old font rendering swap the skia,cairo order to cairo,skia or remove the skia and leave cairo.

  • gfx.canvas.azure.backends = direct2d1.1,cairo,skia
  • gfx.content.azure.backends = direct2d1.1,cairo,skia

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

my screenshot from there http://leshaigraet.ru/vote-about-stream/

Modificato da and.g.000 il

more options

cor-el said

You can modify these gfx.*.azure.backends prefs on the about:config page to revert to the old font rendering swap the skia,cairo order to cairo,skia or remove the skia and leave cairo.

  • gfx.canvas.azure.backends = direct2d1.1,cairo,skia
  • gfx.content.azure.backends = direct2d1.1,cairo,skia
it didn't work for me

Modificato da and.g.000 il

more options

FredMcD said

Please provide public (no password) link(s) that we can check out. No Personal Information Please !

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Yes I tried it first of all - it works. If I turn off "Allow Web Sites To Choose Their Own" - I can see web page correctly. But I think it is not good solution because I miss the individual design of web pages.

That about "Detected via Flash" - I see the all fonts correctly (thank you for interesting link)

Modificato da and.g.000 il

more options

That website uses a downloadable font named "Open Sans Regular" as you can see in the Inspector.

We have seen issues reported before with this specific font.

more options

Soluzione scelta

cor-el said

That website uses a downloadable font named "Open Sans Regular" as you can see in the Inspector. We have seen issues reported before with this specific font.

Thank you again cor-el I used "Inspect Element" through right click on my mouse. I came to the same conclusion - My problem is the system font "Open Sans Regular". I found it in my system fonts folder, it's look well and the file reads correctly. Anyway I download new font file from the web and replaced (reinstall) my ttf file. - and problem solved Now. P.S. I do not really know what particular point of this solution. now I little sorry that I didn't make a copy of my old Open Sans Regular TTF file. But like I said at first sight, it looked good.

Modificato da and.g.000 il