Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Question marks instead of words on some websites

  • 19 risposte
  • 112 hanno questo problema
  • 21906 visualizzazioni
  • Ultima risposta di Imaginist

more options

On certain websites (specifically the one my school uses) there are no words popping up. Only question marks in boxes. Other websites, like facebook are totally normal. I made sure that the websites were given permissions to pick their own fonts and this did not fix the problem. Thanks

Soluzione scelta

If you see a question mark then it is possible that the server sends the file with a Windows or Western encoding instead of with Unicode.

You can check the encoding here:

  • View -> Text Encoding

Can you attach a screenshot and possibly give some links?

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (19)

more options

Hello, When The question mark in a box shows, it usually means your computer can not display the character to you.

Firefox recently updated to 54.0.1, have you installed that?

This, seems like an issue with the website and not Firefox.

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

more options

Other Mac users have reported similar things, but I don't think we've found a definitive explanation for what caused it, so that makes it hard to propose fixes.

more options

Soluzione scelta

If you see a question mark then it is possible that the server sends the file with a Windows or Western encoding instead of with Unicode.

You can check the encoding here:

  • View -> Text Encoding

Can you attach a screenshot and possibly give some links?

more options
more options

carolinchicago have you checked out the above?

more options

Fred, I tried everything except disabling Suitcase Fusion. That I am not willing to do. I downgraded Firefox instead.

more options

That is up to you. But as a test, you can disable Suitcase Fusion to see if it is the problem.

more options

Turned off Suitcase. No improvement.

more options

carolinchicago

Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief. Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

more options

What font is used on these pages?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

We have seen cases where a box with all '?' or all 'A' is displayed that might be related to using a Last Resort font that displays all the glyphs with one same character.

more options

Hi carolinchicago, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. You might have those same fonts in TrueType or OpenType format, but Firefox may not be seeing them for one reason or another.

As a temporary workaround, you can reduce the sandbox level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox.

Does that work on your Firefox?

more options

Have had the same problem since upgrading to latest Firefox. Any pages that give me this problem view fine in Safari and Chrome.

Too many people are having the same problem for it to be an individual problem due to their computer/browser/set-up. Clearly it's a problem with the latest upgrade to Firefox.

Where's the fix?!?!?!

At this rate I'll just use Chrome for everything - fed up flicking between the two.

more options

Hi ignitedc

Do you still have this problem in Firefox 57?


We have seen cases where boxes instead of the real character are displayed that might be related to using a Last Resort font that displays all the glyphs with one same character like a '?'. or 'A' or an empty box.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox. If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Note that this workaround is only necessary for Firefox 56 and should be fixed in Firefox 57. Remember to reset this pref via the right-click context menu to the default value once you have updated to a Firefox version that fixes this since this is a security feature.

more options

I am already using Firefox 57.

This is f***ed, I shouldn't have to go in and edit configurations because Firefox can't get their s*** together.

Never had this problem in previous version of Firefox, upgraded to version 57 and now this happens regularly on various pages, in emails etc etc etc.

more options

Hi ignitedc, the font your having problems with on that page is Arial. I think this also is the font used on the Google results page and many other sites.

If this is not caused by the sandbox, there may be a font corruption issue that Firefox is sensitive to, but Safari isn't.

But if you no longer care to use Firefox, then, never mind.

more options

You can check on the Font tab in the Inspector what font Firefox uses as a substitute of the specified font.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

Solved the problem on my Mac. Cause: corrupt Helvetica Neue font. Solution: removed it with my fontapplication. (In my case FontExplorer X by Linotype.)