Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

I'm not allowed to see anything on my browser except for the letter A in a box. What should I do?

  • 19 risposte
  • 4 hanno questo problema
  • 191 visualizzazioni
  • Ultima risposta di EvBond

more options

Whenever I go online using firefox I can't see any of the text because all I see is the letter A in a box and I'm not able to use firefox at all. I refreshed firefox, delete and reinstall and still have the same problem. Is there anything I should do?

Tutte le risposte (19)

more options

This is kind of hard to picture. If you type a search into the address bar (for example firefox) and press Enter to submit it to your default search engine site, can you get a page of results, or is that also only "A"?

Does the A look like someone's logo? Maybe you could post a screenshot showing what it looks like, or if there is an unusual address in the address bar, reply with a copy/paste of the address.

If you aren't familiar with taking screenshots of different programs, this article might be useful: How do I create a screenshot of my problem? Please cut out or blur any sensitive information in the image before attaching it to a reply.

more options

Start Firefox in Safe Mode by holding down the <Shift> (Mac=Options) key, and then starting Firefox. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

This is what my screen looks like and no starting in safe mode does not work.

more options

Wow.

Is the problem limited to HTTPS pages? For example, can you view text normally on HTTP pages, or on internal Firefox pages?

Example HTTP page: http://www.jeffersonscher.com/res/jstest.php

As an example of an internal page, can you call up the Troubleshooting Information page from the Help menu and if it's readable, copy/paste the "Graphics" section into a reply?

more options

It is possible that there is a problem with the font that is used to display the text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Options/Preferences -> Content : Fonts & Colors -> Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
more options

Hi   !
My first reaction was :   " and it's not even April 1st ......"
Then I found   this .......

more options

I'm able to go on to firefox and http://www.jeffersonscher.com/res/jstest.php and see everything clearly, but if i go onto any other website it looks exactly the same with the problem I'm having.

more options

Are you using any 3rd party font handlers, like fontexplorer  ? If so :   disable them and see if that works.

more options

adosunmu said

I'm able to go on to firefox and http://www.jeffersonscher.com/res/jstest.php and see everything clearly, but if i go onto any other website it looks exactly the same with the problem I'm having.

Sorry, I should have had you contrast the secure connection to the same page to try to see whether it's HTTPS-specific:

https://www.jeffersonscher.com/res/jstest.php

more options

I believe it is https specific

more options

adosunmu said

I believe it is https specific

So you're sure the fonts on this page are readable:

http://www.jeffersonscher.com/res/jstest.php

but on this page some or all of the characters are replaced with boxed A's:

https://www.jeffersonscher.com/res/jstest.php

more options

I have exactly the same problem. Had this on Google Chrome a few yrs ago so switched to FF - and has been fine for years and then today, Bang - everything is Cap A - and I've not changed anything on my system. I run FontAgent Pro for font mgmt and I know that can cause issues - as can PostScript fonts, but I did not change anything with my Mac and this morning it's all A's - see attached. Very odd. Fonts display fine on the jeffersonscher website above so not sure it is https specific

more options

I don't have a Vimeo account, so I'm going to ask you to figure out which are the fonts that are working and which are not using Firefox's Page Inspector.

If you right-click (or on a one-button mouse, Ctrl+click) a line of boxed A's and choose Inspect Element, Firefox should open a panel in the lower part of the tab with an HTML tree diagram with the element you right-clicked selected. On the right side there are several panels including Rules and most importantly Fonts. If you display the Fonts panel, it should show what fonts Firefox is attempting to use for that line.

There is a little "click to select" icon at the upper left of the Inspector. If you click that, then click some other working/non-working text in the page, you should be able to learn what fonts Firefox is attempting to use there. For adjacent lines, clicking in the HTML tree may be faster.

The goal is to make a list of working and non-working fonts. In some cases, it may be the same font family (e.g., Arial) but different weights/styles (e.g., Regular is OK but Bold is broken, or vice versa).

What do you find?

more options

EvBond You may not have made any changes, but the programs and files get updated now and then.

more options

Hi jscher2000 - thanks for helping me out - bizarrely it says helvetica neue - didn't know that was a websafe font - looks like it's a lastResort font too - whatever that means - see attached screengrab (I am on a Mac by the way PowerMac late 2013 running Yosemite 10.10.5)

more options

Hi EvBond, thank you for looking that up.

Helvetica Neue is a font commonly found on Mac's, rarely on Windows, and many sites use it in preference to Helvetica and Arial if it's found on a system. I have no idea why your Firefox is using LastResort in place of Helvetica Neue.

If you look a little further down in that Fonts panel, do you see a style rule starting with @font-face that is making the substitution? You can use the Rules panel to skim down and look for that rule. It should have a little link on the right side which points to the file that contains it. That might be part of the website or part of an extension; I don't think it's part of Firefox itself or this thread would have hundreds of participants by now....

more options

Hi EvBond, in other threads, users are reporting that on their Macs, Firefox 56 is replacing Arial with LastResort, so that breaks huge parts of the web. Some of these users use a program named Suitcase Fusion. I don't know if you also use that. It's not clear whether that is a factor.

more options

Hi EvBond, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. You might have those same fonts in TrueType or OpenType format, but Firefox may not be seeing them for one reason or another.

As a temporary workaround, you can reduce the sandbox level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from its default value of 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox.

Does that work on your Firefox?

more options

Hi jscher2000. That absolutely worked! Yes, perfect, thank you very much. And no more lastResort being read as a font in my Inspector - they are all being read as helveticaNeue. Wow I wish FF would warn us about this security sandbox. It was such a asimple fix at the end but what a mission to get to. Thanks so much for persevering with this problem. You rock!! :-))