X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

firefox loads blank page but other browsers show the content

Inserita

Firefox shows a blank page for a website or document. Other browsers show the webpage or document, so not a connection problem.

Firefox shows a blank page for a website or document. Other browsers show the webpage or document, so not a connection problem.

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 25.0 r0

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

Ulteriori informazioni

jscher2000
  • Top 10 Contributor
8695 soluzioni 71066 risposte

Do you have the same problem for all sites or is there any pattern to what works?

I'll mention something that's been going around this month: several users with this combination --

Recent Windows 10 update + Norton security + Malwarebytes Premium

-- have reported being unable to connect to any sites and the upper right "X" button not working. It appears to be a conflict between Firefox's multiprocess feature and the Malwarebytes Exploit Protection feature.

As a workaround, you can either: (1) turn off Exploit Protection in Malwarebytes (either completely or for Firefox (firefox.exe), or (2) turn off multiprocess in Firefox.

Multiprocess. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Firefox assess whether your current configuration is compatible during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Could you investigate:

Are you using Multiprocess (e10s)?

Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing problems, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

Do you have the same problem for all sites or is there any pattern to what works? <p>I'll mention something that's been going around this month: several users with this combination --</p> <p>Recent Windows 10 update + Norton security + Malwarebytes Premium</p> <p>-- have reported being unable to connect to any sites and the upper right "X" button not working. It appears to be a conflict between Firefox's multiprocess feature and the Malwarebytes Exploit Protection feature.</p> <p>As a workaround, you can either: (1) turn off Exploit Protection in Malwarebytes (either completely or for Firefox (firefox.exe), or (2) turn off multiprocess in Firefox.</p> <p><em><strong>Multiprocess</strong></em>. Recent versions of Firefox are migrating more users to a "multiprocess" architecture where the user interface and the web content are in separate processes to improve stability. Firefox assess whether your current configuration is compatible during the first run -- first run after installation or first run after a Refresh -- and if it is, enables it going forward for future runs. Could you investigate:</p> <p><em>Are you using Multiprocess (e10s)?</em></p> <p>Multiprocess creates a second firefox.exe or plugin-container.exe process to isolate the web content from the browser UI. You can check whether you have this feature turned on as follows. Either:</p> <ul> <li>"3-bar" menu button &gt; "?" button &gt; Troubleshooting Information</li> <li>(menu bar) Help &gt; Troubleshooting Information</li> <li>type or paste about:support in the address bar and press Enter/Return</li> </ul> <p>In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.</p> <p><em>If you are using e10s:</em></p> <p>To help evaluate whether that feature is causing problems, you could turn it off as follows:</p> <p>(1) In a new tab, type or paste <strong>about:config</strong> in the address bar and press Enter/Return. Click the button promising to be careful.</p> <p>(2) In the search box above the list, type or paste <strong>autos</strong> and pause while the list is filtered</p> <p>(3) Double-click the <strong>browser.tabs.remote.autostart.2</strong> preference to switch the value from true to false</p> <p><em>Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart</em></p> <p>At your next Firefox startup, it should run in the traditional way. Any difference?</p>