Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox not displaying all web pages correctly

  • 9 risposte
  • 6 hanno questo problema
  • 7149 visualizzazioni
  • Ultima risposta di Tim_Brooks

more options

I have tried just about everything and no luck. Firefox mysteriously started displaying ALL web pages incorrectly (broken frames) It was working fine until today. I'm running Windows 8.1, Firefox version 47 on a thinkpad yoga 1.5 yr old.

I have tried all solutions from previous postings and threads (from Tech_Chaos on 10/26/15) and no luck:

  • started firefox on safe mode,
  • disabled all extensions
  • Clear the Cache
  • Turn off hardware acceleration
  • Turn off Norton Antivirus suite

Any assistance to resolve this problem would be appreciated. I like firefox but this my force me to other browsers....

Soluzione scelta

You're definitely missing a lot of the standard coloration, some of which is shown in the attached screenshot.

Are you using a "high contrast" theme in Windows? That can trigger Firefox not using background colors and background images. To counter that, check this setting on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Content. Then on the right side, click the Colors button. There's a selector halfway down the box:

"Override the colors specified by the page with my selections above:"

Select Never and click OK.

Does that help at all?

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (9)

more options

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Also, press Alt to bring up the main menu > View > Page Style, and make sure it is set to Basic Page Style.

more options

Thank you for your kind replies...But nothing seems to work.... Attached please find a webpage screenshot (cnn.com) as requested and point of reference.

Any other suggestions to solve this problem are appreciated.

more options

Soluzione scelta

You're definitely missing a lot of the standard coloration, some of which is shown in the attached screenshot.

Are you using a "high contrast" theme in Windows? That can trigger Firefox not using background colors and background images. To counter that, check this setting on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Content. Then on the right side, click the Colors button. There's a selector halfway down the box:

"Override the colors specified by the page with my selections above:"

Select Never and click OK.

Does that help at all?

more options

See also this about the high contrast setting in Windows:

more options

Solved: Tools>Options>Content>Colors> Select: Never A big thanks to jscher2000 for providing the solution.

It is not clear why the web pages became broken. But this is the solution.

more options

I have a problem with firefox loading a page correctly , then after a couple of seconds automatically refreshing, and losing formatting - this sometimes results in content being hidden - see screenshots below - before and after this automatic refresh.

I observe a flash of green at the top of the screen as this refresh happens, but it is too fast to see if there is any message there.

This seems to happen to a greater or lesser degree on all sites that I open

more options

Hi Tim_Brooks, the images are very small, but what seems to be missing are the navigation links along the top. Is that the standard pattern, that website menus disappear?

Since your problem doesn't seem to be related to high contrast themes, could you start a new question and include links to example sites where you have this problem. You can do that using the following link:

https://support.mozilla.org/questions/new/desktop/websites

Please scroll down past article suggestions to continue filling in the form.

more options

The problem was more general than that - web pages were loading correctly - so that they looked the same in Firefox as they do in IE, then a moment later the screen was refreshing and a lot of the formatting was getting lost - text missing as above, background colours missing, fonts incorrect. What I had observed was a brief flash of green at the top of the page as the refresh occurred - and eventually, by hitting 'refresh' multiple times was able to read that this was something to do with an application/trojan 'Jollywallet' - which I had not knowingly installed. Running various cleaning tools seemed to have no effect, nor was Jollywallet listed in installed applications. However, the problem seems now to have gone away - Not, I believe as the result of anything I have consciously done!

Modificato da Tim_Brooks il