Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Youtube doesn't load properly anymore.

  • 3 risposte
  • 9 hanno questo problema
  • 8980 visualizzazioni
  • Ultima risposta di Phoxuponyou

more options

Greetings

Youtube currently loads as shown in the attached file. I tries safe mode, refreshing firefox, and clearing cache and cookies, nothing worked.

Thank your for your ongoing support.

Immagini allegate

Soluzione scelta

Hi there. You're certainly right in that it appears Youtube isn't loading all of its content, but it might also be that it's just not allowed to display it.

First, is there a reason why you're using Firefox 44.0.2? The latest is 45.0.1 and there's an entry in the release notes about performance regression being fixed with Youtube, so you should try to update Firefox: https://support.mozilla.org/en-US/kb/update-firefox-latest-version.

These days Youtube doesn't require Java or Flash to play videos, but you should visit https://www.mozilla.org/en-US/plugincheck/ to make sure your Plugins are up to date as well. Safe Mode should rule out Extensions and Themes.

Now the issue at hand. Websites can look like this if they don't load or if their content is not allowed to display; since the structure looks correct, I would assume the latter. See this answer, https://support.mozilla.org/en-US/questions/912689, for how to check and set the content displaying options. I don't see any content blocking extensions at a glance, not even antivirus (I assume you're using Windows Defender+Firewall?), so these should not be the issue.

Leggere questa risposta nel contesto 👍 5

All Replies (3)

more options

Soluzione scelta

Hi there. You're certainly right in that it appears Youtube isn't loading all of its content, but it might also be that it's just not allowed to display it.

First, is there a reason why you're using Firefox 44.0.2? The latest is 45.0.1 and there's an entry in the release notes about performance regression being fixed with Youtube, so you should try to update Firefox: https://support.mozilla.org/en-US/kb/update-firefox-latest-version.

These days Youtube doesn't require Java or Flash to play videos, but you should visit https://www.mozilla.org/en-US/plugincheck/ to make sure your Plugins are up to date as well. Safe Mode should rule out Extensions and Themes.

Now the issue at hand. Websites can look like this if they don't load or if their content is not allowed to display; since the structure looks correct, I would assume the latter. See this answer, https://support.mozilla.org/en-US/questions/912689, for how to check and set the content displaying options. I don't see any content blocking extensions at a glance, not even antivirus (I assume you're using Windows Defender+Firewall?), so these should not be the issue.

more options

Hello Phoxuponyou, and many thanks for your punctual reply.

Only reason I'm using 44.0.2 is that I wasn't informed of updates. It even claims to be "up to date" as in the attached file..

As I opened the links you sent me, downloading the 45.0.1, and updating Silverlight (all other plugins were up to date), I thought lets give Youtube a shot, and -to my surprise- it works!

I didn't change anything before it stopped working, and nothing (other than Silverlight update) before it reworked.

I'm grateful for your assistance though. Thanks again ^^

more options

Excellent, you're welcome! The update routine can get stuck sometimes, so when in trouble, it is worth it to check manually. It was probably just some setting gone astray that was corrected by the update - or maybe even an actual issue per same.

In any case, glad to see Firefox working again - happy travels. :)