Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

History has stopped recording -- I'm not using "Private Browsing".

  • 12 risposte
  • 1 ha questo problema
  • 195 visualizzazioni
  • Ultima risposta di bramweiser

more options

Hello, and thanks for reading my post.

For some reason, since this morning, my Firefox v42.0 has stopped recording my site/page visits into the History. (Yes, I know there's now a v43.0.1, and maybe a little after that, too, but I thought this was a fairly recent version, so I didn't anticipate that to be a problem...so please work with me to try and resolve this, if possible...thanks!)

I searched Mozilla's Online Knowledge Base and, based on what I saw there, want you to know that I've chosen "Remember History" (if I selected "Use Custom Settings", then I'd see an UN-checked box for "Private Browsing" with the other 3 boxes -- "Remember my browsing and download history", "Remember search and form history" and "Accept cookies from sites" -- all checked), so I don't know why this is happening. (Could the History somehow be "full"?)

Also, I searched my hard drive and saw an "Old Firefox Data" folder that included "places.sqlite" files from as recent as a year ago...but nothing anywhere that was more recent than that, and no such files anywhere else on my hard drive besides that folder...yet, there's History that shows up in the "Library" from earlier this morning, and earlier...but not later.

Any insights, please?

Thank you very much, Bram Weiser

Soluzione scelta

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Bounce around a few sites. Close Firefox. After a bit, open FF in Safe Mode again. Is the history still there?

Now restart FF normally. Check the history again.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (12)

more options

History and cookies can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings
    (Type about:preferences#privacy<enter> in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
more options

Thank you, FredMcD. I saw this exact same answer in another similar thread but don't think this answers my questions.

1) As I said, I do NOT think I'm using Private Browsing, as I described in my original post. If I am, then I don't know why I'm seeing the settings I'd mentioned, or, in the alternative, why I'm not seeing some special icon, etc., to indicate Private Browsing, either. 2) This leads to the Tools --> Options --> Privacy screen from which I'd described in my original post which selections I made. 3) I've not added any software in the past 12 hours, so the fact that History has suddenly stopped recording leads me to think that this might NOT be a reason. 4) I don't believe this is the case, either, as (so far, anyway) this lack of continued recording of History is the only "symptom" I've noticed,

If you, or others, have additional insights, please post them here as well.

Thanks again, Bram Weiser

more options

You did not say if you checked; 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.

How are your bookmarks? Any problem there? These are stored in the same file.


Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Then follow the directions.

more options

Soluzione scelta

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Bounce around a few sites. Close Firefox. After a bit, open FF in Safe Mode again. Is the history still there?

Now restart FF normally. Check the history again.

more options

FredMcD said

You did not say if you checked; 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone. How are your bookmarks? Any problem there? These are stored in the same file.

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Then follow the directions.

Thank you, FredMcD. I'd said I hadn't added any software recently (that would include anti-virus or disk cleaners) so I'd be surprised if this was at issue.

My bookmarks appear to be in place just fine, thanks.

Before I install something new that I'm not familiar with, like Places Maintenance, I'll try your "Open-in-Safe-Mode, Navigate-to-several-pages, Close-the-browser, Open-in-Regular-Mode" idea to see if that does anything.

Thanks again, Bram Weiser

Modificato da bramweiser il

more options

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Browsing History

If you use cleanup software like CCleaner then check the settings for the Firefox application.


You can check for problems with the places.sqlite database (bookmarks, history) in the Firefox profile folder.

If the Places Maintenance extension isn't able to repair the places.sqlite database then (re)move all places.sqlite file(s) including places.sqlite-shm and places.sqlite-wal in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

more options

Thank you, cor-el.

I don't clear the History when Firefox closes. I'd honestly prefer to have a comprehensive History than to not have one.

As I mentioned earlier, I couldn't appear to find a current places.sqlite file, but DID find several in the "Old Firefox Data" folder from at least a year ago.

Thank you for offering assistance, Bram Weiser

more options

Dear FredMcD,

As I promised, I...

  • Closed Firefox
  • Reopened it in Safe Mode
  • Navigated to several Web Pages I don't usually visit
  • Checked History and did NOT see those pages there
  • Closed Firefox again
  • Reopened it in Safe Mode again
  • Checked History again, and now (surprise) DID see those several Web Pages!
  • Closed Firefox once more
  • Reopened it the usual way
  • After navigating to several more Pages, including this one in Mozilla Support, checked History again to find that it DOES seem to be recording History again as it should.

Thank you very much for the Safe Mode idea that seemed to "reset" things!

Do you have any insight as to why it stopped recording the History in the first place? What might have caused it, that doing this "Safe Mode" trick went and corrected?

Thanks again, Bram Weiser

more options

I don't know. Sometimes, a file gets corrupt. Later it's overwritten.

Well, as long as it's working. Safe Surfing.

more options

FredMcD said

I don't know. Sometimes, a file gets corrupt. Later it's overwritten. Well, as long as it's working. Safe Surfing.

Thanks again, FredMcD.

If so, that's very odd...corruption happens...and then disappears...if only because I opened Firefox in Safe Mode before doing so again the regular way. Very peculiar, if you ask me... :-)

Still, I don't want to look the proverbial gift horse in its proverbial oral cavity, so thanks again (and to cor-el) for taking time to guide and assist me (& perhaps others, too) with this.

Bram

more options

Strange as it seems, sometimes SafeMode works like banging on an old CRT television set did to "fix" a fuzzy or "rolling" screen - like the digital equivalent of "shaking things up" to clean a dirty connection in a RF tuner back in the days of vacuum tube electronics. Yeah, I am "that old".

more options

Thank you, the-edmeister. Yes, I remember CRTs, and tubes in my TV, too. :-)

I thought Safe Mode, whether with Firefox, or Windows in general, was simply a way of trying to utilize the software in a bare-bones fashion, not necessarily how you described it...though I'm glad that you're right and I was wrong. :-)

Thanks again, Bram