X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

I get a message saying script needs to be stopped continued or debugged. It makes using the browser useless and have to shut down.

Inserita

A box pops up and says script has stopped running. Debug, continue or stop script are my choices. No matter what I choose I end up having to go to task manager and shut down the browser windows. It usually happens when running the following sites: finviz.com stocktwits.com twitter.com

A box pops up and says script has stopped running. Debug, continue or stop script are my choices. No matter what I choose I end up having to go to task manager and shut down the browser windows. It usually happens when running the following sites: finviz.com stocktwits.com twitter.com

Dettagli aggiuntivi sul sistema

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Ulteriori informazioni

jscher2000
  • Top 10 Contributor
8758 soluzioni 71662 risposte

Risposta utile

Hmm, that's very annoying. Do you notice any pattern to the problem script listed in the dialog? For example, scripts in pages usually have addresses starting with http or https, while scripts that are part of Firefox or an add-on usually have addresses starting with chrome or resource.

We have a comprehensive help article about that unresponsive script dialog: Warning Unresponsive script - What it means and how to fix it.

However, I will suggest one thing to try first, which is to minimize the problems that can be caused by the Flash plugin, using these two measures (the second one often helps specifically with the unresponsive script problem).

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Hmm, that's very annoying. Do you notice any pattern to the problem script listed in the dialog? For example, scripts in pages usually have addresses starting with http or https, while scripts that are part of Firefox or an add-on usually have addresses starting with chrome or resource. We have a comprehensive help article about that unresponsive script dialog: [[Warning Unresponsive script - What it means and how to fix it]]. However, I will suggest one thing to try first, which is to minimize the problems that can be caused by the Flash plugin, using these two measures (the second one often helps specifically with the unresponsive script problem). (1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. (2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then ''uncheck'' the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
rghirardi 0 soluzioni 2 risposte

I also have this problem!!

I also have this problem!!
jscher2000
  • Top 10 Contributor
8758 soluzioni 71662 risposte

Hi rghirardi, are you also running Windows 10? Did you try the suggestions in my first reply?

Hi rghirardi, are you also running Windows 10? Did you try the suggestions in my first reply?
rghirardi 0 soluzioni 2 risposte

I performed the 'fix' you first mentioned. It worked for only a short while. Flash is not active, but the script problem came up the following day.

I performed the 'fix' you first mentioned. It worked for only a short while. Flash is not active, but the script problem came up the following day.
jscher2000
  • Top 10 Contributor
8758 soluzioni 71662 risposte

Hi rghirardi, could you note the names/addresses of the scripts listed in the dialog as unresponsive. You may wish to use a screen capture tool for this. Our support article "How do I create a screenshot of my problem?" has information on how to do that. Please cut out or blur any sensitive information before attaching any screen shots to a reply.

Also, what is your Windows version?

Hi rghirardi, could you note the names/addresses of the scripts listed in the dialog as unresponsive. You may wish to use a screen capture tool for this. Our support article "[[How do I create a screenshot of my problem?]]" has information on how to do that. Please cut out or blur any sensitive information before attaching any screen shots to a reply. Also, what is your Windows version?