Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

site says i need to turn on cookies, but I have cookies turned on!

  • 3 risposte
  • 3 hanno questo problema
  • 6725 visualizzazioni
  • Ultima risposta di cor-el

more options

I have tried to visit several websites today, but when I get there it says i have cookies disabled and that i need to enable them to visit the site. When I go to check my cookies settings it says they are ON! Why am I all of a sudden having this issue? I have not changed any of my settings! Please help. I need these sites to finish my work!

Soluzione scelta

Hi Lisa, you could first double-check your settings on the Options page, Privacy panel, as described in this article:

Websites say cookies are blocked - Unblock them

If that checks out, perhaps one of your add-ons is causing the problem. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (3)

more options

Soluzione scelta

Hi Lisa, you could first double-check your settings on the Options page, Privacy panel, as described in this article:

Websites say cookies are blocked - Unblock them

If that checks out, perhaps one of your add-ons is causing the problem. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

more options

I got it fixed. I went in and unchecked everything and then rechecked it all again. That seemed to fix the problem. Still not sure why it was registering as not accepting cookies. Oh well, problem solved! Thanks for the help.

Modificato da lisafullerton il

more options

When it happens again then try to clear the cookies.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)