Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Font issues after upgrading to Windows 10

  • 7 risposte
  • 20 hanno questo problema
  • 4100 visualizzazioni
  • Ultima risposta di jscher2000

more options

After upgrading to Windows 10. Some of the Font are white with black outlines making it hard to read some pages. I refreshed and reinstalled firefox and it's still there. I disabled and removed all addons and it's still happening.

Soluzione scelta

Never-mind. My only solution was to delete the font cache. Restart the PC and uncheck Allow Web Sites To Choose Their Own and simply used the Arial Font. I can read them fine now. For some reason rechecking the last option defaults the text to look like that. Doesn't happen in Google Chorme so yeah.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (7)

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

more options

It was already set to Allow Web sites to choose their own. That didn't help.

The instructions on the website all read for Max OSX. I am running Windows 10.

more options

Looks like the preferred font list for those left column items is:

"Helvetica Neue",helvetica,arial,sans-serif;

I do not have any Helvetica variants installed, so my system uses Arial.

To see which font is the problem for you, right-click one of those items and choose Inspect Element (Q). The Inspector will open in the lower part of the tab. On the right side, Firefox might be showing the "Rules" list. Change that to "Font" to see which font is actually being used. (Example screen shot attached.)

As an aside, you can remove this old extension: Updated Ad Blocker for Firefox 11+. Adblock Plus is now much more updated than that one.

more options

I checked the inspect element. This is the result. It's blank

more options

Also, I am using Adblocker Plus.

more options

Soluzione scelta

Never-mind. My only solution was to delete the font cache. Restart the PC and uncheck Allow Web Sites To Choose Their Own and simply used the Arial Font. I can read them fine now. For some reason rechecking the last option defaults the text to look like that. Doesn't happen in Google Chorme so yeah.

more options

I think you're going to run into situations where websites use downloadable fonts for icons and you'll want to allow sites to choose their own fonts again.

If you don't want to remove the Helvetica fonts from your system, you may be able to use custom style rules to have Firefox use Arial instead. I first saw that documented in this article: Helvetica on Firefox: Overriding Fonts with CSS | Keyvan Minoukadeh.

Just as a proof of concept, I used his technique to substitute Comic Sans for Helvetica, with the expected hideous results (screen shot attached).