Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox sync 500 Error? was working now i get this 500 Error????

  • 9 risposte
  • 14 hanno questo problema
  • 3338 visualizzazioni
  • Ultima risposta di enlightent_1

more options

Hi, Firefox sync was working perfectly fine until recently. Now every time i click on sync i get a 500 Error. Using Firefox 39 and about:accounts?entrypoint=menubar I get a 500 error. If I try going to https://accounts.firefox.com in Firefox I also get a 500 error.

I also have the same browser setup on 2 other computers and so far they seem to work just fine ( so far ) however my main browser will not sync anymore. Looked every where for answers but all i can find is a lot of people with the same problem but not fix ????

Soluzione scelta

Try to delete the signedInUser.json file in the Firefox profile folder and delete the Weave folder (Sync was formerly named Weave). If that isn't enough then delete the prefs.js files to reset all prefs and maybe also delete the compatibility.ini file to reinitialize the profile.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Leggere questa risposta nel contesto 👍 2

Tutte le risposte (9)

more options

hello, when you type about:sync-log into the address bar and open the latest one or two error logs, can you copy their contents and put them into http://pastebin.mozilla.org/ or a similar service and paste a link here on the forum? this would be very helpful in assessing the problem. thank you!

more options

Hi Pilipp, i have posted the last three error logs via your link hope it helps. Here is the link to the log https://pastebin.mozilla.org/8839349 please let me know if something is a miss. Thank you very much

more options

This should help.

Allow accounts.firefox.com to set cookies. If you disallow cookies by default, you need to check this.

After that, the procedure for upgrading is relatively simple: go to your preferences, and either click on the message that pops up prompting you to upgrade (which should walk you through some kind of wizard), or go to https://accounts.firefox.com/ and create a new account by hand, and then back in the preferences unlink your browser and sign into your new account. You'll need to do that for every browser / other device. But allowing cookies is crucial, otherwise you'll keep getting the error 500.

more options

Hi, thank you for your help, but !! First, i do allow cookies and i have not changed that setting at all. Second, i can not log in to accounts.firefox.com or https://accounts.firefox.com/ because as soon as i try to log into anything like sync or accounts i get the:

           500 Error 

Oh dear, something went wrong there. We've been notified and will get working on a fix. and this is as far as it will go.

Now as stated in my post above, it was working perfectly fine until all of the sudden for no good reason at all it gave me the 500 error. Funny thing is though Firefox on the other 2 computers ( with the exact same setup ) are working just fine ( so far ). I have the latest version of Firefox and have tried everything i can and know to get it to sync again but without any luck at all.

Modificato da enlightent_1 il

more options

Wow, I can't believe that absolutely no one is able to provide a fix for this issue, .....well done firefox!

Update on the issue: all my Firefox browsers now have the 500 error. Of course needless to say that all the searching in the world has provided zero results. A common problem but no fix as of yet.

more options

Soluzione scelta

Try to delete the signedInUser.json file in the Firefox profile folder and delete the Weave folder (Sync was formerly named Weave). If that isn't enough then delete the prefs.js files to reset all prefs and maybe also delete the compatibility.ini file to reinitialize the profile.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

OMG, it worked, THANK YOU so very much. It worked, it worked, it worked :-) I followed your instructions ( probably should have mentioned that I am using Linux not windows) found the folders and deleted them, didn't worke until i deleted the " prefs.js " file. Once that was gone i was able to sign into my account.

Now it did take Firefox back to a new start ( with all bookmarks and plug ins there) but the strange thing was my previously synced account was empty too.

Not sure what happened there but I'm never the less happy that I'm able to sync my browser again :-) Now I just have to do this to my other two browsers ;) Once again Thank you very much for your help :-)

more options

Ps: any Linux users who encounter the same problem, make sure you use Root access to fix the problem. Now for anyone who doesn't know I will post the instructions on how to gain access to these files. Linux Mint and Ubuntu users: Open Terminal: su - and press enter Type Password ( your password that is, which will NOT be visible ) gksudo nemo ( or which ever file manager you are using )

Once your file manager is open press control and H to show hidden files. After that got to: File system Home Your user Name Mozilla Firefox and now find and delete the files and folder as per the above instructions. Hope it works for you as it did for me. Good luck :-)

Modificato da enlightent_1 il

more options

Update on 500 error,

I have recently had the " 500 Error " Oh dear, something went wrong there. We've been notified and will get working on a fix " AGAIN after changing some Firefox privacy settings.

During my " re-tracing" of changes i have made i noticed that if the dom.storage.enabled is changed from " true " to " false " you WILL get the horrible " 500 Error " Oh dear, something went wrong there. We've been notified and will get working on a fix.

Firefox will NOT sync and things like Internet accounts the like of Amazon will NOT work. So for anybody who has the 500 error follow these steps.

1. in the search bar type or copy, about:config and press enter 2. Promise to be careful  ;-) 3. again in the search bar type or copy, dom.storage.enabled 4. Make sure it is set to TRUE

Failing these steps follow the guide above. Good luck