Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox loads home page when opening new tabs

more options

Greetings!

When I open a new tab (add) in Firefox, the new tab automatically loads my start-up (home) page. This is an annoying "feature" when I'm opening the page to insert an address because the start-up page address is present, causing the need to remove it from the address bar. This was not the case in previous versions of Firefox. Is there a setting to fix this? In other words, I would like to open a "blank" page when opening a tab, but I don't want a blank page to appear at start-up.

Thanks.

california.cyclist

Soluzione scelta

These actually are separate settings internally, unless you are using an add-on to override that.

Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

Leggere questa risposta nel contesto 👍 7

Tutte le risposte (4)

more options

Soluzione scelta

These actually are separate settings internally, unless you are using an add-on to override that.

Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

jscher2000 said

Here's how you can change your new tab page: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste newtab and pause while the list is filtered (3) Double-click the browser.newtab.url preference and enter your preferred page:
  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page
Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Hi jscher2000,

Thanks, awesome support! One thing I might add to your instructions would be how to actually save the new setting (i.e., just closing the about:config tab, entire browser, etc.), or other instruction that might be needed to ensure the integrity of the process. I wasn't exactly sure if the new setting would actually "save", or if another step was needed. The last thing I want to do is guess when the potential for "voiding my warranty" is at stake! :)

Thanks again for your help!

california.cyclist

Modificato da california.cyclist il

more options

Hi california.cyclist, thank you for the feedback. I think I used to add "You're done with this tab now" but often we needed to follow up, so I stopped adding that. Tech writing can never be perfect!

more options

Yep... I get that. How did Mark Twain say it..., "If I had more time, I would have written a shorter letter". ;-)

Anyway, maybe just add, like this... "... that it worked. Fixed? Close your browser and confirm the changes are applied when you launch Firefox."

Then the rest.

Of course, I'm assuming you're doing a cut/paste instruction message... if this stuff just comes off the top of your head, well then... yeah, looks pretty close to perfect to me.

Again, thank for the help and super quick responses!