Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

error ssl_error_weak_server_ephemeral_dh_key I can't log into my ISP please help.

  • 7 risposte
  • 474 hanno questo problema
  • 264700 visualizzazioni
  • Ultima risposta di jjpjjpjjp

more options

I don't know why I don't have the correct ssl certificate or whatever. I use firefox 60(nightly) I am not sure if I deleted my certificates or what may have happened but it says ssl_error_weak_server_ephemeral_dh_key I don't know exactly what this means or how to get my dh key to give them the right key.

Soluzione scelta

Note that users with the current and older Firefox releases can toggle these prefs to false on the about:config page to disable the cipher suites that are involved with the Logjam vulnerability.

  • security.ssl3.dhe_rsa_aes_128_sha
  • security.ssl3.dhe_rsa_aes_256_sha

  • Bug 1138554 - NSS accepts export-length DHE keys with regular DHE cipher suites

Logjam: How Diffie-Hellman Fails in Practice:

Leggere questa risposta nel contesto 👍 97

Tutte le risposte (7)

more options

hi jjpjjpjjp, this means that the webserver you're trying to reach is vulnerable to the recently published logjam vulnerability: http://arstechnica.com/security/2015/05/https-crippling-attack-threatens-tens-of-thousands-of-web-and-mail-servers/ please report that to webmaster of the site in question to fix that issue...

https://weakdh.org/

more options

This seems to directly refer to my problem, just to make sure, I am running 64 bit windows 8.1 and a newer browser, it would still affect me?

more options

this is a vulnerability in the configuration of web-servers, that allows downgrading the encryption levels of connections so that third parties can listen in (so it will need to be fixed by the administrators of each affected webservers). new browser versions should show you a warning message like the one you have referenced and block any connections to affected servers.

more options

Well thank you very much for sharing this knowledge with me, I will do what I can to correct it, and I will contact the webmasters a.s.a.p.

more options

Soluzione scelta

Note that users with the current and older Firefox releases can toggle these prefs to false on the about:config page to disable the cipher suites that are involved with the Logjam vulnerability.

  • security.ssl3.dhe_rsa_aes_128_sha
  • security.ssl3.dhe_rsa_aes_256_sha

  • Bug 1138554 - NSS accepts export-length DHE keys with regular DHE cipher suites

Logjam: How Diffie-Hellman Fails in Practice:

more options

Thanks for the update, I'm going to go ahead and access that now and see if that changes anything about the certificate.

more options

well after toggling both to false, I still get the error on the secure page I am accessing. I have, however, found a solution, for now, my Google Chrome has not been affected by this weak dh error and I can use it to access that specific page and probably any other page with such an error.

Edit: hold on. I had picked the wrong ones. I did what you said and that solved it perfectly. Thank you for your solution! I can now access the secure page using my mozilla browser.

Modificato da jjpjjpjjp il