X
Tocca qui per la versione per piattaforma mobile del sito.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

No sound or audio in flash.

Inserita

I have: Firefox 38.0.5 Shockwave Flash 18.0.0.160

Problem is that when I watch a video that is NOT in youtube, there seems to be no sound. This happens on sites such as: twitch.com kissanime.com (In this site the have the option to play videos in HTML5, which works fine) and website with flash games like: kongregate.com

I have: Firefox 38.0.5 Shockwave Flash 18.0.0.160 Problem is that when I watch a video that is NOT in youtube, there seems to be no sound. This happens on sites such as: twitch.com kissanime.com (In this site the have the option to play videos in HTML5, which works fine) and website with flash games like: kongregate.com

Soluzione scelta

I think I have found the problem. Turns out it wasn't the Firefox. I found out that it was my headset. I use a Logitech G35, there was volume in youtube but not other flash player on other website.

I found this out when I used earphones and switched the playback from my G35 to Realtek HD Audio.

The problem is still there, but now I know it is my headset that is the problem. I'll just have to play around with settings more.

Leggere questa risposta nel contesto 0

Dettagli aggiuntivi sul sistema

Plugin installati

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 18.0 r0
  • 5.1.40416.0
  • VLC media player Web Plugin
  • NPWLPG
  • iTunes Detector Plug-in

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Ulteriori informazioni

FredMcD
  • Top 10 Contributor
4385 soluzioni 61542 risposte
See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Utente che ha posto la domanda

FredMcD said

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

My graphics driver is up to date and still the problem persist.

''FredMcD [[#answer-740731|said]]'' <blockquote> See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> My graphics driver is up to date and still the problem persist.
FredMcD
  • Top 10 Contributor
4385 soluzioni 61542 risposte
http://kb.mozillazine.org/Images_or_animations_do_not_load '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues ------------------------ If these do not help, I wll call the big guys.

Utente che ha posto la domanda

FredMcD said

http://kb.mozillazine.org/Images_or_animations_do_not_load https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

If these do not help, I wll call the big guys.

Thank you for the quick replies.

I tried most of the solutions in those sites. Problem is still here. Youtube works fine, but twitch plays the videos with no sound.

I tried: making sure volume is up, turning off firewall and Adblock, disabling and enabling various Plugins and made sure they are up to date, clearing cache and cookies and making sure they are enabled, running firefox in safe mode, reinstalling firefox and flash.

None of these methods worked.

''FredMcD [[#answer-741278|said]]'' <blockquote> http://kb.mozillazine.org/Images_or_animations_do_not_load '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues ------------------------ If these do not help, I wll call the big guys. </blockquote> Thank you for the quick replies. I tried most of the solutions in those sites. Problem is still here. Youtube works fine, but twitch plays the videos with no sound. I tried: making sure volume is up, turning off firewall and Adblock, disabling and enabling various Plugins and made sure they are up to date, clearing cache and cookies and making sure they are enabled, running firefox in safe mode, reinstalling firefox and flash. None of these methods worked.
FredMcD
  • Top 10 Contributor
4385 soluzioni 61542 risposte

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
guigs 1072 soluzioni 11697 risposte

I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed.

I also tried these settings in Flash Global settings:

  • Clear the browsing cache in Advanced
  • Clear the storage after I updated

The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change?

Does the twitch player use the DRM plugin? Check to see if this is enabled: https://support.mozilla.org/en-US/kb/enable-drm

''I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed. I also tried these settings in Flash Global settings: *Clear the browsing cache in Advanced *Clear the storage after I updated The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change? *[[Fix common audio and video issues]] *[[What to do if Firefox won't play any sounds]] Does the twitch player use the DRM plugin? Check to see if this is enabled: [https://support.mozilla.org/en-US/kb/enable-drm] ''

Utente che ha posto la domanda

guigs2 said

I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed. I also tried these settings in Flash Global settings:
  • Clear the browsing cache in Advanced
  • Clear the storage after I updated

I did the flash global settings, like instructed, and the problem is still the same.

The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change?

I tried to do everything in these 2 links again. Problem is the same, and I didn't notice any changes, even if I try other twitch channels that were streaming at the time.

Does the twitch player use the DRM plugin? Check to see if this is enabled: https://support.mozilla.org/en-US/kb/enable-drm

It is enabled when I checked, I also tried disabling it and results did not change. Video still played without no audio.

''guigs2 [[#answer-741588|said]]'' <blockquote> ''I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed. I also tried these settings in Flash Global settings: *Clear the browsing cache in Advanced *Clear the storage after I updated </blockquote> I did the flash global settings, like instructed, and the problem is still the same. <blockquote> The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change? *[[Fix common audio and video issues]] *[[What to do if Firefox won't play any sounds]] </blockquote> I tried to do everything in these 2 links again. Problem is the same, and I didn't notice any changes, even if I try other twitch channels that were streaming at the time. <blockquote> Does the twitch player use the DRM plugin? Check to see if this is enabled: [https://support.mozilla.org/en-US/kb/enable-drm] </blockquote> It is enabled when I checked, I also tried disabling it and results did not change. Video still played without no audio.

Soluzione scelta

I think I have found the problem. Turns out it wasn't the Firefox. I found out that it was my headset. I use a Logitech G35, there was volume in youtube but not other flash player on other website.

I found this out when I used earphones and switched the playback from my G35 to Realtek HD Audio.

The problem is still there, but now I know it is my headset that is the problem. I'll just have to play around with settings more.

I think I have found the problem. Turns out it wasn't the Firefox. I found out that it was my headset. I use a Logitech G35, there was volume in youtube but not other flash player on other website. I found this out when I used earphones and switched the playback from my G35 to Realtek HD Audio. The problem is still there, but now I know it is my headset that is the problem. I'll just have to play around with settings more.