Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 38.0.5 does not honor the "ask me every time" download location.

  • 4 risposte
  • 5 hanno questo problema
  • 513 visualizzazioni
  • Ultima risposta di FredMcD

more options

I have been using and loving FF for many years.

In Tools | Options I have selected: Always ask me where to save files.

But Firefox ignores that and saves it is the usual User directory.

Interestingly, I noticed another unresolved post on this forum that is just the opposite. Someone has checked-off a location to download to every time but FF asks for a location on every download.

Soluzione scelta

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

Leggere questa risposta nel contesto 👍 2

Tutte le risposte (4)

more options

Soluzione scelta

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

more options

You can rename (or delete) the content-prefs.sqlite file to content-prefs.sqlite.old in the Firefox profile folder to reset all website specific data.

You can disable the feature to remember a host based download directory by creating a new Boolean pref on the about:config page with the name browser.download.lastDir.savePerSite pref and set its value to false.

You can use this button to go to the currently used Firefox profile folder:

more options

Thank-you all. I got it working now :-)

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.