Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Why does Firefox 38 keep saying it is not the default browser when it is the only browser installed?

  • 10 risposte
  • 1 ha questo problema
  • 25 visualizzazioni
  • Ultima risposta di jiliji

more options

Firefox is the only graphical browser installed and has been set to default browser numerous times, yet preferences says Firefox is not the default browser (even though it is). System is CentOS 7. In the Mate-Control-Center Firefox is set as the preferred browser.

Tutte le risposte (10)

more options

Hi, I think I would Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for the suggestion but it was not the solution. The message Firefox is not your default browser is still present. (Not that I have any intention of ditching any extensions - I install what I need and will not be going without them.) Something else is wrong.

I should add that this is more of a nuisance than a problem for me since if I click on a link in Thunderbird, Libreoffice or anywhere else it opens in Firefox. Firefox is clearly the default (and only) browser installed (except a few text only browsers).

Modificato da jiliji il

more options

Type about:preferences#general<enter> in the address bar. Turn on/off Always Check Firefox Default Browser.

more options
more options

Thanks folks but no dice so far. I did try to tell Firefox to just stop checking. It still displays the message. Clicking make Firefox default just rechecked the box to always check. Something screwy in this latest Firefox. I suppose I should file a bug report.

more options

Are you sure this is from Firefox?

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

I'm sorry - is what from Firefox? The message Firefox is not the default browser? Of course it is a Firefox message. I will attach a screenshot.

more options

On that page, have you pressed the Make Default button on the right?

more options

Do you have the http (FirefoxURL) and .html (FirefoxHTML) registry keys under HKEY_CLASSES_ROOT?

more options

-On that page, have you pressed the Make Default button on the right?

In my initial post where I say Firefox has been set to default numerous times, I mean to say I've pressed that button numerous times.

-Do you have the http (FirefoxURL) and .html (FirefoxHTML) registry keys under HKEY_CLASSES_ROOT?

Say again? That sounds like Windows jargon, please correct me if I'm wrong. See my initial post. CentOS 7.1 is the operating system.

Unless someone can show me definitively that the problem lies on my end somewhere, I'm going with the problem is in Firefox 38, or possibly its integration with CentOS 7.1.

Modificato da jiliji il