Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox windows will not close.

  • 7 risposte
  • 56 hanno questo problema
  • 20134 visualizzazioni
  • Ultima risposta di Ed Randall

more options

Hi I am running windows 8.1 and Firefox 38.0.1. whenever I click on the red "x" to close Firefox, Firefox will not close. if I want to close all the tabs, Firefox won't close the last tab. If I try to merge windows (by dragging the tab from one window in to a different window) Firefox will create a blank tab on the window from which I dragged the the tab was dragged. So far the only way to close fire fox is to click on the shut down button or to end it through the task manger. when I re-open Firefox the windows and previous tabs are also there, and I am still unable to close them. I have restarted my PC and reinstalled Firefox (i.e. uninstalled and download again). however, after downloading Firefox.... the same windows will open, with the same tabs! It is horrible!

Soluzione scelta

Hello cach_dies,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Leggere questa risposta nel contesto 👍 3

Tutte le risposte (7)

more options

Soluzione scelta

Hello cach_dies,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks this is very helpful

Modificato da cach dies il

more options

Hi, please test for faulty extensions.

thank you

more options

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.


There are some add-ons that can place a close button on the toolbar.

Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.

more options

FredMcD said

A post was flagged as Solved Problem. Please remove that flag. If you don’t, others that can help may not read this post.

There are some add-ons that can place a close button on the toolbar.

Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.

Why to remove the flag as Solved Problem if he solve it with the above suggestions ? :-)

more options

I had this problem and it turned out the addon Tab Mix Plus was the culprit. Luckily, it was the first addon I tried, as I suspected it was something to do with tabs.

Modificato da aragornian il

more options

I fixed this by updating TabMixPlus from 0.4.1.7.1 to the latest development build 0.4.1.8pre.150317a1 The download link is at the top right of their support forum http://tmp.garyr.net/support/viewtopic.php?t=2