Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

PDF not rendering correctly in FF 38

  • 10 risposte
  • 2 hanno questo problema
  • 722 visualizzazioni
  • Ultima risposta di legarsblond

more options

Since I installed FF 37, the PDF files of my website render incorrectly (choppy image), using the native PDF viewer.

There is no such problem in IE or Chrome. Version 37.0.2 didn't fix the problem.

As my viewers are really general public (may not know how to install different plugin), i might just suggest NOT using FF on my website if this is not fixed quickly!

Immagini allegate

Modificato da legarsblond il

Soluzione scelta

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Leggere questa risposta nel contesto 👍 1

Tutte le risposte (10)

more options

Can you post a link to the pdf in question? I'll see what I can do.

more options

Sorry for the delay, I was on vacation!

I'm now on FF 38.0.1 and I still have that problem.

The PDF link: http://mimotel.webuda.com/BAO_Routes_8x11.pdf

Thanks!

more options

Mark Schmidt said

Can you post a link to the pdf in question? I'll see what I can do.


Sorry for the delay, I was on vacation!

I'm now on FF 38.0.1 and I still have that problem.

The PDF link: http://mimotel.webuda.com/BAO_Routes_8x11.pdf

Thanks!

more options

I've tried to reduplicate this issue on multiple computers using every Firefox version from 37 through 40. In every attempt the native viewer renders the pdf the same as adobe's viewer.

It's probable that this issue is related to some feature of your specific graphics card not playing well with the pdf rendering engine.

The good news is, I strongly suspect this is not a more widespread issue. The bad news is, it's very hard to prove a negative. I'm sorry I couldn't be more helpful.

more options

Looks fine here.

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

cor-el, there's a screenshot in the OP.

Left side is the incorrect render. Right side is correct.

more options

Mark Schmidt said

I've tried to reduplicate this issue on multiple computers using every Firefox version from 37 through 40. In every attempt the native viewer renders the pdf the same as adobe's viewer. It's probable that this issue is related to some feature of your specific graphics card not playing well with the pdf rendering engine. The good news is, I strongly suspect this is not a more widespread issue. The bad news is, it's very hard to prove a negative. I'm sorry I couldn't be more helpful.

Thank you very much Mark for all the tests you've made. Looks like you're right. My collegues have no problem viewing the PDF on their computers. I'll try updating my drivers and see if it solves my problem.

Cheers!

more options

Soluzione scelta

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

I tried it in safe mode, and it works. Only thing is that the fonts used in the PDF is not right. What should I do to correct hardware acceleration?

more options

cor-el said

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

When I'm unchecking hardware acceleration, problem is gone...