Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

After recent upgrades Firefox prevents links in several websites from working whilst there is no such problem with other browsers - help please.

  • 15 risposte
  • 5 hanno questo problema
  • 3904 visualizzazioni
  • Ultima risposta di FredMcD

more options

Since a recent upgrade of Firefox links in several websites no longer work. They used to be fine and I loved Firefox. The problems do not exist with other browsers e.g. Internet Explorer, Google Chrome. More specifically, on talktalk.co.uk the links to news items do not work, nor do those to "My Account." On Barclays.co.uk the link to print my statement doesn't work - similarly on MBNA.com There are several suggested solutions around the internet but all are complex, none so far have worked and I don't see why I should need to carry out the suggested tweaks. Firefox used to be great - now it isn't. The problem seems to be with the upgrade. Please help me to get my Firefox to where it should be.

Soluzione scelta

AFAICT then that are just normal links on the News page

The http://www.talktalk.co.uk/ opens if I click the News & TV guide link on the https://sales.talktalk.co.uk/ page.

If I right-click a link and use Inspect Element to open the Inspector then I see that there is an onclick event on the links ("ev" button appended), so make sure that you aren't blocking JavaScript.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (15)

more options

Those all are secure sites, and one has to be a member to check. Kind of hard to test. What tweaks were suggested? Are these sites still using only SSL? It is possible to re-enable that, but it is better not to do that.

more options

The talktalk.co.uk site is not "secure" as you suggest. Just go to the site and click on one of the news pictures. This should take you to more on the subject matter - no log-in required. These links don't work for me. As for the suggested tweaks - just Google "website links don't work with Firefox." You'll get lots of links to postings about similar problems with various solutions offered. I tried a few and none have worked for me. As to whether the sites are "still using only SSL" I don't have a clue. I don't even know what it means. This really leads to the issue I have - namely - having downloaded the upgrade ( it was done automatically without my being involved as is the Mozilla recommendation) it is not unreasonable for me to expect Firefox to work as well and as easily as it did previously - it does not do that. I should not have to know about SSL or any other technicalities. I am disappointed.

Modificato da Richard69 il

more options

Hello Richard,

As a member of the public, when I click through to talktalk.com.au I am redirected to: https://sales.talktalk.co.uk/

As the address would indicate, this is a "sales" page and there aren't any "News" links as such. I'd guess the "News" pictures are only available to those who are logged into the site (such as existing customers). Because this is not accessible to non-customers, I can't test whether the links work properly or not.

Do you have any other examples of links that aren't working? Without access to any of the examples you've provided, it's very hard to verify or test the problem you are experiencing. Thanks.

more options

Is this the site you are talking about?

I was re-directed to; https://sales.talktalk.co.uk/

more options

The site I am referring to is www.talktalk.co.uk

It is not a secure site. No login is required to access the page nor to follow the links. Login is only required to access accounts. I have had similar problems with other non-secure sites but can't at present recall which they are. I am not alone having problems since the upgrade. Look at this: https://www.google.co.uk/search?q=firefox+update+problems+2014&ie=utf-8&oe=utf-8&gws_rd=cr&ei=kjGZVKTQL4v6UNS9gMAL

more options

I used your link, and ended up back at https://sales.talktalk.co.uk/

I tried to manually enter https://talktalk.co.uk/ and this is what I got;

more options

Thank you all for your efforts on my behalf. I don't think this issue warrants any more of your time. I will try uninstalling and re-installing Firefox. If it doesn't work after that I will just use another browser. The issues I have only occur with Firefox. Is it unreasonable of me to expect a product (Firefox in this case) to work "out of the box" without complicated tweaks? Thanks again.

more options

In most cases, Firefox does work Out Of The Box. Tell me, are you able to get on that page with another browser? Are you sure that is the correct web address? Are there any others?

more options

I guess talktalk.co.uk is not just using SSL, since I have blocked that and can still load it, though I am redirected to the sales page. You might want to try clearing its cookies and clearing the Firefox cache.

more options

Thank you but please don't waste any more time on this. I have done as I said I would - removed and re- installed Firefox, cleared all cookies and caches (CCleaner) - still doesn't work. As I said at the start, the problem is not confined to Talktalk - it applies to several other sites and links. The problem does not occur with Internet Explorer nor with Google Chrome so I am now using those.

more options

Soluzione scelta

AFAICT then that are just normal links on the News page

The http://www.talktalk.co.uk/ opens if I click the News & TV guide link on the https://sales.talktalk.co.uk/ page.

If I right-click a link and use Inspect Element to open the Inspector then I see that there is an onclick event on the links ("ev" button appended), so make sure that you aren't blocking JavaScript.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

I have eventually traced the problem to the add-on Ghostery. Disabled it an the problem has gone away.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so other will know.

more options

I can't see how to "flag your last post as Solved Problem" please tell me.

more options

Look for the post that Solved the problem. To it's right, press the Solved button.

Also, please contact Ghostery and tell them.

Modificato da FredMcD il