Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Mouse single click for links doesn't work in firefox

  • 12 risposte
  • 11 hanno questo problema
  • 3616 visualizzazioni
  • Ultima risposta di sfrvn

more options

Hello

Having a strange issue with firefox - single mouse click will not open links - always needs a double click (even one with a long delay between first and second clicks) to navigate. This problem started about a month ago. I have used firefox for years without encountering this issue.

Outside of firefox (including in Windows, IE...) this problem does not occur. Interestingly, the problem also does not occur in firefox toolbars, menus, etc. It seems to be only for links...

I would really rather not reset firefox as it will be a right pain to recustomize lost settings etc.

All help appreciated

Modificato da mackslim il

Soluzione scelta

For others who may be in the same boat: culprit found - Webroot Filtering Extension (v1.0.2.42). I use Webroot as my antivirus and installed their firefox extension which "screens" search engine results link

I think it might be a recent update to that extension which is the issue as I reckon I have been using that extension for longer than I've had the problem... In any case, problem solved once extension disabled. It's a shame, as I found it mostly useful.

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (12)

more options

hello mackslim, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

philipp said

hello mackslim, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here... Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

I didn't even know you could do that - yes, it does solve the problem, thanks! So I assume that I need to disable add-ons one by one to see which one is causing the problem...

more options

Soluzione scelta

For others who may be in the same boat: culprit found - Webroot Filtering Extension (v1.0.2.42). I use Webroot as my antivirus and installed their firefox extension which "screens" search engine results link

I think it might be a recent update to that extension which is the issue as I reckon I have been using that extension for longer than I've had the problem... In any case, problem solved once extension disabled. It's a shame, as I found it mostly useful.

more options

great, thanks for sharing your findings! you may also want to contact webroot's support at http://www.webroot.com/us/en/support/support-home and inform them of this issue - hopefully they can come up with an update to their extension's code that fixes the issue...

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so other will know.

more options

mackslim said

Hello Having a strange issue with firefox - single mouse click will not open links - always needs a double click (even one with a long delay between first and second clicks) to navigate. This problem started about a month ago. I have used firefox for years without encountering this issue. Outside of firefox (including in Windows, IE...) this problem does not occur. Interestingly, the problem also does not occur in firefox toolbars, menus, etc. It seems to be only for links... I would really rather not reset firefox as it will be a right pain to recustomize lost settings etc. All help appreciated

Thanks for posting what you found! I, too, had this problem, but it manifested itself *only* after FF ver 34 was installed. I falsely assumed that FF was the problem. I also run webroot, but never gave that a thought since prev versions of FF worked fine with the add-on enabled.

I will disable that add-on and see if, like you, my problem disappears.

Thanks again...

more options

I experienced this behavior all over the place on the website. I can easily recreate one of this by using gmail contains 2 shortend email button like this [...]. Click one of two then click the other, but it doesn't work at first click. 2nd click successfully expand the email.

But I'm still using 29.0.1 so this may or may not help to identify the culprit.

more options

sfrvn said

I will disable that add-on and see if, like you, my problem disappears.

I disabled the Webroot add-on but continue to have the frustrating problem. *Assuming* that use of this add-on results in the observed deficiency, that does not preclude Webroot **or** Firefox as the actual cause of the problem.

I've given up on Firefox and have switched browsers. Thanks to all for contributing.

more options

I had the same problem, I resolved it activating the plugin Microsoft .net framework assistant plugin in Menu Bar Mozilla/ Tools/Add Ons (Additional Components)/Extensions

more options

Disabling the Webroot add-on did *not* eliminate the mouse problem. Therefore, I do not believe the Webroot Filtering add-on is the problem and disabling the add-on is not the solution -- for *my* configuration.

However, repetto seems to have found the solution! I did not have the ,Net extension in FF. I added it, activated it, and FF now seems to work fine. So a big tip-of-the-hat to repetto for presenting this info!! You are Da Man!

Now for the FWIW aspects... I've been using Chrome for a couple weeks now. I evaluate it as a 'very good' browser -- equal in many aspects to FF. But there are a couple differences that I just do not like. The lack of the 'top menu' (which provides easy access to items such as Bookmarks and Option) is a real PITA. (Chrome's use of ONE icon for access to menu functionality and 'child' cascading menus is not convenient!) You *cannot* customize the Chrome menu (header) area -- like arranging the placement of Home icon.

One more thing... Some of my favorite add-ons (e.g., Download Video Helper) don't work in Chrome. FF *seems* to have more/better usable add-ons.

So I am going to switch back to FF. That will allow further testing to ensure that the "mouse click" problem is truly resolved by adding the .Net extension. I am optimistic that I can use FF as my default browser once again.

Modificato da sfrvn il

more options

Glad you got it sorted.

However, just a note here: I don't have any .net extensions installed for FF, and disabling the WR extension did solve my problem at the time.

Not sure if that really helps anyone but thought I should mention...

more options

Can't have too many possible solutions! With so many various PC-specific configurations, leave no possible solution unstated!  :-)

Thanks for YOUR input.

Modificato da sfrvn il