X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Text is being cut off on websites.

Inserita

I just noticed this problem and so far it's only happening with my school's website. I assume this is because of the latest update. See this link: http://catalog.uab.edu/undergraduate/collegeofartsciences/psychology/#courseinventory The text becomes cut off at PY 390. (The last class that should be displayed is PY 499.) This happens on every single page that lists each major's courses (Here's another example: http://catalog.uab.edu/undergraduate/collegeofartsciences/justicesciences/#courseinventory). Only the tabs that display courses are affected, so I assume this probably has to do with page length?

From what I can tell this is a text issue with Firefox - when I zoom out, I can see that all the text is still there, but Firefox is cutting it off for some reason (tested this in Chrome and it's true - I can see everything fine in it). But obviously that's not practical and would likely cause eye issues.

I just noticed this problem and so far it's only happening with my school's website. I assume this is because of the latest update. See this link: http://catalog.uab.edu/undergraduate/collegeofartsciences/psychology/#courseinventory The text becomes cut off at PY 390. (The last class that should be displayed is PY 499.) This happens on every single page that lists each major's courses (Here's another example: http://catalog.uab.edu/undergraduate/collegeofartsciences/justicesciences/#courseinventory). Only the tabs that display courses are affected, so I assume this probably has to do with page length? From what I can tell this is a text issue with Firefox - when I zoom out, I can see that all the text is still there, but Firefox is cutting it off for some reason (tested this in Chrome and it's true - I can see everything fine in it). But obviously that's not practical and would likely cause eye issues.

Dettagli aggiuntivi sul sistema

Plugin installati

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Creative Cloud Desktop Plugin.v_2_0_0_0
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 15.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.30514.0
  • iTunes Detector Plug-in

Applicazione

  • Firefox 34.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
  • URL per il supporto: https://support.mozilla.org/1/firefox/34.0.5/WINNT/en-US/

Estensioni

  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • Classic Theme Restorer 1.2.7 (ClassicThemeRestorer@ArisT2Noia4dev)
  • New Tab Tools 34.2 (newtabtools@darktrojan.net)
  • Stylish 2.0.0 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Theme Font & Size Changer 34.0 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 3.2.3.20140507025036 ({635abd67-4fe9-1b23-4f01-e679fa7484c1}) (Inattiva)

Javascript

  • incrementalGCEnabled: True

Grafica

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 0a161414
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 3-7-2014
  • driverDate2:
  • driverVersion: 10.18.10.3496
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Preferenze modificate

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.display.use_document_fonts: 0
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141126041045
  • browser.startup.homepage_override.buildID: 20141126041045
  • browser.startup.homepage_override.mstone: 34.0.5
  • browser.tabs.drawInTitlebar: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 34.0.5
  • font.internaluseonly.changed: False
  • font.name.monospace.x-western: Century Gothic
  • font.name.sans-serif.x-western: Century Gothic
  • font.name.serif.x-western: Century Gothic
  • font.size.variable.x-western: 15
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1414810810
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418538713
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1418534319
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types:
  • plugin.importedState: True
  • plugin.state.nppdf: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4
  • security.tls.version.max: 1
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1416033103

Varie

  • User JS: No
  • Accessibilità: Sì
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

You may have zoomed the page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.

You may have zoomed the page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems. *Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/
SammyJoe 3 soluzioni 10 risposte

I could see everything with all zoom levels from 100 to 300. I am running Firefox version 34. So I can't duplicate your problem. So it's not an obvious Firefox issue. The general response will be to restart Firefox in safe mode so all of your add-ons are disabled. Also you should post which version of Firefox you are running.

I could see everything with all zoom levels from 100 to 300. I am running Firefox version 34. So I can't duplicate your problem. So it's not an obvious Firefox issue. The general response will be to restart Firefox in safe mode so all of your add-ons are disabled. Also you should post which version of Firefox you are running.
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Firefox can have issues on Windows with very large text containers (above 32000px), but that shouldn't happen in this case as the DIV is a lot smaller.

Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" ----- Firefox can have issues on Windows with very large text containers (above 32000px), but that shouldn't happen in this case as the DIV is a lot smaller.

Utente che ha posto la domanda

Thanks for the replies. It's not zoom related (and I haven't changed the default text sizes), I can tell you that. I tried restarting firefox without addons and the issue is not present then, however, if I disable each addon individually (to figure out which one is causing the issue), the issue is still present.

Like I said, this is a new issue so it really does seem to be related to the Firefox update (I'm on the latest version, by the way - it should be listed under system details). Any other suggestions? This is pretty weird.

Thanks for the replies. It's not zoom related (and I haven't changed the default text sizes), I can tell you that. I tried restarting firefox without addons and the issue is not present then, however, if I disable each addon individually (to figure out which one is causing the issue), the issue is still present. Like I said, this is a new issue so it really does seem to be related to the Firefox update (I'm on the latest version, by the way - it should be listed under system details). Any other suggestions? This is pretty weird.

Modificato da ArtisticScientist il

Utente che ha posto la domanda

Oops, didn't see the last post. I tried clearing cache and cookies first, but that didn't help either. :(

Edit: Couldn't attach a picture, so here's a link instead: http://i683.photobucket.com/albums/vv193/SweetHeartGirl/Screenshot1238_zps6daee742.png

I realized that it's something that's not displayed in the middle of the page. If I scroll down to the very bottom, for example, I can see part of the bottom of the page. But if I scroll up at all, it disappears again.

Oops, didn't see the last post. I tried clearing cache and cookies first, but that didn't help either. :( Edit: Couldn't attach a picture, so here's a link instead: http://i683.photobucket.com/albums/vv193/SweetHeartGirl/Screenshot1238_zps6daee742.png I realized that it's something that's not displayed in the middle of the page. If I scroll down to the very bottom, for example, I can see part of the bottom of the page. But if I scroll up at all, it disappears again.

Modificato da ArtisticScientist il

cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
FredMcD
  • Top 10 Contributor
4254 soluzioni 59584 risposte

If all else fails;

Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

If all else fails; '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Utente che ha posto la domanda

Thanks again for all the replies, guys. I've tried all of the suggestions - some even twice - and it still happens.

What baffles me is that it DOESN'T happen in safe mode, but it's not add-on related either, because if I restart Firefox and disable all add-ons, the problem still occurs. It's just strange.

I tried looking specifically into what safe mode disables (relating to this issue), but couldn't find anything that could help. Perhaps one of you would have an idea?

Thanks again for all the replies, guys. I've tried all of the suggestions - some even twice - and it still happens. What baffles me is that it DOESN'T happen in safe mode, but it's not add-on related either, because if I restart Firefox and disable all add-ons, the problem still occurs. It's just strange. I tried looking specifically into what safe mode disables (relating to this issue), but couldn't find anything that could help. Perhaps one of you would have an idea?
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • default toolbar layout is used
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
You can try to disable OMTC and leave hardware acceleration in Firefox enabled. *<b>about:config</b> page: <b>layers.offmainthreadcomposition.enabled</b> = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config ---- You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder in profile folder) *default toolbar layout is used *JavaScript JIT compilers are disabled *hardware acceleration is disabled (Options > Advanced > General) *plugins are not affected *preferences are not affected
FredMcD
  • Top 10 Contributor
4254 soluzioni 59584 risposte

Safe mode disables add-ons (but not plugins), Hardware Acceleration, and turns off some user settings.

Reset Firefox {web link} is a LAST RESORT ! !

Reset Firefox -- easily fix most problems

If you're having problems with Firefox, resetting it can help. The reset feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs.


https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Safe mode disables add-ons (but not plugins), Hardware Acceleration, and turns off some user settings.<br><br> '''[https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems Reset Firefox]''' {web link} is a '''LAST RESORT ! !''' Reset Firefox -- easily fix most problems If you're having problems with Firefox, resetting it can help. The reset feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. -------------------- '''https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile''' '''https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles'''

Utente che ha posto la domanda

Guess I'll try resetting it later. Hopefully that'll work.

Thanks again!

Guess I'll try resetting it later. Hopefully that'll work. Thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

Do you see all the text in the page source?

You can try to install the DOM Inspector and check if there are rules that set a height for that container.

Do you see all the text in the page source? You can try to install the DOM Inspector and check if there are rules that set a height for that container. *DOM Inspector: https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ *https://developer.mozilla.org/DOM_Inspector *https://developer.mozilla.org/Introduction_to_DOM_Inspector
Torye 0 soluzioni 7 risposte

My site doesn't show the same as in IE and Chrome — it's cut off.

Take a look please:

http://www.thelovereporter.com/ (IE)

http://www.thelovereporter.com/ (Chrome)

http://www.thelovereporter.com/ (Firefox culprit)  : It would be very nice to fix this since I'm a die-hard Firefox fan.

Thank you for responding!

Torye

My site doesn't show the same as in IE and Chrome — it's cut off. Take a look please: http://www.thelovereporter.com/ (IE) http://www.thelovereporter.com/ (Chrome) http://www.thelovereporter.com/ (Firefox culprit) : It would be very nice to fix this since I'm a die-hard Firefox fan. Thank you for responding! Torye
Torye 0 soluzioni 7 risposte

I just noticed that I'm on someone else's thread. So sorry! I'll find where I should be.

I just noticed that I'm on someone else's thread. So sorry! I'll find where I should be.

Utente che ha posto la domanda

It's fine! For the record though, your site looks okay to me? Do you have a screenshot? I'd like to know if we're experiencing the same issue because I never did fix mine :(

It's fine! For the record though, your site looks okay to me? Do you have a screenshot? I'd like to know if we're experiencing the same issue because I never did fix mine :(
Torye 0 soluzioni 7 risposte

Here you go Jasmine. Was your question to the forum recent?

Here you go Jasmine. Was your question to the forum recent?
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

Hi Torye

The website looks OK to me most of the time. This happens with floating content and the sidebar doesn't fit next to the main content column and thus get pushed down. I've been able to reproduce the sidebar being pushed down with zoom text only and zooming 120%. I also see issues with the sidebar overlapping the main content with a default minimum set to 9 or lower (10 still shows correctly). So you can check for issues with zooming the page and check the font size prefs on the about:config page to see if you made any changes.


You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
Hi Torye The website looks OK to me most of the time. This happens with floating content and the sidebar doesn't fit next to the main content column and thus get pushed down. I've been able to reproduce the sidebar being pushed down with zoom text only and zooming 120%. I also see issues with the sidebar overlapping the main content with a default minimum set to 9 or lower (10 still shows correctly). So you can check for issues with zooming the page and check the font size prefs on the <b>about:config</b> page to see if you made any changes. ---- You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac)
Torye 0 soluzioni 7 risposte

Thank you cor-el,

I did the zoom up and down without success.

The only question I have is — since the site shows up perfectly on IE and Chrome — why would I want to change size and font and then screw up the other two?

Have you looked at my site on IE and Chrome? This is truly a FF issue and I wish there was a FF fairy with a magic wand to straighten things out :-)

By the way — is there anywhere I could get a programmer to fix this?

Thank you cor-el, I did the zoom up and down without success. The only question I have is — since the site shows up perfectly on IE and Chrome — why would I want to change size and font and then screw up the other two? Have you looked at my site on IE and Chrome? This is truly a FF issue and I wish there was a FF fairy with a magic wand to straighten things out :-) By the way — is there anywhere I could get a programmer to fix this?
cor-el
  • Top 10 Contributor
  • Moderator
17525 soluzioni 158458 risposte

I'm on Linux, so can't do testing with IE. Google Chrome shows issues when I zoom the page.

It did some further testing in Firefox and the page only looks good with the default setting (16) for the size of the proportional font as set in Tools > Options > Content : Fonts & Colors Setting this value to 17 makes the sidebar jump to the bottom and setting it to 15 makes the sidebar shift under the Flash object.

I'm on Linux, so can't do testing with IE. Google Chrome shows issues when I zoom the page. It did some further testing in Firefox and the page only looks good with the default setting (16) for the size of the proportional font as set in Tools > Options > Content : Fonts & Colors Setting this value to 17 makes the sidebar jump to the bottom and setting it to 15 makes the sidebar shift under the Flash object.
Torye 0 soluzioni 7 risposte

I appreciate all responses — thank you!

Please don't forget: If you know of a Firefox programming specialist — can you pass his/her info to me?

Torye

I appreciate all responses — thank you! Please don't forget: If you know of a Firefox programming specialist — can you pass his/her info to me? Torye