Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

security.tls.version.max keeps changing by itslef, how can I prevent it to change from the default?

  • 4 risposte
  • 1 ha questo problema
  • 647 visualizzazioni
  • Ultima risposta di RobFF

more options

I have one web site that does not work when security.tls.version.max. is not the default.

I don't know why, but this setting keeps changing, and I have to manually reset it using the about:config page.

Is there a way to know what changes this setting, and is there a way to prevent this from happening?

Thanks in advance for any help.

Soluzione scelta

Yes you can lock it, see : Locking preferences

thanks again

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (4)

more options

Hello RobFF, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

thank you

more options

Thank you for the fast reply.

I tried using FF without ad-ons, but I have so many customizations that not using then is just impossible in my environment. The problem happens randomly maybe once a day, with a very heavy FF usage. I could not work all day without any ad-on and therefore could not reproduce the problem in that state.

In particular, it might be the ad-on to use the site that does not work when TLS is reset that is the culprit! Without the ad-on, using this site is cumbersome.

I'll try to follow the guide, but it's not going to be easy with a problem that needs one day testing to reproduce.

I was hoping with a way to lock the TLS setting regardless of what any ad-on could try to do with it, but from your answer, there does not seem to be any.

If I find out, I will of course post the information.

more options

Soluzione scelta

Yes you can lock it, see : Locking preferences

thanks again

more options

Great, exactly what I needed.

I followed the guide, and this setting is indeed locked now.

Thanks!