Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Why did firefox change yahoo home page. Now different from IE

  • 10 risposte
  • 7 hanno questo problema
  • 12458 visualizzazioni
  • Ultima risposta di jscher2000

more options

For some reason the Yahoo home page which I always use has been changed on Firefox. On IE it is the good old home page that I not only like but was used to. I prefer Firefox as my browser but would like the regular Yahoo home page back. Any ideas?

Soluzione scelta

The one on the left looks like a simplified "mobile" layout. It could be that one of your Yahoo cookies that Firefox sends back to the site has a preference for that layout. Since private windows have a separate set of cookies, that would be consistent with the results of your test.

Do you want to try clearing all your Yahoo cookies to see whether that fixes it? First, save any pending work such as draft email messages. While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, yahoo.com should show at the top. You can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Leggere questa risposta nel contesto 👍 8

Tutte le risposte (10)

more options

Could you compare three things for me:

(1) the address of the home page displayed in Firefox, (2) the address of the home page displayed in IE, and (3) the address in the Options dialog that Firefox is supposed to be loading

If they are very long, you might need to copy them out of the address bar into a reply for easier comparison. To get back into the Options dialog, you can use the steps in this article: Startup, home page, tabs, and download settings.

Any differences?


Sometimes you will find some unexpected parts in the URL which are inserted by an extension. You might want to review your extensions and disable nonessential or unrecognized ones on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help at all?

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

Hope these show up well enough. One more thing that might be important is that when I switch to "private browsing" in firefox and go to yahoo the "normal" screen shows up.

more options

Soluzione scelta

The one on the left looks like a simplified "mobile" layout. It could be that one of your Yahoo cookies that Firefox sends back to the site has a preference for that layout. Since private windows have a separate set of cookies, that would be consistent with the results of your test.

Do you want to try clearing all your Yahoo cookies to see whether that fixes it? First, save any pending work such as draft email messages. While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, yahoo.com should show at the top. You can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

more options

This seems to be the answer I was looking for. After deleting the cookies I restarted my home page and there was the page I have grown used to. Thank you so very much. This makes my experience on the web much better and far more enjoyable.

more options

I have the same problem too. I had the same problem about two months ago and someone on here told me what to do. Unfortunately I did not write it down so i don't remember. I've tried, tools-options - advance - general - unchecked use hardware acceleration when available...it did not work. Yahoo main page looks perfect on IE, on Firefox it's a mess. Someone please help.

Modificato da sepharad il

more options

Hi sepharad, did you try the steps listed here: https://support.mozilla.org/questions/1024465#answer-638804

more options

Thank you it's fixed.

more options

? SOLUTION ? I wasted three hours last night trying to sget rid of the Yahoo home page. Just now I uninstalled Adobe Air and some superfluous unknown interloper with "hold" in its name; I had to restart after. When Windows restarted there was a notification that there was a new version of Firefox, which I installed. One of these three items presumably caused the Yahoo! glitch. ? SOLUTION ? I wasted three hours last night trying to sget rid of the Yahoo home page. Just now I uninstalled Adobe Air and some superfluous unknown interloper with "hold" in its name; I had to restart after. When Windows restarted there was a notification that there was a new version of Firefox, which I installed. One of these three items presumably caused the Yahoo! glitch.

more options

Hi johnbarr, I replied to your other post here: https://support.mozilla.org/questions/1018414#answer-669587