Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Disable HTTPS redirect

  • 3 risposte
  • 31 hanno questo problema
  • 97909 visualizzazioni
  • Ultima risposta di lostinlodos

more options

How do I disable HTTPS redirect. I am "aware of the risks" blah blah paranoid blah. And well aware of what I'm doing. But for some reason with 32 no everything heads over to https including non-https bookmarks.

No matter how I type it in; HTTP://www.xxxx www.xxxxx

I would like to find some way, by setting, about:config command (or hack if I have to) or even an extension someone could point me to that could stop this maddening overuse of secure transfers.

Soluzione scelta

Disabling https, is not an absolute in Firefox. Some sites will redirect and may not offer http.

However to choose one url over the other if it is an option you can disable autofil:


Address Bar Search In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. In the filter box, type or paste autofill and pause while the list is filtered
  4. Double-click browser.urlbar.autoFill to toggle it from true to false.
Leggere questa risposta nel contesto 👍 11

Tutte le risposte (3)

more options

Soluzione scelta

Disabling https, is not an absolute in Firefox. Some sites will redirect and may not offer http.

However to choose one url over the other if it is an option you can disable autofil:


Address Bar Search In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. In the filter box, type or paste autofill and pause while the list is filtered
  4. Double-click browser.urlbar.autoFill to toggle it from true to false.
more options

It's not all sites, though, just some sites? Like the following URL that you've never visited before (on a site that has not SSL support):

http://dev.jeffersonscher.com/jstest.asp

If ALL sites attempt HTTPS, make sure you haven't installed the "HTTPS Everywhere" extension or something similar.

You can review and disable extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. I suggest disabling unrecognized and nonessential extensions, and removing any that obviously are undesirable (if any).

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that resolve it?

more options

@guigs2 Actually had that set for some time. But you sparked my memory and I double checked. Either an addon/plugin or a firefox update had wiped out my settings there. Fixed and all my bookmarks are back to accurate. Thanks for the reminder. !!

)