Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Icons not displaying correctly getting text instead.

  • 13 risposte
  • 2 hanno questo problema
  • 2293 visualizzazioni
  • Ultima risposta di cor-el

more options

I have tried all options that I have found on your forum with no luck. I went as far as resting my Firefox to default with no success.

Using MAC 10.8.5

My setting are set up correct - Allow pages to choose their own fonts, instead of my selections above is checked.

I also rest this as well gfx.downloadable_fonts.enabled

So far no luck I am still getting text instead of the icons.

Soluzione scelta

Yes, that shows that a downloadable font isn't retrieved

The Web Console shows: downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:2): bad URI or cross-site access not allowed source: http://topproducerloops.com/wp-content/themes/simplepxcreate/assets/font/fontawesome-webfont.ttf?v=3.2.1

It looks that it is caused by the domain with and without the leading www. http://topproducerloops.com redirect to http://www.topproducerloops.com and a lot of links in the main page source show files retrieved from topproducerloops.com as you can see in the error message.

You can use this bookmarklet to correct this issue.

javascript:f=document.querySelector("link[id=\"fontawesome-css\"]");f.href=f.href.replace(/\/\/(?!www)/,"//www");void(0);

You can create a new bookmark on the Bookmarks Toolbar and paste the code in the location field. After the page has finished loading, you can click the button to run the code.

You can contact the website and set their attention to this issue and ask them to correct this.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (13)

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

Here is a picture and I am able to get it to work within Safari and my mobile devices but not Firefox. I even tested it out on my wife's PC laptop.

more options

It may be you are using blocking options / add-ons.

Start Firefox in Safe Mode {web link}

Poke around safe web sites. Are there any problems?

Then restart.

more options

Still did not work going to try this on my wifes PC laptop once.

more options

Same thing with my wife's laptop.

more options

The missing icons are supplied by a font that is downloaded from the server (@font-face) as you can probably see by little boxes that show the hex code of the characters.

Make sure that you allow pages to choose their own fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Modificato da cor-el il

more options

I tried that already with the same results.

more options

I noticed that I had missed that you are using a Mac and had posted links for the Windows platform.

Did you check the setting in Firefox > Preferences > Content : Fonts & Colors > Advanced ?

You can open the Web Console (Tools > Web Developer). Check on the Network tab if any content is blocked and has a file size 0 (zero).

more options

Yes and it's check to use other text as well. I did find some stuff with file size zero sending you an image.

more options

Soluzione scelta

Yes, that shows that a downloadable font isn't retrieved

The Web Console shows: downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:2): bad URI or cross-site access not allowed source: http://topproducerloops.com/wp-content/themes/simplepxcreate/assets/font/fontawesome-webfont.ttf?v=3.2.1

It looks that it is caused by the domain with and without the leading www. http://topproducerloops.com redirect to http://www.topproducerloops.com and a lot of links in the main page source show files retrieved from topproducerloops.com as you can see in the error message.

You can use this bookmarklet to correct this issue.

javascript:f=document.querySelector("link[id=\"fontawesome-css\"]");f.href=f.href.replace(/\/\/(?!www)/,"//www");void(0);

You can create a new bookmark on the Bookmarks Toolbar and paste the code in the location field. After the page has finished loading, you can click the button to run the code.

You can contact the website and set their attention to this issue and ask them to correct this.

Modificato da cor-el il

more options

I am the site owner and once you showed me that error I knew what it was. It is working again thank you so much.

more options

It was a setting within my website.

more options

You're welcome. Yes, it is working for me now.