Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox won't display video from Facebook, same vids play on YouTube

  • 2 risposte
  • 11 hanno questo problema
  • 2563 visualizzazioni
  • Ultima risposta di cor-el

more options

Running Firefox 31.0 on OpenSuSE 13.1 x64 with KDE 4.11 desktop. Videos embedded in Facebook posts will not play. Clicking on them results in moving arrows as though the vid is loading, then the video display area turns into a black box. Moving the cursor over the black box and right-clicking brings up the usual Flash player 3-item menu. The same video that is linked in the FB page will open and play perfectly at the YouTube site. This happens even after clearing the cache, disabling plug-ins and starting in safe mode. Videos also play perfectly using Chrome and Konquerer

Tutte le risposte (2)

more options

Hello, I want to recommend hardware acceleration, but I also saw this issue for protected mode for flash player: http://helpx.adobe.com/x-productkb/mu.../flash-player-11-problems-playing.html does disabling protected mode improve the issue?

____________hardware acceleration instructions below. ________________

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window