Cerca nel supporto

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 31 not clearing cache, showing content that no longer exists

  • 5 risposte
  • 18 hanno questo problema
  • 1727 visualizzazioni
  • Ultima risposta di FredMcD

more options

on www.westportnow.com, there are images that display as part of an ad network. Problem is, FF is not changing the images even when the images no longer exists. I looked in about:cache, and found this information about one problem image: http://cdn.westportnow.com/adv/images/WCPNora1.gif 52062 bytes 1 2014-08-02 17:36:28 2014-08-05 08:07:59 showing that this image expires on August 5.

How do I change this so images that no longer exist go away? I guess what I'm trying to figure out is how to clear cached images -- which is easily done in Chrome, but I can't find out how to do it in FF. Is there a way to set FF to not cache images at all?

Tutte le risposte (5)

more options

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


You can also try to clear the cache folder on the hard drive. You can find the location of the disk cache on the about:cache page.

more options

How do I disable image caching permanently? For any website? FF 31 is the only browser that I know of that does not load new images on page reload.

more options

Those are all things I have already tried many times over and over again. Its Firefox and Chrome that has serious issues with caching plugins for WordPress. No matter how much or what you do it just does not bring back what your missing in the website.

Internet Explorer 11 does not have the issues that Firefox and Chrome does with cache refreshing. With all the people saying they are better than Internet Explorer, you would think they would fix this. I used to love either Firefox or Chrome, but now I am very tired of playing this game, and not getting anything back the way it should be because of these two browsers not working right.

Were these browser just made for browsing or for developing too? Seems to me they are made just for faster browsing, and could care less about people the develop websites. I do not like the way Internet Explorer looks, but I might just stay with it, because it refreshes the caching right.

more options

Empty Cache Button {web link} Cache clearing made easy. One click.

more options

Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy.

The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on Cache.