Risoluzione dei problemi relativi ai plugin | Soluzioni

Risoluzione dei problemi relativi ai plugin

Se si riscontrano problemi con pagine web in cui vengono utilizzati i plugin (come Flash, Java e altri) per la visualizzazione dei contenuti, potrebbe essere necessario verificare se uno dei plugin sia la causa del problema.

Di seguito alcuni dei problemi più comuni causati dai plugin:

Questo articolo spiega come individuare i problemi relativi ai plugin. Se si stanno riscontrando problemi con estensioni o temi, fare riferimento all'articolo Risoluzione dei problemi relativi a estensioni e temi. Per informazioni generali sui plugin, leggere l'articolo Utilizzare i plugin con Firefox.

Determinare se il problema sia causato da un plugin

È possibile disattivare i plugin in maniera selettiva mentre Firefox è in esecuzione. Se si pensa che un certo plugin stia causando il problema, si può disattivare e controllare se l'errore si ripresenta. Se non si ha idea di quale plugin disattivare:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Selezionare un plugin in elenco e fare clic sul corrispondente tasto Disattiva. Ripetere questa operazione per ciascun plugin in elenco fino a disattivarli tutti. Non occorre riavviare Firefox per rendere effettive le modifiche.
  4. Verificare se il problema persiste. In caso contrario, riaprire la scheda di gestione dei componenti aggiuntivi e riattivare uno per uno i plugin con il tasto Attiva finché non si individua quello che causa il problema.
  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Selezionare un plugin in elenco e successivamente la voce Non attivare mai del menu a discesa corrispondente. Ripetere questa operazione per ciascun plugin in elenco fino a disattivarli tutti. Non occorre riavviare Firefox per rendere effettive le modifiche.
  4. Verificare se il problema persiste. In caso contrario, riaprire la scheda di gestione dei componenti aggiuntivi e riattivare uno per uno i plugin con il tasto Attiva finché non si individua quello che causa il problema.

Se si individua il plugin problematico, continuare con le istruzioni contenute in questo articolo.

Aggiornare o reinstallare i plugin

Molti problemi relativi ai plugin possono essere risolti aggiornandoli all'ultima versione disponibile. Per verificare se si stanno utilizzando plugin obsoleti, visitare la pagina di verifica plugin di Mozilla.

Se il problema non viene risolto da un aggiornamento o da una reinstallazione, si può decidere di lasciare disattivato il plugin.

Disinstallare manualmente un plugin

Se non è possibile utilizzare un programma di disinstallazione per eliminare un plugin, si può rimuoverlo manualmente utilizzando le istruzioni riportate di seguito.

  1. Digitare about:plugins nella Barra degli indirizzi e premere Invio per visualizzare la pagina di informazioni sui plugin.
  2. Cercare la preferenza plugin.expose_full_path.
  3. Fare doppio clic su plugin.expose_full_path e cambiare il valore a true.
  4. Digitare about:plugins nella barra degli indirizzi e premere Invio per avere l'elenco dei plugin installati.
  5. Ciascun elemento della pagina Informazioni sui plugin riporterà il nome di un file seguito da un percorso. Utilizzare Esplora Risorse per navigareNavigare fino alla cartella contenente il file del plugin da rimuovere.
  6. Assegnare al file un nome diverso - ad esempio rinominare npswf32 come oldnpswf32.
  7. Fare di nuovo doppio clic sulla preferenza plugin.expose_full_path nella pagina about:config per riportare il suo valore a false in modo da evitare che il percorso dei plugin venga comunicato ai siti web.

In questo modo il plugin verrà rimosso.

Se non è possibile utilizzare un programma di disinstallazione per eliminare un plugin, si può rimuoverlo manualmente utilizzando le istruzioni riportate di seguito.

  1. Digitare about:plugins nella Barra degli indirizzi e premere Invio per visualizzare la pagina di informazioni sui plugin.
  2. Ciascun elemento della pagina riporterà il nome di un file seguito da un percorso. Utilizzando un editor di testo, aprire il file pluginreg.dat ubicato nella cartella del profilo per trovare l'esatta posizione del file di ciascun plugin. Utilizzare successivamente Esplora Risorse per navigareNavigare successivamente fino alla cartella contenente il file del plugin da rimuovere.
  3. Assegnare al file un nome diverso - ad esempio rinominare npswf32 come oldnpswf32.

In questo modo il plugin verrà rimosso.

Se non è possibile utilizzare un programma di disinstallazione per eliminare un plugin, si può rimuoverlo manualmente utilizzando le istruzioni riportate di seguito.

  1. Digitare about:plugins nella Barra degli indirizzi e premere Invio per visualizzare la pagina Plugin installati.
  2. Ciascun elemento della pagina riporterà il nome di un file seguito da un percorso. Utilizzare Esplora Risorse per navigareNavigare fino alla cartella contenente il file del plugin da rimuovere.
  3. Assegnare al file un nome diverso - ad esempio rinominare npswf32 come oldnpswf32.

In questo modo il plugin verrà rimosso.

Reinizializzare il database dei plugin

In alcuni casi, potrebbe essere impossibile installare o reinstallare un dato plugin. Il problema può essere a volte corretto reinizializzando il database dei plugin.

  1. Aprire la cartella del profilo:

    Dal menu in alto nella finestra di Firefox, fare clic sul pulsante Firefox, spostarsi sul menu AiutoSulla barra dei menu, fare clic su AiutoDal menu in alto nella finestra di Firefox, fare clic su Aiuto e selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 , quindi selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.

  2. Nella sezione Informazioni di base, fare clic sul pulsante Mostra cartellaMostra nel FinderApri percorso. Verrà aperta una finestra con i filela cartella del profilo.
  3. Nota: nel caso in cui non sia possibile aprire o utilizzare Firefox, seguire le istruzioni contenute in Individuare il profilo senza avviare Firefox.

  4. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  5. Cancellare il file pluginreg.dat.
  6. Avviare Firefox.
  7. Nella barra degli indirizzi, digitare about:plugins e premere Invio per visualizzare l'elenco dei plugin.



Condividi questo articolo: http://mzl.la/NYtGci

È stato utile questo articolo?

Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.
Ottieni supporto per una diversa piattaforma:
Personalizza questo articolo

Firefox