Procedure standard per la risoluzione dei problemi | Soluzioni

Procedure standard per la risoluzione dei problemi

Molti dei problemi comuni che si incontrano nell'utilizzo di Firefox possono essere risolti utilizzando le procedure descritte di seguito. Eseguire le seguenti operazioni procedendo nell'ordine proposto. Nel caso di dubbi sui passi da seguire, è possibile richiedere supporto specifico.

Nota: controllare questo elenco relativo ai problemi recenti segnalati per verificare se il problema riscontrato nell'utilizzo di Firefox dispone di una soluzione.

1. Riavviare il computer

A volte alcuni problemi possono essere risolti con un semplice riavvio del sistema. Dopo aver riavviato il computer, provare a riavviare Firefox.

2. Cancellare i cookie e la cache

Molti problemi di caricamento delle pagine possono essere risolti eliminando i cookie e la cache.

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Strumenti e selezionare Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Strumenti e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Cronologia e selezionare Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Cronologia e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
  1. Fare clic sul pulsante dei menu New Fx Menu , successivamente su Cronologia e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
Per ulteriori informazioni, fare riferimento alla pagina Cancellare la cronologia recente.

3. Riavviare Firefox in modalità provvisoria

Quando si esegue Firefox in modalità provvisoria vengono disattivate tutte le estensioni, viene forzato il tema predefinito, viene disattivata l'accelerazione hardware e viene caricato l'insieme predefinito di controlli per le barre degli strumenti. Per avviare Firefox in questa modalità:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente sul menu AiutoDalla barra dei menu, fare clic sul menu AiutoNella parte superiore della finestra di Firefox fare clic sul menu Aiutoe selezionare Riavvia disattivando i componenti aggiuntivi.... Al riavvio di Firefox verrà mostrata la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
    Fare clic sul pulsante dei menu New Fx Menu , successivamente sul pulsante di aiuto Help-29 e selezionare Riavvia disattivando i componenti aggiuntivi.... Firefox si avvierà con la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
  2. Nella finestra di dialogo della modalità provvisoria fare clic su Continua in modalità provvisoriaAvvia in Modalità provvisoria.
  3. Controllare se il problema si manifesta ugualmente mentre ci si trova in modalità provvisoria.

4. Risolvere i problemi relativi ai plugin

A volte i problemi possono essere causati da uno o più plugin installati (come Adobe Reader, Flash, Java, QuickTime, RealPlayer e Windows Media Player). Il più delle volte la causa risiede nel mancato aggiornamento di uno o più plugin. Per controllare se si utilizzano i plugin all'ultima versione disponibile, visitare la pagina di controllo plugin. Se vi sono plugin non aggiornati, fare clic su Aggiorna e seguire le istruzioni specifiche relative all'aggiornamento di ciascun plugin. Dopo aver aggiornato tutti i plugin, riavviare Firefox: nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox (menu File in Windows XP) e successivamente su Escisulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefoxnella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci. Riavviare quindi Firefox. Se il problema continua a verificarsi, provare a disattivare tutti i plugin per vedere se la causa sia riconducibile a uno di essi:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Fare clic su ciascun plugin in elenco e per ciascuno di essi fare clic sul pulsante Disattiva.
  4. Controllare se il problema continua a verificarsi.
  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Fare clic su ciascun plugin in elenco e per ciascuno di essi selezionare l'opzione Non attivare mai dal menu a discesa.
  4. Controllare se il problema continua a verificarsi.

Se il malfunzionamento non si verifica, leggere l'articolo Risoluzione dei problemi relativi ai plugin per capire come individuare il plugin che lo sta causando.

5. Reinstallare Firefox

Alcuni problemi potrebbero risiedere in uno o più file del programma Firefox. Seguire i passi riportati di seguito per rimuovere completamente e reinstallare Firefox.

Nota: potrebbe essere opportuno stampare queste istruzioni o visualizzarle in un altro browser.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Eliminare la cartella di installazione ubicata per impostazione predefinita in
    • C:\Program files\Mozilla Firefox per le versioni di Windows a 32-bit
    • C:\Program Files (x86)\Mozilla Firefox per le versioni di Windows a 64-bit
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Windows.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Disinstallare Firefox aprendo la cartella Applicazioni nel Finder e trascinando l'applicazione Firefox nel Cestino.
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Mac.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Disinstallare Firefox: se il programma è stato installato utilizzando il gestore di pacchetti della distribuzione utilizzata è opportuno disinstallarlo utilizzando quello stesso sistema - leggere Installare Firefox su Linux per maggiori dettagli. Se invece il programma è stato scaricato in forma binaria dalla pagina di download di Firefox, è sufficiente cancellare la cartella firefox presente nella propria Home.
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Linux.

Successivamente, avviare Firefox per capire se il problema si è risolto. Se si è risolto, è possibile reinstallare le estensioni e i temi che non stanno causando malfunzionamenti (vedere paragrafo 3). Se il problema continua a verificarsi, proseguire nella lettura di questo articolo.

6. Ripristinare Firefox

La funzione di ripristino di Firefox può risultare risolutiva in molte occasioni in quanto consente di riportare Firefox ai suoi valori predefiniti effettuando contemporaneamente il salvataggio delle informazioni personali.

Nota: quando si utilizza la funzione di ripristino vengono conservati i segnalibri, la cronologia di navigazione, le finestre e le schede aperte, le password, i cookie e le informazioni di completamento automatico dei moduli. Verranno comunque rimossi i temi e le estensioni e verranno totalmente reimpostate le preferenze.quando si utilizza la funzione di ripristino, vengono conservati i segnalibri, la cronologia di navigazione, le password, i cookie e le informazioni di completamento automatico dei moduli. In ogni caso i temi e le estensioni vengono rimossi; le schede aperte, le finestre e i gruppi di schede non vengono salvati; le preferenze vengono totalmente reimpostate. Per ulteriori informazioni leggere l'articolo La funzione di ripristino di Firefox.
  1. Nella parte superiore della finestra di Firefox, fare clic sul menu Aiuto e selezionare Risoluzione dei problemi.Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, spostarsi al sottomenu Aiuto e selezionare Risoluzione dei problemi.Dalla barra dei menu, fare clic sul menu Aiuto e selezionare Risoluzione dei problemi.

    reset_winxp_1

    fx_reset_1_win

    fx_reset_1_mac

    fx_reset_1_linux


    Nel caso in cui non sia possibile accedere al menu Aiuto, per visualizzare la pagina Informazioni per la risoluzione dei problemi, digitare about:support nella barra degli indirizzi e premere il tasto Invio.
  2. Fare clic sul pulsante Ripristina Firefox nell'angolo superiore destro della pagina Informazioni per la risoluzione dei problemi.

    reset_winxp2

    fx_reset_3_win

    fx_reset_2_mac

    fx_reset_2_linux


  3. Per continuare, fare clic sul pulsante Ripristina Firefox nella successiva finestra di conferma.Per continuare, fare clic sul pulsante Ripristina Firefox nella successiva scheda a discesa di conferma.
  4. Firefox verrà chiuso e ripristinato. Al riavvio, in una finestra verrà presentato l'elenco di tutte le informazioni importate. Fare clic sul pulsante Fine per aprire Firefox.Firefox verrà chiuso e ripristinato. Al riavvio, in una finestra verrà presentato l'elenco di tutte le informazioni importate. Fare clic sul pulsante Fatto per aprire Firefox.
  1. Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 .
  2. Dal menu Aiuto selezionare Risoluzione dei problemi.
    Nel caso in cui non sia possibile accedere al menu Aiuto, per visualizzare la pagina Informazioni per la risoluzione dei problemi, digitare about:support nella barra degli indirizzi e premere il tasto Invio.
  3. Fare clic sul pulsante Ripristina Firefox... nell'angolo superiore destro della pagina Informazioni per la risoluzione dei problemi.

    reset_fx29_win reset_fx29_mac reset_fx29_linux
  4. Per continuare, fare clic sul pulsante Ripristina Firefox nella successiva finestra di conferma.
  5. Firefox verrà chiuso e ripristinato. Al riavvio, in una finestra verrà presentato l'elenco di tutte le informazioni importate. Fare clic sul pulsante Fine per aprire Firefox.

1. Riavviare il computer

A volte alcuni problemi possono essere risolti con un semplice riavvio del sistema. Dopo aver riavviato il computer, provare a riavviare Firefox.

2. Cancellare i cookie e la cache

Molti problemi di caricamento delle pagine possono essere risolti eliminando i cookie e la cache.

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Strumenti e selezionare Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Strumenti e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Cronologia e selezionare Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Cronologia e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
  1. Fare clic sul pulsante dei menu New Fx Menu , successivamente su Cronologia e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa Intervallo di tempo da cancellare: selezionare la voce tutto.
  3. Fare clic sulla freccia posta accanto a Dettagli per visualizzare l'elenco degli elementi da eliminare.
  4. Selezionare Cookie e Cache (solamente).
  5. Fare clic su Cancella adesso.
Per ulteriori informazioni, fare riferimento alla pagina Cancellare la cronologia recente.

3. Riavviare Firefox in modalità provvisoria

Quando si esegue Firefox in modalità provvisoria vengono disattivate tutte le estensioni, viene forzato il tema predefinito, viene disattivata l'accelerazione hardware e viene caricato l'insieme predefinito di controlli per le barre degli strumenti. Per avviare Firefox in questa modalità:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente sul menu AiutoDalla barra dei menu, fare clic sul menu AiutoNella parte superiore della finestra di Firefox fare clic sul menu Aiutoe selezionare Riavvia disattivando i componenti aggiuntivi.... Al riavvio di Firefox verrà mostrata la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
    Fare clic sul pulsante dei menu New Fx Menu , successivamente sul pulsante di aiuto Help-29 e selezionare Riavvia disattivando i componenti aggiuntivi.... Firefox si avvierà con la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
  2. Nella finestra di dialogo della modalità provvisoria fare clic su Continua in modalità provvisoria.
  3. Controllare se il problema si manifesta ugualmente mentre ci si trova in modalità provvisoria.

4. Risolvere i problemi relativi ai plugin

A volte i problemi possono essere causati da uno o più plugin installati (come Adobe Reader, Flash, Java, QuickTime, RealPlayer e Windows Media Player). Il più delle volte la causa risiede nel mancato aggiornamento di uno o più plugin. Per controllare se si utilizzano i plugin all'ultima versione disponibile, visitare la pagina di controllo plugin. Se vi sono plugin non aggiornati, fare clic su Update e seguire le istruzioni specifiche relative all'aggiornamento di ciascun plugin. Dopo aver aggiornato tutti i plugin, riavviare Firefox: nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox (menu File in Windows XP) e successivamente su Escisulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefoxnella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci. Riavviare quindi Firefox. Se il problema continua a verificarsi, provare a disattivare tutti i plugin per vedere se la causa sia riconducibile a uno di essi:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Fare clic su ciascun plugin in elenco e per ciascuno di essi fare clic sul pulsante Disattiva.
  4. Controllare se il problema continua a verificarsi.

Se il malfunzionamento non si verifica, leggere l'articolo Risoluzione dei problemi relativi ai plugin per capire come individuare il plugin che lo sta causando.

5. Ripristinare le impostazioni di Firefox

Alcuni problemi possono essere risolti ripristinando le impostazioni predefinite di Firefox:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente sul menu AiutoDalla barra dei menu, fare clic sul menu AiutoNella parte superiore della finestra di Firefox fare clic sul menu Aiutoe selezionare Riavvia disattivando i componenti aggiuntivi.... Al riavvio di Firefox verrà mostrata la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
    Fare clic sul pulsante dei menu New Fx Menu , successivamente sul pulsante di aiuto Help-29 e selezionare Riavvia disattivando i componenti aggiuntivi.... Firefox si avvierà con la finestra di dialogo della modalità provvisoria.
    Nota: è possibile anche avviare Firefox in modalità provvisoria tenendo premuto il tasto Maiusc mentre si avvia Firefox.tenendo premuto il tasto Opt mentre si avvia Firefox.chiudendo Firefox e successivamente aprendo un Terminale e digitando: firefox -safe-mode
    seguito da Invio. Potrebbe essere necessario specificare il percorso di installazione di Firefox (es.: /usr/lib/firefox).
  2. Dalla finestra di dialogo della modalità provvisoria, fare clic su Ripristina le preferenze predefinite di Firefox.
  3. Per rendere effettive le modifiche, fare clic su Applica le modifiche e riavvia.

6. Reinstallare Firefox

Alcuni problemi potrebbero risiedere in uno o più file del programma Firefox. Seguire i passi riportati di seguito per rimuovere completamente e reinstallare Firefox.

Nota: potrebbe essere opportuno stampare queste istruzioni o visualizzarle in un altro browser.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Eliminare la cartella di installazione ubicata per impostazione predefinita in
    • C:\Program files\Mozilla Firefox per le versioni di Windows a 32-bit
    • C:\Program Files (x86)\Mozilla Firefox per le versioni di Windows a 64-bit
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Windows.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Disinstallare Firefox aprendo la cartella Applicazioni nel Finder e trascinando l'applicazione Firefox nel Cestino.
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Mac.
  1. Scaricare l'ultima versione ufficiale di Firefox da mozilla.org.
  2. Chiudere completamente Firefox:

    Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  3. Disinstallare Firefox: se il programma è stato installato utilizzando il gestore di pacchetti della distribuzione utilizzata è opportuno disinstallarlo utilizzando quello stesso sistema - leggere Installare Firefox su Linux per maggiori dettagli. Se invece il programma è stato scaricato in forma binaria dalla pagina di download di Firefox, è sufficiente cancellare la cartella firefox presente nella propria Home.
  4. Reinstallare Firefox leggendo le istruzioni contenute nell'articolo Installare Firefox su Linux.

Successivamente, avviare Firefox per capire se il problema si è risolto. Se si è risolto, è possibile reinstallare le estensioni e i temi che non stanno causando malfunzionamenti (vedere paragrafo 3). Se il problema continua a verificarsi, proseguire nella lettura di questo articolo.

7. Creare un nuovo profilo

Un profilo corrotto può causare svariati problemi con Firefox. È perciò consigliata la creazione di un nuovo profilo di test per capire se il problema in questo modo si risolve. In caso affermativo, è possibile copiare nel nuovo profilo i dati personali (segnalibri, password salvate, ecc. ecc.).

  1. Seguire le istruzioni date all'articolo Gestione dei profili per avviare il gestore dei profili e creare un nuovo profilo.
    Durante la creazione del nuovo profilo evitare di cancellare il vecchio profilo. In caso contrario, verranno persi i segnalibri, la cronologia, le password e le impostazioni.
  2. Una volta creato il nuovo profilo, selezionarlo dal gestore dei profili e fare clic su Avvia Firefox.

Verificare se il problema si presenta anche col nuovo profilo. In caso contrario, si possono copiare nel nuovo profilo i dati personali seguendo le istruzioni contenute in Recuperare dati personali da un vecchio profilo.

Altre soluzioni

Se nessuna delle precedenti soluzioni ha risolto il problema, è possibile che esso sia causato da altri programmi installati sul sistema o dall'hardware utilizzato.

Questa sezione non contiene procedure guidate. Per maggiori informazioni su ciascuna soluzione proposta si prega di far riferimento alla documentazione relativa al sistema operativo o al programma indicato.

Conflitti causati da programmi per la sicurezza in Internet

Alcuni programmi per la sicurezza in Internet (come i programmi antivirus, antispyware e firewall) possono interagire in maniera anomala con Firefox, impedendo ad esempio l'apertura delle pagine web, provocando chiusure improvvise del programma, ecc. ecc. Il più delle volte il problema si risolve accedendo alle opzioni del programma, rimuovendo Firefox dalla lista dei programmi consentiti e facendo in modo che il programma individui nuovamente Firefox. Se il programma è elencato nell'articolo dedicato ai firewall, è possibile ottenere istruzioni specifiche su come riconfigurarlo.

Problemi causati da virus e spyware

Periodicamente è necessario eseguire una scansione del sistema per individuare eventuali virus, spyware e altri programmi malevoli (malware). È possibile utilizzare anche uno di questi strumenti gratuiti per la rimozione di malware:

Per ulteriori informazioni, consultare anche l'articolo Come capire se un malware impedisce il corretto funzionamento di Firefox.

Errori nel disco fisso o nella memoria RAM del computer

Errori presenti sul disco fisso o nella memoria RAM del computer in uso possono impedire l'avvio di Firefox o provocare continue chiusure inaspettate (crash). Le istruzioni per eseguire un controllo del disco fisso e della RAM sono a queste pagine:



L'articolo è basato sulle informazioni contenute in Standard diagnostic - Firefox (mozillaZine KB)



Condividi questo articolo: http://mzl.la/NYkV1X

È stato utile questo articolo?

Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.
Ottieni supporto per una diversa piattaforma:
Personalizza questo articolo

Firefox