Installare una versione precedente di Firefox

Informazioni sulla versione
  • ID versione: 146395
  • Data di creazione:
  • Autore: Underpass
  • Commento: nuove per fx56
  • Revisionata:
  • Revisionata:
  • Revisionata da: underpass
  • Approvata?
  • Versione corrente? No
  • Pronta per la localizzazione: No
Sorgente della versione
Contenuto della versione

Molti utenti, quando si presenta un problema dopo un aggiornamento di Firefox, tentano di tornare alla versione precedente. Ciò di solito non risolve il problema e aggrava la situazione in quanto rende il computer in uso e i dati personali più facilmente vulnerabili agli attacchi. In questo articolo vengono discusse alcune alternative all'aggiornamento e vengono indicati i link alle versioni precedenti di Firefox.

Installare una versione precedente in genere non risolve i problemi

Se si verificano problemi dopo un aggiornamento di Firefox, questi non sono di norma causati da malfunzionamenti dovuti alla nuova versione in sé ma sono spesso legati ad errori occorsi durante la procedura di aggiornamento. L'installazione di una versione obsoleta difficilmente potrà essere utile per la risoluzione della maggior parte dei problemi riscontrati. Leggere a tal proposito:

Nota: altri tipi di problemi possono essere risolti utilizzando la Funzione di ripristino di Firefox, che consente di riportare il browser alle sue impostazioni originarie mantenendo inalterati i dati personali.

Assicurarsi inoltre che tutti i programmi relativi alla sicurezza siano alle loro versioni più recenti. Alcuni programmi necessitano di essere portati a una versione successiva affinché Firefox possa essere aggiornato correttamente.

Anche per alcuni programmi opzionali distribuiti insieme ai programmi relativi alla sicurezza potrebbe essere necessario un aggiornamento. Tali programmi, anche se non essenziali alla sicurezza del computer, in caso di mancato aggiornamento potrebbero interferire col funzionamento di Firefox o causarne chiusure inaspettate (crash).

Se si desidera lo stesso installare la versione precedente

Sebbene a scopo di test vi sia un archivio web con le versioni precedenti di Firefox, se ne sconsiglia l'utilizzo.
Attenzione: l'utilizzo di versioni obsolete di Firefox costituisce un concreto rischio per la sicurezza.

Per impostazione predefinita, le diverse versioni di Firefox si avvieranno con gli stessi dati del profilo. Se si installa una versione precedente di Firefox dopo aver già utilizzato la versione 55 o una versione successiva si potrebbe incorrere in vari problemi come messaggi di errore, mancata visualizzazione di porzioni dell'interfaccia e impossibilità di navigare in alcuni siti web. Si dovrebbe quindi o creare un nuovo profilo oppure eseguire un ripristino di Firefox dopo aver installato una versione precedente.
  • Per gli utenti Windows XP SP2: l'ultima versione di Firefox precedente alla 49 e compatibile con questo sistema operativo è Firefox 43.0.1 (italiano).
Attenzione: per impostazione predefinita Firefox è configurato per aggiornarsi automaticamente. Se si installa una vecchia versione di Firefox, è necessario modificare le impostazioni del browser per evitare che venga automaticamente aggiornato alla versione più recente disponibile. Per informazioni dettagliate, leggere Impostazioni di Firefox - pannello Avanzate.

Se non è possibile utilizzare l'ultima versione di Firefox, invece di installare una versione precedente e modificare le impostazioni di aggiornamento, è raccomandabile installare l'ultima versione di un altro browser:


Aiutare gli sviluppatori a migliorare Firefox

Se si pensa che l'ultima versione di Firefox sta causando problemi o se si vuole soltanto esprimere un'opinione (anche negativa) su alcune delle caratteristiche, è possibile lasciare un commento a questa pagina: