Aprire i documenti PDF con Firefox | Procedure

Aprire i documenti PDF con Firefox

Per visualizzare i file PDF nella finestra di Firefox, è possibile utilizzare PDF Viewer, il visualizzatore di PDF integrato in Firefox o un plugin specifico per la lettura di questi file. Nel presente articolo vengono spiegati tutti e due i metodi e come risolvere i problemi più comuni.

Per visualizzare i file PDF nella finestra di Firefox, è possibile utilizzare l'estensione PDF Viewer o un plugin specifico per la lettura di questi file. Nel presente articolo vengono spiegati tutti e due i metodi e come risolvere i problemi più comuni.

Nota: il visualizzatore PDF è ora incluso in Firefox: per utilizzarlo occorre aggiornare Firefox all'ultima versione.

Utilizzare il visualizzatore PDF integrato

In Firefox ora è incluso un visualizzatore di PDF integrato nel browser, che consente di visualizzare quasi tutti i file PDF presenti sul web senza dover utilizzare un plugin. Il visualizzatore PDF è attivo per impostazione predefinita.

Utilizzare l'estensione PDF Viewer

PDF Viewer (conosciuta anche come pdf.js) è una nuovissima fantastica estensione che, utilizzando le tecnologie standard del web, consente di visualizzare quasi tutti i file PDF in Firefox senza la necessità di installare un plugin.

PDF JS

Se sul sistema sono installati uno o più plugin di visualizzazione PDF (come Adobe Reader), occorre disattivarli perché l'estensione PDF Viewer funzioni.

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Plugin.
  3. Selezionare ciascun plugin di lettura PDF e fare clic sul pulsante Disattiva accanto ad esso.

Funzioni della barra degli strumenti del visualizzatore PDF

  • Visualizzazione delle anteprime o della struttura del documento: il pulsante di scorrimento all'estrema sinistra consente l'apertura di una barra laterale in cui compaiono le anteprime delle pagine dei documenti. Alcuni documenti possono anche presentare una visualizzazione strutturata in modo da consentire una navigazione più semplice tra le pagine, soprattutto in documenti lunghi.

    PDF Thumbnails
  • Andare alla pagina precedente, a quella successiva, o passare direttamente a una certa pagina: è possibile utilizzare le frecce in alto o in basso per muoversi nel documento oppure inserire il numero della pagina che si desidera visualizzare.

    PDF Pager
  • Aumentare o diminuire lo zoom del documento: utilizzare i pulsanti + e - per aumentare o diminuire lo zoom, o scegliere una dimensione dello zoom dal menu a discesa.

    PDF Zoom
  • Modalità a schermo intero o presentazione: fare clic sull'apposito pulsante per portare la visualizzazione del documento a schermo intero. Per uscire da questa modalità è sufficiente premere il tasto ESC.

    PDF Fullscreen
  • Stampa: premendo questo pulsante verrà visualizzata la finestra di dialogo di stampa.

    PDF Print
  • Download: fare clic sul pulsante Scarica questo documento per salvare il file sul computer o aprirlo con un visualizzatore PDF installato.

    PDF Download
  • Copia visualizzazione corrente: Fare clic col tasto destroTenere premuto il tasto Ctrl facendo clic su questo pulsante per copiare la visulizzazione corrente in un'altra scheda o in un'altra finestra.

    PDF Copy

Scorciatoie da tastiera per il visualizzatore PDF

Comando Scorciatoia
Pagina successiva N o K o
Pagina precedente P o J o
Aumenta zoom Ctrl + +Comando + +
Riduci zoom Ctrl + -Comando + -
Ripristina zoom Ctrl + 0Comando + 0
Ruota il documento in senso orario R
Ruota il documento in senso antiorario Maiusc + R

Risoluzione dei problemi relativi al visualizzatore di PDF

Alcuni file PDF non vengono correttamente visualizzati o sono vuoti

Con alcuni tipi di file PDF, PDF Viewer potrebbe presentare alcuni problemi nel disegnare caratteri, colori o l'intero contenuto di alcuni file PDF. Per visualizzare questi file:

  • Scaricare il file facendo clic sul pulsante di download (posto in alto a destra dell'intestazione della pagina) per aprirlo con il lettore di PDF installato sul computer.

Impossibile aprire file PDF

Alcune estensioni preposte al blocco degli script JavaScript potrebbero impedire il funzionamento del PDF Viewer. Occorre quindi disattivarle per consentire il corretto funzionamento del visualizzatore di PDF:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e successivamente su Componenti aggiuntiviDalla barra dei menu fare clic sul menu Strumenti e successivamente su Componenti aggiuntiviNella parte superiore della finestra di Firefox fare clic sul menu Strumenti e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi. Fare clic sul pulsante dei menu New Fx Menu e successivamente su Componenti aggiuntivi per aprire la scheda di gestione dei componenti aggiuntivi.

  2. Nella scheda di gestione dei componenti aggiuntivi, selezionare il pannello Estensioni.
  3. Selezionare ciascuna estensione di blocco JavaScript facendo clic sul pulsante Disattiva accanto ad essa.

Per ulteriori informazioni, leggere l'articolo Risoluzione dei problemi relativi a estensioni e temi.

Utilizzare un plugin per la lettura dei file PDF

Se non si ha intenzione di utilizzare PDF Viewer, è possibile affidarsi a plugin per la lettura dei PDF come Adobe Reader, Nitro PDF Reader o Sumatra PDFAdobe Reader, MozPlugger o KParts pluginSchubert|it PDF Browser Plugin per Mac OS X 10.6 e versioni successive.

Per utilizzare un plugin di visualizzazione PDF in luogo del visualizzatore PDF integrato:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Applicazioni.
  3. Cercare la voce Portable Document Format (PDF) nell'elenco e fare clic per selezionarlo.
  4. Fare clic sul menu a discesa nella colonna Azione per l'elemento selezionato e scegliere Usa <nome del lettore PDF> (in Firefox).

    adobe_plugin_win

Se i documenti PDF vengono scaricati invece di essere visualizzati, provare le seguenti soluzioni

Se i documenti PDF vengono scaricati invece di essere visualizzati, verificare le impostazioni

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Applicazioni.
  3. Cercare Adobe Acrobat Document (se si sta utilizzando Adobe Reader) o File PDF (per altri lettori PDF) nell'elenco e fare clic per selezionarlo.
  4. Fare clic sulla freccia nella colonna Azione per la voce per la voce selezionata e scegliere la voce Usa <nome del lettore di PDF> (in Firefox).

    adobe_plugin_win
    • Se la voce Usa <nome del lettore di PDF> (in Firefox) non è in elenco, leggere la sezione Ripristinare le azioni di download di seguito e successivamente ripetere i passi appena descritti.
  5. Fare clic su OK per chiudere la finestra delle opzioniFare clic su Chiudi per chiudere la finestra delle preferenzeChiudere la finestra delle preferenze.

Altre soluzioni

Ripristinare le azioni di download

  1. Aprire la cartella del profilo:

    Dal menu in alto nella finestra di Firefox, fare clic sul pulsante Firefox, spostarsi sul menu AiutoSulla barra dei menu, fare clic su AiutoDal menu in alto nella finestra di Firefox, fare clic su Aiuto e selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di aiuto Help-29 , quindi selezionare Risoluzione dei problemi. Verrà aperta la pagina di Informazioni per la risoluzione dei problemi in una nuova scheda.

  2. Nella sezione Informazioni di base, fare clic sul pulsante Mostra cartellaMostra nel FinderApri percorso. Verrà aperta una finestra con i filela cartella del profilo.
  3. Nota: nel caso in cui non sia possibile aprire o utilizzare Firefox, seguire le istruzioni contenute in Individuare il profilo senza avviare Firefox.

  4. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox e successivamente su Esci.Nella parte superiore della finestra di Firefox, fare clic sul menu File e successivamente su Esci.Sulla barra dei menu, fare clic sul menu Firefox e selezionare Esci da Firefox.Nella parte superiore della finestra di Firefox, fare clic sul menu File e selezionare Esci.

    Fare clic sul pulsante dei menu New Fx Menu e successivamente sul pulsante di chiusura Close 29

  5. Eliminare il file mimetypes.rdf.

Verificare le impostazioni dell'applicazione

Se il plugin per la lettura dei PDF è parte di un'applicazione per la lettura di documenti, verificare se in essa sono presenti opzioni per la configurazione del plugin.

  • Per Adobe Reader:
    1. Aprire Adobe Reader.
    2. Fare clic sul menu Modifica in alto a sinistra e selezionare Preferenze... per aprire la finestra delle Preferenze.
    3. A sinistra, nel menu Categorie, selezionare Internet.
    4. Controllare che la prima opzione, Visualizza PDF nel browser, sia attivata.
    5. Fare clic su OK per chiudere la finestra e quindi chiudere anche Adobe Reader.

Provare quindi a visualizzare un file PDF in Firefox: se viene aperto nella finestra del browser il problema è risolto; in caso contrario continuare a leggere.

Reinizializzare il database dei plugin

Seguire le istruzioni contenute in Reinizializzare il database dei plugin.

Questa operazione forzerà la ricostruzione del database dei plugin in Firefox. Provare quindi a visualizzare un file PDF in Firefox. Se viene aperto nella finestra del browser il problema è risolto. In caso contrario, proseguire con le istruzioni successive.

Reinstallare l'applicazione

Se il plugin per la lettura dei PDF è parte di un'applicazione per la lettura di documenti e i metodi precedenti non hanno sortito risultati, provare a disinstallare e reinstallare l'applicazione.

Infine, se ancora non si riescono a visualizzare i PDF in Firefox, leggere le istruzioni di seguito.

Ulteriori informazioni per Adobe Reader

Se nessuno di questi metodi dà un risultato positivo visitare la pagina di risoluzione dei problemi di Adobe per ulteriori istruzioni (in inglese).



Condividi questo articolo: http://mzl.la/MyRa61

È stato utile questo articolo?

Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.
Ottieni supporto per una diversa piattaforma:
Personalizza questo articolo

Firefox